summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2003-06-06 08:33:10 +0000
committerAndres Loeh <kosmikus@gentoo.org>2003-06-06 08:33:10 +0000
commit2c1d3f5610f4c12b391007bd02a8999acfdbfb14 (patch)
treeeba496c915f04e7fc98a3e4bb3b8acd8381639a7 /dev-haskell/haddock
parentxml2 USE flag used instead of xml USE flag (diff)
downloadgentoo-2-2c1d3f5610f4c12b391007bd02a8999acfdbfb14.tar.gz
gentoo-2-2c1d3f5610f4c12b391007bd02a8999acfdbfb14.tar.bz2
gentoo-2-2c1d3f5610f4c12b391007bd02a8999acfdbfb14.zip
fixed path setting in ebuild
Diffstat (limited to 'dev-haskell/haddock')
-rw-r--r--dev-haskell/haddock/Manifest2
-rw-r--r--dev-haskell/haddock/haddock-0.4.ebuild7
2 files changed, 6 insertions, 3 deletions
diff --git a/dev-haskell/haddock/Manifest b/dev-haskell/haddock/Manifest
index 17c281e7430b..287ab82dade4 100644
--- a/dev-haskell/haddock/Manifest
+++ b/dev-haskell/haddock/Manifest
@@ -1,3 +1,3 @@
-MD5 1475ede4d8a531bc9c81309a3bc07e87 haddock-0.4.ebuild 1845
+MD5 b32a17083e2beddb422fbc873e953d7c haddock-0.4.ebuild 1960
MD5 a73e3298b72b7ea07f4dee1b9b06efbd ChangeLog 650
MD5 345c00e86d5388d60c897e487987922a files/digest-haddock-0.4 67
diff --git a/dev-haskell/haddock/haddock-0.4.ebuild b/dev-haskell/haddock/haddock-0.4.ebuild
index 280b3ca3cd2e..182359c5e797 100644
--- a/dev-haskell/haddock/haddock-0.4.ebuild
+++ b/dev-haskell/haddock/haddock-0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/haddock-0.4.ebuild,v 1.2 2003/06/05 11:18:16 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/haddock-0.4.ebuild,v 1.3 2003/06/06 08:32:52 kosmikus Exp $
#
# USE variable summary:
# doc - Build extra documenation from DocBook sources,
@@ -28,10 +28,13 @@ DEPEND="virtual/ghc
RDEPEND=""
+# extend path to /opt/ghc/bin to guarantee that ghc-bin is found
+GHCPATH="${PATH}:/opt/ghc/bin"
+
src_compile() {
# unset SGML_CATALOG_FILES because documentation installation
# breaks otherwise ...
- SGML_CATALOG_FILES="" econf
+ PATH="${GHCPATH}" SGML_CATALOG_FILES="" econf
# using make because emake behaved strangely on my machine
make || die