summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2015-04-05 03:16:57 +0000
committerMark Wright <gienah@gentoo.org>2015-04-05 03:16:57 +0000
commit9cc9525bb40f4a791a32f6f470b61e0459805295 (patch)
tree19767ad088047a88245302db7d99afe06a2f0aae /dev-haskell/gtk
parentfixing init scripts for bug 511710 (diff)
downloadgentoo-2-9cc9525bb40f4a791a32f6f470b61e0459805295.tar.gz
gentoo-2-9cc9525bb40f4a791a32f6f470b61e0459805295.tar.bz2
gentoo-2-9cc9525bb40f4a791a32f6f470b61e0459805295.zip
Bump gtk to 0.13.6
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/gtk')
-rw-r--r--dev-haskell/gtk/ChangeLog7
-rw-r--r--dev-haskell/gtk/gtk-0.13.6.0.2.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/dev-haskell/gtk/ChangeLog b/dev-haskell/gtk/ChangeLog
index ee316da0660b..4ef18e7067ce 100644
--- a/dev-haskell/gtk/ChangeLog
+++ b/dev-haskell/gtk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/gtk
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk/ChangeLog,v 1.25 2015/03/11 09:31:42 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk/ChangeLog,v 1.26 2015/04/05 03:16:57 gienah Exp $
+
+*gtk-0.13.6.0.2 (05 Apr 2015)
+
+ 05 Apr 2015; Mark Wright <gienah@gentoo.org> +gtk-0.13.6.0.2.ebuild:
+ Bump gtk to 0.13.6
*gtk-0.13.4.0.2 (11 Mar 2015)
diff --git a/dev-haskell/gtk/gtk-0.13.6.0.2.ebuild b/dev-haskell/gtk/gtk-0.13.6.0.2.ebuild
new file mode 100644
index 000000000000..4110d927d354
--- /dev/null
+++ b/dev-haskell/gtk/gtk-0.13.6.0.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk/gtk-0.13.6.0.2.ebuild,v 1.1 2015/04/05 03:16:57 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+GTK_MAJ_VER="2"
+
+MY_PV="${PV%.0.*}"
+MY_P="${PN}-${MY_PV}"
+
+#nocabaldep is for the fancy cabal-detection feature at build-time
+CABAL_FEATURES="lib profile haddock hoogle hscolour nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the Gtk+ graphical user interface library"
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${MY_PV}/${MY_P}.tar.gz"
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2.1"
+SLOT="${GTK_MAJ_VER}/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples +fmode-binary +gio"
+
+RDEPEND=">=dev-haskell/cairo-0.13.0.0:=[profile?] <dev-haskell/cairo-0.14:=[profile?]
+ >=dev-haskell/glib-0.13.0.0:=[profile?] <dev-haskell/glib-0.14:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pango-0.13.0.0:=[profile?] <dev-haskell/pango-0.14:=[profile?]
+ >=dev-haskell/text-0.11.0.6:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ dev-libs/glib:2
+ x11-libs/gtk+:${GTK_MAJ_VER}
+ gio? ( >=dev-haskell/gio-0.13.0:=[profile?] <dev-haskell/gio-0.14:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/gtk2hs-buildtools-0.13.0.3:0=
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ base_src_prepare
+ # workaround for module order
+ cabal_chdeps \
+ 'other-modules:' 'exposed-modules:'
+}
+
+src_configure() {
+ # Upstream has this enabled, so we might as well force it enabled to be sure.
+ cabal_src_configure \
+ --flags=deprecated \
+ $(cabal_flag fmode-binary fmode-binary) \
+ $(cabal_flag gio have-gio) \
+ --flags=-have-quartz-gtk
+}