summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-05-13 15:40:18 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-05-13 15:40:18 +0000
commit3aecff210b54f8174705caa1b82087d1f6d1b80d (patch)
tree6f6cfcad6510edf76007fb9433be31c110962a6c /dev-haskell/gtk
parentMake AUTHOR a string in Makefile.PL (#415235) (diff)
downloadgentoo-2-3aecff210b54f8174705caa1b82087d1f6d1b80d.tar.gz
gentoo-2-3aecff210b54f8174705caa1b82087d1f6d1b80d.tar.bz2
gentoo-2-3aecff210b54f8174705caa1b82087d1f6d1b80d.zip
Version bump (ghc-7.4 support, bug #413229 by Alex)
(Portage version: 2.2.0_alpha101_p6/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/gtk')
-rw-r--r--dev-haskell/gtk/ChangeLog10
-rw-r--r--dev-haskell/gtk/files/gtk-0.12.3-glib-2.32.patch18
-rw-r--r--dev-haskell/gtk/gtk-0.12.3.ebuild40
3 files changed, 66 insertions, 2 deletions
diff --git a/dev-haskell/gtk/ChangeLog b/dev-haskell/gtk/ChangeLog
index 7459c48dd8a9..5eaa34472278 100644
--- a/dev-haskell/gtk/ChangeLog
+++ b/dev-haskell/gtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/gtk
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk/ChangeLog,v 1.3 2011/06/21 11:01:56 hwoarang Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk/ChangeLog,v 1.4 2012/05/13 15:40:18 slyfox Exp $
+
+*gtk-0.12.3 (13 May 2012)
+
+ 13 May 2012; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/gtk-0.12.3-glib-2.32.patch, +gtk-0.12.3.ebuild:
+ Version bump (ghc-7.4 support, bug #413229 by Alex)
21 Jun 2011; Markos Chandras <hwoarang@gentoo.org> gtk-0.12.0.ebuild:
Stable on amd64 wrt bug #314059
diff --git a/dev-haskell/gtk/files/gtk-0.12.3-glib-2.32.patch b/dev-haskell/gtk/files/gtk-0.12.3-glib-2.32.patch
new file mode 100644
index 000000000000..1f07c0737150
--- /dev/null
+++ b/dev-haskell/gtk/files/gtk-0.12.3-glib-2.32.patch
@@ -0,0 +1,18 @@
+fix build failure against recent glib-2.32
+
+In file included from Graphics/UI/Gtk/General/hsgthread.c:29:0:
+
+/usr/include/glib-2.0/glib/gthread.h:28:2:
+ ошибка: #error "Only <glib.h> can be included directly."
+diff --git a/Graphics/UI/Gtk/General/hsgthread.c b/Graphics/UI/Gtk/General/hsgthread.c
+index 5eaed46..6d20e73 100644
+--- a/Graphics/UI/Gtk/General/hsgthread.c
++++ b/Graphics/UI/Gtk/General/hsgthread.c
+@@ -26,7 +26,6 @@
+ */
+
+ #include <glib.h>
+-#include <glib/gthread.h>
+ #include <gdk/gdk.h>
+ #include "hsgthread.h"
+
diff --git a/dev-haskell/gtk/gtk-0.12.3.ebuild b/dev-haskell/gtk/gtk-0.12.3.ebuild
new file mode 100644
index 000000000000..5fdd3e635b18
--- /dev/null
+++ b/dev-haskell/gtk/gtk-0.12.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk/gtk-0.12.3.ebuild,v 1.1 2012/05/13 15:40:18 slyfox Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI=4
+
+#nocabaldep is for the fancy cabal-detection feature at build-time
+CABAL_FEATURES="lib profile haddock hscolour hoogle nocabaldep"
+inherit base haskell-cabal
+
+DESCRIPTION="Binding to the Gtk+ graphical user interface library."
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gio"
+
+RDEPEND="=dev-haskell/cairo-0.12*[profile?]
+ =dev-haskell/glib-0.12*[profile?]
+ dev-haskell/mtl[profile?]
+ =dev-haskell/pango-0.12*[profile?]
+ >=dev-lang/ghc-6.10.1
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ gio? ( =dev-haskell/gio-0.12*[profile?] )"
+DEPEND="${RDEPEND}
+ dev-haskell/gtk2hs-buildtools"
+
+PATCHES=("${FILESDIR}"/${P}-glib-2.32.patch)
+
+src_configure() {
+ # Upstream has this enabled, so we might as well force it enabled to be sure.
+ cabal_src_configure \
+ --flags=deprecated \
+ $(cabal_flag gio have-gio)
+}