summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2007-07-09 12:41:01 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2007-07-09 12:41:01 +0000
commit56dc4c7dfb458833d7f3c61ea6988bc5037b6e02 (patch)
tree5b7be4bdba43665dd6ea298e61f6d8c1748cd51a /dev-haskell/glut/glut-2.0.ebuild
parentKeyworded ~x86-fbsd (diff)
downloadgentoo-2-56dc4c7dfb458833d7f3c61ea6988bc5037b6e02.tar.gz
gentoo-2-56dc4c7dfb458833d7f3c61ea6988bc5037b6e02.tar.bz2
gentoo-2-56dc4c7dfb458833d7f3c61ea6988bc5037b6e02.zip
Initial versions.
(Portage version: 2.1.2.9)
Diffstat (limited to 'dev-haskell/glut/glut-2.0.ebuild')
-rw-r--r--dev-haskell/glut/glut-2.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-haskell/glut/glut-2.0.ebuild b/dev-haskell/glut/glut-2.0.ebuild
new file mode 100644
index 000000000000..a0ca9465f51e
--- /dev/null
+++ b/dev-haskell/glut/glut-2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/glut/glut-2.0.ebuild,v 1.1 2007/07/09 12:41:01 dcoutts Exp $
+
+inherit ghc-package
+
+DESCRIPTION="GLUT bindings for Haskell"
+HOMEPAGE="http://www.haskell.org/HOpenGL/"
+SRC_URI=""
+LICENSE="BSD"
+SLOT="0"
+
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="=dev-lang/ghc-6.4*"
+
+pkg_setup () {
+ ghc-package_pkg_setup
+ einfo "This library is already provided by ghc. This ebuild does nothing."
+}
+
+src_install () {
+ dodir "$(ghc-libdir)"
+ touch "${D}/$(ghc-libdir)/.${P}.ghc-updater"
+}