summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-12-14 11:44:19 +0000
committerMark Wright <gienah@gentoo.org>2014-12-14 11:44:19 +0000
commit57b06d264dfeff3e2aeb55ee77322722f0b90ff7 (patch)
treef01f690886b3bc95febfc5dc1a76590982e73d21 /dev-haskell/filestore
parentBump project-template to 0.1.4.2 (diff)
downloadgentoo-2-57b06d264dfeff3e2aeb55ee77322722f0b90ff7.tar.gz
gentoo-2-57b06d264dfeff3e2aeb55ee77322722f0b90ff7.tar.bz2
gentoo-2-57b06d264dfeff3e2aeb55ee77322722f0b90ff7.zip
Bump filestore to 0.6.0.4
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/filestore')
-rw-r--r--dev-haskell/filestore/ChangeLog7
-rw-r--r--dev-haskell/filestore/filestore-0.6.0.4.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-haskell/filestore/ChangeLog b/dev-haskell/filestore/ChangeLog
index a0ca43a664e1..5aa8d78d898d 100644
--- a/dev-haskell/filestore/ChangeLog
+++ b/dev-haskell/filestore/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/filestore
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/filestore/ChangeLog,v 1.5 2014/07/25 09:16:44 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/filestore/ChangeLog,v 1.6 2014/12/14 11:44:19 gienah Exp $
+
+*filestore-0.6.0.4 (14 Dec 2014)
+
+ 14 Dec 2014; Mark Wright <gienah@gentoo.org> +filestore-0.6.0.4.ebuild:
+ Bump filestore to 0.6.0.4
25 Jul 2014; Sergei Trofimovich <slyfox@gentoo.org> filestore-0.6.0.1.ebuild,
filestore-0.6.0.2.ebuild:
diff --git a/dev-haskell/filestore/filestore-0.6.0.4.ebuild b/dev-haskell/filestore/filestore-0.6.0.4.ebuild
new file mode 100644
index 000000000000..a73800e7824b
--- /dev/null
+++ b/dev-haskell/filestore/filestore-0.6.0.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/filestore/filestore-0.6.0.4.ebuild,v 1.1 2014/12/14 11:44:19 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Interface for versioning file stores"
+HOMEPAGE="http://hackage.haskell.org/package/filestore"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+maxcount"
+
+RESTRICT=test # one darcs test fails
+
+RDEPEND=">=dev-haskell/diff-0.2:=[profile?] <dev-haskell/diff-0.4:=[profile?]
+ >=dev-haskell/parsec-2:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/split-0.1:=[profile?] <dev-haskell/split-0.3:=[profile?]
+ >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-0.4:=[profile?]
+ >=dev-haskell/xml-1.3:=[profile?] <dev-haskell/xml-1.4:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.3
+ dev-haskell/mtl )
+"
+DEPEND+="
+ test? ( dev-vcs/darcs
+ dev-vcs/git
+ dev-vcs/mercurial
+ )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag maxcount maxcount)
+}
+
+src_test() {
+ export HOME=${T}/
+ git config --global user.email "git@src_test"
+ git config --global user.name "Mr. ${P} The Test"
+
+ haskell-cabal_src_test
+}