summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-09-13 06:00:08 +0000
committerMark Wright <gienah@gentoo.org>2013-09-13 06:00:08 +0000
commitae3dc766b67474d87b104795ccb6af47cd4969d3 (patch)
tree366b7920ad0487811d8eb1481fff002ecfb73cff /dev-haskell/crypto-pubkey
parentBump crypto-numbers to 0.2.1 (diff)
downloadgentoo-2-ae3dc766b67474d87b104795ccb6af47cd4969d3.tar.gz
gentoo-2-ae3dc766b67474d87b104795ccb6af47cd4969d3.tar.bz2
gentoo-2-ae3dc766b67474d87b104795ccb6af47cd4969d3.zip
Bump crypto-pubkey to 0.2.1
(Portage version: 2.2.3/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/crypto-pubkey')
-rw-r--r--dev-haskell/crypto-pubkey/ChangeLog8
-rw-r--r--dev-haskell/crypto-pubkey/crypto-pubkey-0.2.1.ebuild40
-rw-r--r--dev-haskell/crypto-pubkey/metadata.xml3
3 files changed, 50 insertions, 1 deletions
diff --git a/dev-haskell/crypto-pubkey/ChangeLog b/dev-haskell/crypto-pubkey/ChangeLog
index 7507c050e8ec..0778056622ad 100644
--- a/dev-haskell/crypto-pubkey/ChangeLog
+++ b/dev-haskell/crypto-pubkey/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/crypto-pubkey
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/crypto-pubkey/ChangeLog,v 1.2 2013/09/10 03:32:44 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/crypto-pubkey/ChangeLog,v 1.3 2013/09/13 06:00:08 gienah Exp $
+
+*crypto-pubkey-0.2.1 (13 Sep 2013)
+
+ 13 Sep 2013; Mark Wright <gienah@gentoo.org> +crypto-pubkey-0.2.1.ebuild,
+ metadata.xml:
+ Bump crypto-pubkey to 0.2.1
10 Sep 2013; Patrick Lauer <patrick@gentoo.org> crypto-pubkey-0.1.4.ebuild:
Whitespace
diff --git a/dev-haskell/crypto-pubkey/crypto-pubkey-0.2.1.ebuild b/dev-haskell/crypto-pubkey/crypto-pubkey-0.2.1.ebuild
new file mode 100644
index 000000000000..651e52dbbcad
--- /dev/null
+++ b/dev-haskell/crypto-pubkey/crypto-pubkey-0.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/crypto-pubkey/crypto-pubkey-0.2.1.ebuild,v 1.1 2013/09/13 06:00:08 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Public Key cryptography"
+HOMEPAGE="http://github.com/vincenthz/hs-crypto-pubkey"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="benchmark"
+
+RDEPEND="dev-haskell/byteable:=[profile?]
+ >=dev-haskell/crypto-numbers-0.2:=[profile?]
+ >=dev-haskell/crypto-pubkey-types-0.4:=[profile?] <dev-haskell/crypto-pubkey-types-0.5:=[profile?]
+ >=dev-haskell/crypto-random-0.0:=[profile?] <dev-haskell/crypto-random-0.1:=[profile?]
+ >=dev-haskell/cryptohash-0.9.1:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ >=dev-haskell/quickcheck-2
+ >=dev-haskell/test-framework-0.3.3
+ dev-haskell/test-framework-hunit
+ >=dev-haskell/test-framework-quickcheck2-0.2.9 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag benchmark benchmark)
+}
diff --git a/dev-haskell/crypto-pubkey/metadata.xml b/dev-haskell/crypto-pubkey/metadata.xml
index a2bea8a570e2..5c6a186fdd0c 100644
--- a/dev-haskell/crypto-pubkey/metadata.xml
+++ b/dev-haskell/crypto-pubkey/metadata.xml
@@ -12,4 +12,7 @@
Also have primitive support for Diffie Hellman, and ElGamal encryption
</longdescription>
+ <use>
+ <flag name='benchmark'>Build benchmarks.</flag>
+ </use>
</pkgmetadata>