summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2010-06-14 06:21:58 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2010-06-14 06:21:58 +0000
commit3cf26ca6a05b1ec8febffe3efd440ea1ceeb4c61 (patch)
tree6c16fd2ae0b88485f1ccc12bfc273a626df708d3 /dev-haskell/c2hs
parentVersion bump reported by few in #gentoo-bugs. Took over maintenance. (diff)
downloadgentoo-2-3cf26ca6a05b1ec8febffe3efd440ea1ceeb4c61.tar.gz
gentoo-2-3cf26ca6a05b1ec8febffe3efd440ea1ceeb4c61.tar.bz2
gentoo-2-3cf26ca6a05b1ec8febffe3efd440ea1ceeb4c61.zip
Version bump dev-haskell/c2hs, now supports ghc 6.12.3.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/c2hs')
-rw-r--r--dev-haskell/c2hs/ChangeLog7
-rw-r--r--dev-haskell/c2hs/c2hs-0.16.2.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-haskell/c2hs/ChangeLog b/dev-haskell/c2hs/ChangeLog
index c17b572cc927..bb06b13cb942 100644
--- a/dev-haskell/c2hs/ChangeLog
+++ b/dev-haskell/c2hs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/c2hs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/c2hs/ChangeLog,v 1.31 2010/05/31 18:41:51 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/c2hs/ChangeLog,v 1.32 2010/06/14 06:21:58 kolmodin Exp $
+
+*c2hs-0.16.2 (14 Jun 2010)
+
+ 14 Jun 2010; Lennart Kolmodin <kolmodin@gentoo.org> +c2hs-0.16.2.ebuild:
+ Version bump. Supports GHC 6.12.3.
31 May 2010; Joseph Jezak <josejx@gentoo.org> c2hs-0.16.0.ebuild:
Marked ~ppc/~ppc64 for bug #306311.
diff --git a/dev-haskell/c2hs/c2hs-0.16.2.ebuild b/dev-haskell/c2hs/c2hs-0.16.2.ebuild
new file mode 100644
index 000000000000..1ee5201670e3
--- /dev/null
+++ b/dev-haskell/c2hs/c2hs-0.16.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/c2hs/c2hs-0.16.2.ebuild,v 1.1 2010/06/14 06:21:58 kolmodin Exp $
+
+CABAL_FEATURES="bin"
+inherit haskell-cabal
+
+DESCRIPTION="C->Haskell FFI tool that gives some cross-language type safety"
+HOMEPAGE="http://www.cse.unsw.edu.au/~chak/haskell/c2hs/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND=">=dev-lang/ghc-6.6.1
+ >=dev-haskell/cabal-1.6
+ >=dev-haskell/language-c-0.3.1.1
+ doc? ( ~app-text/docbook-xml-dtd-4.2
+ app-text/docbook-xsl-stylesheets
+ >=dev-libs/libxslt-1.1.2 )"
+RDEPEND="dev-libs/gmp"
+
+
+src_compile() {
+ cabal_src_compile
+
+ if use doc; then
+ emake -C doc
+ fi
+}
+
+src_install() {
+ cabal_src_install
+
+ doman "${S}/doc/man1/c2hs.1"
+
+ if use doc; then
+ dohtml "${S}/doc/users_guide/"*
+ fi
+}