summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-02-03 15:54:44 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-02-03 15:54:44 +0000
commitf826932e4b8095ff3573b4d08f80835df7873d9c (patch)
treebdf66b75559df81f83a881c6cd38b8c0ce1d59cd /dev-games
parentInitial import from sunrise, thanks to Christian Helbling and all contributor... (diff)
downloadgentoo-2-f826932e4b8095ff3573b4d08f80835df7873d9c.tar.gz
gentoo-2-f826932e4b8095ff3573b4d08f80835df7873d9c.tar.bz2
gentoo-2-f826932e4b8095ff3573b4d08f80835df7873d9c.zip
Fix build after resolving --as-needed. bug #257455
(Portage version: 2.1.6.4/cvs/Linux 2.6.27-gentoo-r8 x86_64)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/guichan/ChangeLog6
-rw-r--r--dev-games/guichan/files/guichan-0.8.1-as-needed.patch13
-rw-r--r--dev-games/guichan/guichan-0.8.1.ebuild11
3 files changed, 20 insertions, 10 deletions
diff --git a/dev-games/guichan/ChangeLog b/dev-games/guichan/ChangeLog
index 0ce6eb771cf0..e1716f2f03c0 100644
--- a/dev-games/guichan/ChangeLog
+++ b/dev-games/guichan/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-games/guichan
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/ChangeLog,v 1.16 2009/02/03 03:56:27 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/ChangeLog,v 1.17 2009/02/03 15:54:43 tupone Exp $
+
+ 03 Feb 2009; Alfredo Tupone <tupone@gentoo.org>
+ files/guichan-0.8.1-as-needed.patch, guichan-0.8.1.ebuild:
+ Fix build after resolving --as-needed. bug #257455 by franzec05@gmail.com
03 Feb 2009; Michael Sterrett <mr_bones_@gentoo.org> guichan-0.8.1.ebuild:
Commented out the patch until the as-needed stuff is fixed (bug #257455)
diff --git a/dev-games/guichan/files/guichan-0.8.1-as-needed.patch b/dev-games/guichan/files/guichan-0.8.1-as-needed.patch
index 24f1c993bb96..a61d4b1bc7de 100644
--- a/dev-games/guichan/files/guichan-0.8.1-as-needed.patch
+++ b/dev-games/guichan/files/guichan-0.8.1-as-needed.patch
@@ -1,6 +1,5 @@
-diff -ru guichan-0.8.1.orig/src/sdl/Makefile.am guichan-0.8.1/src/sdl/Makefile.am
---- guichan-0.8.1.orig/src/sdl/Makefile.am 2008-04-12 07:57:57.000000000 -0400
-+++ guichan-0.8.1/src/sdl/Makefile.am 2009-01-28 08:53:53.000000000 -0500
+--- src/sdl/Makefile.am.old 2008-04-12 07:57:57.000000000 -0400
++++ src/sdl/Makefile.am 2009-01-28 08:53:53.000000000 -0500
@@ -6,6 +6,8 @@
libguichan_sdl_la_LDFLAGS = -no-undefined -release $(LT_RELEASE) -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
@@ -10,3 +9,11 @@ diff -ru guichan-0.8.1.orig/src/sdl/Makefile.am guichan-0.8.1/src/sdl/Makefile.a
libguichan_sdl_la_SOURCES = \
sdl.cpp \
sdlgraphics.cpp \
+--- src/Makefile.am.old 2009-02-03 16:41:09.000000000 +0100
++++ src/Makefile.am 2009-02-03 16:41:20.000000000 +0100
+@@ -1,4 +1,4 @@
+-SUBDIRS = widgets @GUICHAN_EXTRADIRS@ hge openlayer contrib
++SUBDIRS = widgets . @GUICHAN_EXTRADIRS@ hge openlayer contrib
+
+ INCLUDES = -I$(top_srcdir)/include
+
diff --git a/dev-games/guichan/guichan-0.8.1.ebuild b/dev-games/guichan/guichan-0.8.1.ebuild
index 4ab749cbcdb8..48f755ebd964 100644
--- a/dev-games/guichan/guichan-0.8.1.ebuild
+++ b/dev-games/guichan/guichan-0.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/guichan-0.8.1.ebuild,v 1.4 2009/02/03 03:56:27 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/guichan-0.8.1.ebuild,v 1.5 2009/02/03 15:54:43 tupone Exp $
EAPI=2
inherit eutils autotools
@@ -21,11 +21,10 @@ DEPEND="allegro? ( media-libs/allegro )
media-libs/sdl-image
)"
-# Commented out until the as-needed stuff is fixed (bug #257455)
-#src_prepare() {
- #epatch "${FILESDIR}"/${P}-as-needed.patch
- #eautoreconf
-#}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ eautoreconf
+}
src_configure() {
econf \