summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-01-18 21:57:16 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-01-18 21:57:16 +0000
commited50d07c6dffb4c6c386b282213eeab30386c354 (patch)
treeb0cd6c35d2968a6a405dc9fed2eb7a1caed2992c /dev-games
parentadd doc useflag (diff)
downloadgentoo-2-ed50d07c6dffb4c6c386b282213eeab30386c354.tar.gz
gentoo-2-ed50d07c6dffb4c6c386b282213eeab30386c354.tar.bz2
gentoo-2-ed50d07c6dffb4c6c386b282213eeab30386c354.zip
version bump
(Portage version: 2.2.0_alpha153/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/cegui/ChangeLog7
-rw-r--r--dev-games/cegui/cegui-0.7.9.ebuild158
2 files changed, 164 insertions, 1 deletions
diff --git a/dev-games/cegui/ChangeLog b/dev-games/cegui/ChangeLog
index 91ed339a9517..4ea22976a108 100644
--- a/dev-games/cegui/ChangeLog
+++ b/dev-games/cegui/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-games/cegui
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/cegui/ChangeLog,v 1.56 2013/01/18 20:10:34 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/cegui/ChangeLog,v 1.57 2013/01/18 21:57:16 hasufell Exp $
+
+*cegui-0.7.9 (18 Jan 2013)
+
+ 18 Jan 2013; Julian Ospald <hasufell@gentoo.org> +cegui-0.7.9.ebuild:
+ version bump
18 Jan 2013; Julian Ospald <hasufell@gentoo.org> cegui-0.7.7-r1.ebuild:
fix static-libs build
diff --git a/dev-games/cegui/cegui-0.7.9.ebuild b/dev-games/cegui/cegui-0.7.9.ebuild
new file mode 100644
index 000000000000..ccb8680431bd
--- /dev/null
+++ b/dev-games/cegui/cegui-0.7.9.ebuild
@@ -0,0 +1,158 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/cegui/cegui-0.7.9.ebuild,v 1.1 2013/01/18 21:57:16 hasufell Exp $
+
+EAPI=4
+inherit eutils
+
+MY_P=CEGUI-${PV}
+MY_D=CEGUI-DOCS-${PV}
+DESCRIPTION="Crazy Eddie's GUI System"
+HOMEPAGE="http://www.cegui.org.uk/"
+SRC_URI="mirror://sourceforge/crayzedsgui/${MY_P}.tar.gz
+ doc? ( mirror://sourceforge/crayzedsgui/${MY_D}.tar.gz )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 -ppc ~x86"
+IUSE="bidi debug devil doc examples expat gtk irrlicht lua ogre opengl pcre static-libs tinyxml truetype xerces-c +xml zip"
+REQUIRED_USE="|| ( expat tinyxml xerces-c xml )" # bug 362223
+
+RDEPEND="bidi? ( dev-libs/fribidi )
+ devil? ( media-libs/devil )
+ expat? ( dev-libs/expat )
+ truetype? ( media-libs/freetype:2 )
+ irrlicht? ( dev-games/irrlicht )
+ lua? (
+ dev-lang/lua
+ dev-lua/toluapp
+ )
+ ogre? ( >=dev-games/ogre-1.7 )
+ opengl? (
+ virtual/opengl
+ virtual/glu
+ media-libs/freeglut
+ media-libs/glew
+ )
+ pcre? ( dev-libs/libpcre )
+ tinyxml? ( dev-libs/tinyxml )
+ xerces-c? ( dev-libs/xerces-c )
+ xml? ( dev-libs/libxml2 )
+ zip? ( sys-libs/zlib[minizip] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+S=${WORKDIR}/${MY_P}
+S2=${WORKDIR}/${MY_P}_static
+
+src_prepare() {
+ # use minizip from zlib rather than local code
+ if use zip ; then
+ sed -i \
+ -e '/CEGUI_BUILD_MINIZIP_RESOURCE_PROVIDER_TRUE/{
+ s:minizip/ioapi.cpp minizip/unzip.cpp::;
+ s:libCEGUIBase@cegui_bsfx@_la-ioapi.lo::;
+ s:libCEGUIBase@cegui_bsfx@_la-unzip.lo::
+ }' \
+ -e '/^ZLIB_LIBS/s:=.*:= -lminizip:' \
+ cegui/src/Makefile.in || die
+ fi
+ rm -rf cegui/src/minizip
+
+ if use examples ; then
+ cp -r Samples Samples.clean
+ rm -f $(find Samples.clean -name 'Makefile*')
+ fi
+
+ if use static-libs ; then
+ cp -a "${S}" "${S2}" || die
+ fi
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable bidi bidirectional-text)
+ $(use_enable debug)
+ $(use_enable devil)
+ $(use_enable examples samples)
+ $(use_enable expat)
+ $(use_enable truetype freetype)
+ $(use_enable irrlicht irrlicht-renderer)
+ $(use_enable lua lua-module)
+ $(use_enable lua toluacegui)
+ --enable-external-toluapp
+ $(use_enable ogre ogre-renderer)
+ $(use_enable opengl opengl-renderer)
+ --enable-external-glew
+ $(use_enable pcre)
+ $(use_enable tinyxml)
+ --enable-external-tinyxml
+ $(use_enable xerces-c)
+ $(use_enable xml libxml)
+ $(use_enable zip minizip-resource-provider)
+ --enable-null-renderer
+ --enable-stb
+ --enable-tga
+ --disable-corona
+ --disable-dependency-tracking
+ --disable-freeimage
+ --disable-rapidxml
+ --disable-samples
+ --disable-silly
+ $(use_with gtk gtk2)
+ )
+
+ econf \
+ "${myconf[@]}" \
+ --disable-static \
+ --enable-shared
+
+ if use static-libs ; then
+ cd "${S2}" || die
+ econf \
+ "${myconf[@]}" \
+ --enable-static \
+ --disable-shared
+ fi
+
+ # we are doing a double build here cause
+ # the build system does not permit
+ # "--enable-static --enable-shared"
+}
+
+src_compile() {
+ default
+
+ if use static-libs ; then
+ emake -C "${S2}"
+ fi
+}
+
+src_install() {
+ local i
+ default
+
+ if use doc ; then
+ emake html || die
+ dohtml -r doc/doxygen/html/* || die
+ fi
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/Samples
+ doins -r Samples.clean/* || die
+ fi
+
+ if use static-libs ; then
+ find "${S2}" -name "*CEGUI*.a" -exec dolib.a '{}' \;
+
+ # fix/merge .la files
+ for i in `find "${D}" -name "*.la"` ; do
+ sed \
+ -e "s/old_library=''/old_library='$(basename ${i%.la}).a'/" \
+ -i ${i} || die "fixing .la files failed"
+ done
+ else
+ # remove .la files
+ prune_libtool_files --all
+ fi
+}