summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2010-04-07 01:16:06 +0000
committerTristan Heaven <nyhm@gentoo.org>2010-04-07 01:16:06 +0000
commite90299064dfd7efd0e9632097e8d13d080816c14 (patch)
tree04bdcc47877c02969f4da5a3bd057bafc26b3109 /dev-games
parentKeyword ~x86-fbsd. (diff)
downloadgentoo-2-e90299064dfd7efd0e9632097e8d13d080816c14.tar.gz
gentoo-2-e90299064dfd7efd0e9632097e8d13d080816c14.tar.bz2
gentoo-2-e90299064dfd7efd0e9632097e8d13d080816c14.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/guichan/ChangeLog8
-rw-r--r--dev-games/guichan/files/guichan-0.8.2-as-needed.patch19
-rw-r--r--dev-games/guichan/guichan-0.8.2.ebuild41
3 files changed, 67 insertions, 1 deletions
diff --git a/dev-games/guichan/ChangeLog b/dev-games/guichan/ChangeLog
index 47188494ab43..89d517f96fad 100644
--- a/dev-games/guichan/ChangeLog
+++ b/dev-games/guichan/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-games/guichan
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/ChangeLog,v 1.19 2010/02/10 16:03:13 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/ChangeLog,v 1.20 2010/04/07 01:16:05 nyhm Exp $
+
+*guichan-0.8.2 (07 Apr 2010)
+
+ 07 Apr 2010; Tristan Heaven <nyhm@gentoo.org> +guichan-0.8.2.ebuild,
+ +files/guichan-0.8.2-as-needed.patch:
+ Version bump
10 Feb 2010; Joseph Jezak <josejx@gentoo.org> guichan-0.8.1.ebuild:
Marked ppc stable for bug #294537.
diff --git a/dev-games/guichan/files/guichan-0.8.2-as-needed.patch b/dev-games/guichan/files/guichan-0.8.2-as-needed.patch
new file mode 100644
index 000000000000..79eb563c0f8d
--- /dev/null
+++ b/dev-games/guichan/files/guichan-0.8.2-as-needed.patch
@@ -0,0 +1,19 @@
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -1,4 +1,4 @@
+-SUBDIRS = widgets @GUICHAN_EXTRADIRS@ hge openlayer contrib
++SUBDIRS = widgets . @GUICHAN_EXTRADIRS@ hge openlayer contrib
+
+ INCLUDES = -I$(top_srcdir)/include
+
+--- src/sdl/Makefile.am
++++ src/sdl/Makefile.am
+@@ -6,6 +6,8 @@
+
+ libguichan_sdl_la_LDFLAGS = -no-undefined -release $(LT_RELEASE) -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
+
++libguichan_sdl_la_LIBADD = -lSDL_image -L$(top_srcdir)/src -lguichan
++
+ libguichan_sdl_la_SOURCES = \
+ sdl.cpp \
+ sdlgraphics.cpp \
diff --git a/dev-games/guichan/guichan-0.8.2.ebuild b/dev-games/guichan/guichan-0.8.2.ebuild
new file mode 100644
index 000000000000..3a0b1398db5f
--- /dev/null
+++ b/dev-games/guichan/guichan-0.8.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/guichan-0.8.2.ebuild,v 1.1 2010/04/07 01:16:05 nyhm Exp $
+
+EAPI=2
+inherit eutils autotools
+
+DESCRIPTION="a portable C++ GUI library designed for games using Allegro, SDL and/or OpenGL"
+HOMEPAGE="http://guichan.sourceforge.net/"
+SRC_URI="http://guichan.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="allegro opengl sdl"
+
+DEPEND="allegro? ( media-libs/allegro )
+ opengl? ( virtual/opengl )
+ sdl? (
+ media-libs/libsdl
+ media-libs/sdl-image
+ )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable allegro) \
+ $(use_enable opengl) \
+ $(use_enable sdl) \
+ $(use_enable sdl sdlimage)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}