summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-04-30 20:03:31 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-04-30 20:03:31 +0000
commitd799de6e6d8008bceabd6d2795abc618afbf1008 (patch)
tree7ba38ce204d169c728dde57930c752317a9c813d /dev-games
parentMask blas/lapack USE flags on MIPS. (diff)
downloadgentoo-2-d799de6e6d8008bceabd6d2795abc618afbf1008.tar.gz
gentoo-2-d799de6e6d8008bceabd6d2795abc618afbf1008.tar.bz2
gentoo-2-d799de6e6d8008bceabd6d2795abc618afbf1008.zip
Version bump, bug #214860
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/clanlib/ChangeLog11
-rw-r--r--dev-games/clanlib/clanlib-0.8.1.ebuild74
-rw-r--r--dev-games/clanlib/files/clanlib-0.8.1-gcc43.patch28
-rw-r--r--dev-games/clanlib/files/clanlib-0.8.1-ndebug.patch21
4 files changed, 132 insertions, 2 deletions
diff --git a/dev-games/clanlib/ChangeLog b/dev-games/clanlib/ChangeLog
index 5565589b9ae3..aab6e3e611bb 100644
--- a/dev-games/clanlib/ChangeLog
+++ b/dev-games/clanlib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-games/clanlib
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/ChangeLog,v 1.40 2007/10/29 22:07:43 mr_bones_ Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/ChangeLog,v 1.41 2008/04/30 20:03:30 nyhm Exp $
+
+*clanlib-0.8.1 (30 Apr 2008)
+
+ 30 Apr 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/clanlib-0.8.1-gcc43.patch, +files/clanlib-0.8.1-ndebug.patch,
+ +clanlib-0.8.1.ebuild:
+ Version bump, bug #214860
29 Oct 2007; Michael Sterrett <mr_bones_@gentoo.org>
+files/clanlib-0.7.8-ndebug.patch, +files/clanlib-0.8.0-ndebug.patch,
diff --git a/dev-games/clanlib/clanlib-0.8.1.ebuild b/dev-games/clanlib/clanlib-0.8.1.ebuild
new file mode 100644
index 000000000000..cd36ffab9080
--- /dev/null
+++ b/dev-games/clanlib/clanlib-0.8.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/clanlib-0.8.1.ebuild,v 1.1 2008/04/30 20:03:30 nyhm Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="multi-platform game development library"
+HOMEPAGE="http://www.clanlib.org/"
+SRC_URI="http://clanlib.org/download/releases-${PV:0:3}/ClanLib-${PV}.tgz"
+
+LICENSE="ZLIB"
+SLOT="0.8"
+KEYWORDS="~amd64 ~x86" #not big endian safe #82779
+IUSE="opengl sdl vorbis doc mikmod ipv6"
+
+# opengl keyword does not drop the GL/GLU requirement.
+# Autoconf files need to be fixed
+RDEPEND="media-libs/libpng
+ media-libs/jpeg
+ virtual/opengl
+ virtual/glu
+ sdl? (
+ media-libs/libsdl
+ media-libs/sdl-gfx
+ )
+ x11-libs/libXt
+ x11-libs/libXmu
+ x11-libs/libXxf86vm
+ mikmod? ( media-libs/libmikmod )
+ vorbis? ( media-libs/libvorbis )"
+DEPEND="${RDEPEND}
+ x11-proto/xf86vidmodeproto"
+
+S=${WORKDIR}/ClanLib-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch \
+ "${FILESDIR}"/${P}-ndebug.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
+}
+
+src_compile() {
+ #clanSound only controls mikmod/vorbis so there's
+ # no need to pass --{en,dis}able-clanSound ...
+ #clanDisplay only controls X, SDL, OpenGL plugins
+ # so no need to pass --{en,dis}able-clanDisplay
+ # also same reason why we don't have to use clanGUI
+ econf \
+ --enable-dyn \
+ --enable-clanNetwork \
+ --disable-dependency-tracking \
+ $(use_enable x86 asm386) \
+ $(use_enable doc docs) \
+ $(use_enable opengl clanGL) \
+ $(use_enable sdl clanSDL) \
+ $(use_enable vorbis clanVorbis) \
+ $(use_enable mikmod clanMikMod) \
+ $(use_enable ipv6 getaddr) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ if use doc ; then
+ dodir /usr/share/doc/${PF}/html
+ mv "${D}"/usr/share/doc/clanlib/* "${D}"/usr/share/doc/${PF}/html/ || die
+ rm -rf "${D}"/usr/share/doc/clanlib
+ cp -r Examples Resources "${D}"/usr/share/doc/${PF}/ || die
+ fi
+ dodoc CODING_STYLE CREDITS NEWS PATCHES README* INSTALL.linux
+}
diff --git a/dev-games/clanlib/files/clanlib-0.8.1-gcc43.patch b/dev-games/clanlib/files/clanlib-0.8.1-gcc43.patch
new file mode 100644
index 000000000000..ca1d898ce5ab
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-0.8.1-gcc43.patch
@@ -0,0 +1,28 @@
+--- Sources/GL/opengl.cpp
++++ Sources/GL/opengl.cpp
+@@ -51,6 +51,8 @@
+ #endif
+ #endif
+
++#include <cstring>
++
+ std::vector<std::string> CL_OpenGL::m_ignored_gl_extension;
+
+ CL_ProcAddress *CL_OpenGL::get_proc_address(const std::string& function_name)
+@@ -414,4 +416,4 @@
+ #endif
+
+ m_ignored_gl_extension.push_back(extension_name);
+-}
+\ No newline at end of file
++}
+--- Sources/Network/Socket/ip_address_getsock.cpp
++++ Sources/Network/Socket/ip_address_getsock.cpp
+@@ -40,6 +40,7 @@
+ #include "ip_address_getsock.h"
+
+ #include <cstdlib>
++#include <cstring>
+
+ #ifndef WIN32
+ #include <sys/socket.h>
diff --git a/dev-games/clanlib/files/clanlib-0.8.1-ndebug.patch b/dev-games/clanlib/files/clanlib-0.8.1-ndebug.patch
new file mode 100644
index 000000000000..e41bae1a3296
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-0.8.1-ndebug.patch
@@ -0,0 +1,21 @@
+Patch for clanlib-0.7.8-r2 Bug 154513:
+
+Signal handler deinit() was not declared.
+
+This leads to a compilation failure when a release version
+rather than a debug version is built (-DNDEBUG).
+
+This patch adds the missing declaration, thus make the
+file compile with or without -DNDEBUG.
+
+diff -Naur clanlib-0.7.8-r2.orig/work/ClanLib-0.7.8/Sources/Core/System/Unix/init_linux.cpp clanlib-0.7.8-r2/work/ClanLib-0.7.8/Sources/Core/System/Unix/init_linux.cpp
+--- clanlib-0.7.8-r2.orig/work/ClanLib-0.7.8/Sources/Core/System/Unix/init_linux.cpp 2003-09-19 10:33:02.000000000 +0000
++++ clanlib-0.7.8-r2/work/ClanLib-0.7.8/Sources/Core/System/Unix/init_linux.cpp 2007-10-26 13:36:39.000000000 +0000
+@@ -52,6 +52,7 @@
+ _begin_time = (long) tv.tv_sec*(long) 1000+(long) tv.tv_usec/(long) 1000;
+
+ #ifdef NDEBUG
++ sighandler_t deinit;
+ signal(SIGSEGV, deinit);
+ #endif
+ }