summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-04-14 11:36:12 +0000
committerDavid Holm <dholm@gentoo.org>2004-04-14 11:36:12 +0000
commitcf535516acc6576b9badb45562181ac0c099009b (patch)
tree8917d1558f012928e1566c42778a0d05316e68e4 /dev-games
parentNumerous small fixes, see ChangeLogs for details. (Manifest recommit) (diff)
downloadgentoo-2-cf535516acc6576b9badb45562181ac0c099009b.tar.gz
gentoo-2-cf535516acc6576b9badb45562181ac0c099009b.tar.bz2
gentoo-2-cf535516acc6576b9badb45562181ac0c099009b.zip
Added support for architectures that do not have nvidia-cg-toolkit
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/ogre/ChangeLog6
-rw-r--r--dev-games/ogre/files/0.13.1-nocg.patch30
-rw-r--r--dev-games/ogre/ogre-0.13.1.ebuild23
3 files changed, 55 insertions, 4 deletions
diff --git a/dev-games/ogre/ChangeLog b/dev-games/ogre/ChangeLog
index 63a25ad9c740..6097c771ff2e 100644
--- a/dev-games/ogre/ChangeLog
+++ b/dev-games/ogre/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-games/ogre
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ChangeLog,v 1.8 2004/04/02 21:24:45 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ChangeLog,v 1.9 2004/04/14 11:36:12 dholm Exp $
+
+ 14 Apr 2004; David Holm <dholm@gentoo.org> ogre-0.13.1.ebuild,
+ files/0.13.1-nocg.patch:
+ Added a patch that removes nVidia-Cg support on unsupported archs.
02 Apr 2004; Michael Sterrett <mr_bones_@gentoo.org> ogre-0.13.1.ebuild:
media-gfx/nvidia-cg-toolkit changed versioning schemes
diff --git a/dev-games/ogre/files/0.13.1-nocg.patch b/dev-games/ogre/files/0.13.1-nocg.patch
new file mode 100644
index 000000000000..463dce704339
--- /dev/null
+++ b/dev-games/ogre/files/0.13.1-nocg.patch
@@ -0,0 +1,30 @@
+--- configure.in.orig 2004-04-14 12:04:49.000000000 +0200
++++ configure.in 2004-04-14 12:05:43.000000000 +0200
+@@ -44,12 +44,6 @@
+ ****************************************************************]))
+ AC_CHECK_LIB(ILU, iluFlipImage)
+ AC_CHECK_LIB(pthread, pthread_create)
+-AC_CHECK_LIB(Cg, cgCreateProgram,,AC_MSG_ERROR([
+-****************************************************************
+-* You do not have the nVidia Cg libraries installed. *
+-* Go to http://developer.nvidia.com/object/cg_toolkit.html *
+-* (Click on Cg_Linux.tar.gz). *
+-****************************************************************]))
+ AC_CHECK_FUNC(snprintf, AC_DEFINE(HAVE_SNPRINTF,,snprintf))
+ AC_CHECK_FUNC(vsnprintf, AC_DEFINE(HAVE_VSNPRINTF,,vsnprintf))
+
+@@ -94,9 +88,6 @@
+ PlugIns/BSPSceneManager/Makefile \
+ PlugIns/BSPSceneManager/src/Makefile \
+ PlugIns/BSPSceneManager/include/Makefile \
+- PlugIns/CgProgramManager/Makefile \
+- PlugIns/CgProgramManager/src/Makefile \
+- PlugIns/CgProgramManager/include/Makefile \
+ PlugIns/FileSystem/Makefile \
+ PlugIns/FileSystem/src/Makefile \
+ PlugIns/FileSystem/include/Makefile \
+--- PlugIns/Makefile.am.orig 2004-04-14 12:05:54.000000000 +0200
++++ PlugIns/Makefile.am 2004-04-14 12:06:03.000000000 +0200
+@@ -1 +1 @@
+-SUBDIRS = BSPSceneManager CgProgramManager FileSystem ParticleFX OctreeSceneManager GuiElements NatureSceneManager
++SUBDIRS = BSPSceneManager FileSystem ParticleFX OctreeSceneManager GuiElements NatureSceneManager
diff --git a/dev-games/ogre/ogre-0.13.1.ebuild b/dev-games/ogre/ogre-0.13.1.ebuild
index 82b0ba3b5296..5c2fdf098b8e 100644
--- a/dev-games/ogre/ogre-0.13.1.ebuild
+++ b/dev-games/ogre/ogre-0.13.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ogre-0.13.1.ebuild,v 1.2 2004/04/02 21:24:45 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ogre-0.13.1.ebuild,v 1.3 2004/04/14 11:36:12 dholm Exp $
+
+inherit eutils
DESCRIPTION="Object-oriented Graphics Rendering Engine"
HOMEPAGE="http://www.ogre3d.org/"
@@ -8,7 +10,7 @@ SRC_URI="mirror://sourceforge/ogre/${PN}-linux_osx-v${PV//./-}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~x86 ~ppc"
IUSE="doc gtk"
RDEPEND="virtual/opengl
@@ -21,12 +23,27 @@ RDEPEND="virtual/opengl
)
sys-libs/zlib"
DEPEND="${RDEPEND}
- >=media-gfx/nvidia-cg-toolkit-1.2
+ x86? || amd64? ( >=media-gfx/nvidia-cg-toolkit-1.2 )
>=sys-apps/sed-4
|| ( dev-libs/STLport >=sys-devel/gcc-3.0 )"
S=${WORKDIR}/ogrenew
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ case "${ARCH}" in
+ x86 | amd64)
+ ;;
+ *)
+ einfo "Removing nVidia Cg dependency on this arch"
+ epatch ${FILESDIR}/${PV}-nocg.patch || \
+ die "Failed while removing nVidia Cg support"
+ ./bootstrap
+ ;;
+ esac
+}
+
src_compile() {
local myconf="cli"