summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2013-03-03 08:22:03 +0000
committerRyan Hill <dirtyepic@gentoo.org>2013-03-03 08:22:03 +0000
commitbc38f879d3d53c8fe990d2cec66b0cead0da6969 (patch)
tree538be0925ac31b89d9ff68114ac9450740d227a7 /dev-games
parentAdd s390 love. (diff)
downloadgentoo-2-bc38f879d3d53c8fe990d2cec66b0cead0da6969.tar.gz
gentoo-2-bc38f879d3d53c8fe990d2cec66b0cead0da6969.tar.bz2
gentoo-2-bc38f879d3d53c8fe990d2cec66b0cead0da6969.zip
Further build fixes for GCC 4.7 (bug #459440).
(Portage version: 2.2.0_alpha164/cvs/Linux x86_64, signed Manifest commit with key 957A8463)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/crystalspace/ChangeLog6
-rw-r--r--dev-games/crystalspace/files/crystalspace-2.0-gcc47.patch88
2 files changed, 83 insertions, 11 deletions
diff --git a/dev-games/crystalspace/ChangeLog b/dev-games/crystalspace/ChangeLog
index bd8e3ed8684c..e6910aa3f8f9 100644
--- a/dev-games/crystalspace/ChangeLog
+++ b/dev-games/crystalspace/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-games/crystalspace
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.58 2013/02/13 17:27:38 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.59 2013/03/03 08:22:03 dirtyepic Exp $
+
+ 03 Mar 2013; Ryan Hill <dirtyepic@gentoo.org>
+ files/crystalspace-2.0-gcc47.patch:
+ Further build fixes for GCC 4.7 (bug #459440).
13 Feb 2013; Michael Sterrett <mr_bones_@gentoo.org>
-crystalspace-1.4.0.ebuild, -files/crystalspace-1.4.0-bullet.patch,
diff --git a/dev-games/crystalspace/files/crystalspace-2.0-gcc47.patch b/dev-games/crystalspace/files/crystalspace-2.0-gcc47.patch
index c5144b94eb3b..5b76b2e94707 100644
--- a/dev-games/crystalspace/files/crystalspace-2.0-gcc47.patch
+++ b/dev-games/crystalspace/files/crystalspace-2.0-gcc47.patch
@@ -1,6 +1,45 @@
---- include/csutil/blockallocator.h
-+++ include/csutil/blockallocator.h
-@@ -193,7 +193,7 @@
+https://bugs.gentoo.org/426870
+https://bugs.gentoo.org/459440
+
+ include/csplugincommon/rendermanager/render.h | 6 +++---
+ include/csutil/blockallocator.h | 6 +++---
+ include/csutil/parray.h | 2 +-
+ include/csutil/redblacktree.h | 4 ++--
+ include/csutil/refarr.h | 2 +-
+ 5 files changed, 10 insertions(+), 10 deletions(-)
+
+--- a/include/csplugincommon/rendermanager/render.h
++++ b/include/csplugincommon/rendermanager/render.h
+@@ -194,7 +194,7 @@ namespace RenderManager
+ || (mesh.preCopyNum != 0))
+ {
+ // Render the latest batch of meshes
+- RenderMeshes (context, node->meshes, lastShader, lastTicket, lastRenderedMesh, m);
++ this->RenderMeshes (context, node->meshes, lastShader, lastTicket, lastRenderedMesh, m);
+ lastRenderedMesh = m;
+
+ lastShader = shader;
+@@ -208,7 +208,7 @@ namespace RenderManager
+ }
+ }
+
+- RenderMeshes (context, node->meshes, lastShader, lastTicket, lastRenderedMesh, node->meshes.GetSize ());
++ this->RenderMeshes (context, node->meshes, lastShader, lastTicket, lastRenderedMesh, node->meshes.GetSize ());
+ }
+ };
+
+@@ -242,7 +242,7 @@ namespace RenderManager
+ iShader* shader = context.shaderArray[mesh.contextLocalId+layerOffset];
+
+ size_t ticket = context.ticketArray[mesh.contextLocalId+layerOffset];
+- RenderMeshes (context, node->meshes, shader, ticket, m, m+1);
++ this->RenderMeshes (context, node->meshes, shader, ticket, m, m+1);
+ }
+ }
+ }
+--- a/include/csutil/blockallocator.h
++++ b/include/csutil/blockallocator.h
+@@ -193,7 +193,7 @@ public:
~csBlockAllocator()
{
ObjectDispose dispose (*this, false);
@@ -9,7 +48,16 @@
}
/**
-@@ -215,7 +215,7 @@
+@@ -204,7 +204,7 @@ public:
+ void Empty ()
+ {
+ ObjectDispose dispose (*this, true);
+- FreeAll (dispose);
++ this->FreeAll (dispose);
+ }
+
+ /**
+@@ -215,7 +215,7 @@ public:
void DeleteAll ()
{
ObjectDispose dispose (*this, true);
@@ -18,9 +66,9 @@
}
/**
---- include/csutil/parray.h
-+++ include/csutil/parray.h
-@@ -112,7 +112,7 @@
+--- a/include/csutil/parray.h
++++ b/include/csutil/parray.h
+@@ -112,7 +112,7 @@ public:
{
CS_ASSERT (this->GetSize () > 0);
T* ret = GetAndClear (this->GetSize () - 1); // see *1*
@@ -29,9 +77,29 @@
return ret;
}
---- include/csutil/refarr.h
-+++ include/csutil/refarr.h
-@@ -111,7 +111,7 @@
+--- a/include/csutil/redblacktree.h
++++ b/include/csutil/redblacktree.h
+@@ -1155,7 +1155,7 @@ public:
+ T* Put (const K& key, const T &value)
+ {
+ csRedBlackTreePayload<K, T>* payload = (csRedBlackTreePayload<K, T>*)
+- Insert (csRedBlackTreePayload<K, T>(key, value));
++ this->Insert (csRedBlackTreePayload<K, T>(key, value));
+ return (payload != 0) ? &payload->GetValue() : 0;
+ }
+ /**
+@@ -1194,7 +1194,7 @@ public:
+ */
+ const T& Get (const K& key, const T& fallback) const
+ {
+- const csRedBlackTreePayload<K, T>* payload = Find (key);
++ const csRedBlackTreePayload<K, T>* payload = this->Find (key);
+ if (payload == 0) return fallback;
+ return payload->GetValue();
+ }
+--- a/include/csutil/refarr.h
++++ b/include/csutil/refarr.h
+@@ -111,7 +111,7 @@ public:
{
CS_ASSERT (this->GetSize () > 0);
csRef<T> ret = this->Get (this->GetSize () - 1); // see *1*