summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-06-07 19:16:45 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-06-07 19:16:45 +0000
commita991785f1af97d525c9c8aab896260d64074e988 (patch)
treec19b0ec29f826b82ab8941bd61360394b75f97cf /dev-games
parentinherit multilib for get_libdir (diff)
downloadgentoo-2-a991785f1af97d525c9c8aab896260d64074e988.tar.gz
gentoo-2-a991785f1af97d525c9c8aab896260d64074e988.tar.bz2
gentoo-2-a991785f1af97d525c9c8aab896260d64074e988.zip
version bump
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/ode/ChangeLog9
-rw-r--r--dev-games/ode/ode-0.12.ebuild77
2 files changed, 84 insertions, 2 deletions
diff --git a/dev-games/ode/ChangeLog b/dev-games/ode/ChangeLog
index 5d30319233d7..0f2cb3d0cfd8 100644
--- a/dev-games/ode/ChangeLog
+++ b/dev-games/ode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-games/ode
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/ode/ChangeLog,v 1.58 2010/09/20 03:47:35 mr_bones_ Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/ode/ChangeLog,v 1.59 2012/06/07 19:16:45 mr_bones_ Exp $
+
+*ode-0.12 (07 Jun 2012)
+
+ 07 Jun 2012; Michael Sterrett <mr_bones_@gentoo.org> +ode-0.12.ebuild:
+ version bump
20 Sep 2010; Michael Sterrett <mr_bones_@gentoo.org> ode-0.11.1.ebuild:
fix build with /bin/sh != bash (bug #335760); add USE=static-libs
diff --git a/dev-games/ode/ode-0.12.ebuild b/dev-games/ode/ode-0.12.ebuild
new file mode 100644
index 000000000000..fe4400996aec
--- /dev/null
+++ b/dev-games/ode/ode-0.12.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/ode/ode-0.12.ebuild,v 1.1 2012/06/07 19:16:45 mr_bones_ Exp $
+
+EAPI=2
+DESCRIPTION="Open Dynamics Engine SDK"
+HOMEPAGE="http://ode.org/"
+SRC_URI="mirror://sourceforge/opende/${P}.tar.bz2"
+
+LICENSE="|| ( LGPL-2.1 BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc double-precision examples gyroscopic static-libs"
+
+RDEPEND="examples? (
+ virtual/opengl
+ )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ sed -i \
+ -e "s:\$.*/drawstuff/textures:/usr/share/doc/${PF}/examples:" \
+ drawstuff/src/Makefile.in \
+ ode/demo/Makefile.in \
+ || die "sed Makefile.in failed"
+}
+
+src_configure() {
+ # use bash (bug #335760)
+ CONFIG_SHELL=/bin/bash \
+ econf \
+ --disable-dependency-tracking \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable debug asserts) \
+ $(use_enable double-precision) \
+ $(use_enable examples demos) \
+ $(use_enable gyroscopic) \
+ $(use_with examples drawstuff X11)
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc ; then
+ cd ode/doc
+ doxygen Doxyfile || die "doxygen failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc CHANGELOG.txt README.txt
+ if ! use static-libs ; then
+ find "${D}" -type f -name '*.la' -exec rm {} + \
+ || die "la removal failed"
+ fi
+ if use doc ; then
+ dohtml docs/* || die "dohtml failed"
+ fi
+ if use examples; then
+ cd ode/demo
+ exeinto /usr/share/doc/${PF}/examples
+ local f
+ for f in *.c* ; do
+ doexe .libs/${f%.*} || die "doexe ${f%.*} failed"
+ done
+ cd ../..
+ doexe drawstuff/dstest/dstest
+ insinto /usr/share/doc/${PF}/examples
+ doins ode/demo/*.{c,cpp,h} \
+ drawstuff/textures/*.ppm \
+ drawstuff/dstest/dstest.cpp \
+ drawstuff/src/{drawstuff.cpp,internal.h,x11.cpp} \
+ || die "doins failed"
+ fi
+}