summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-06-01 18:09:07 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-06-01 18:09:07 +0000
commita97130da9511c0fab3aee509ac38297f030367d8 (patch)
tree543a02b48c319541440cf12b8969f4347afb7edc /dev-games
parentold (diff)
downloadgentoo-2-a97130da9511c0fab3aee509ac38297f030367d8.tar.gz
gentoo-2-a97130da9511c0fab3aee509ac38297f030367d8.tar.bz2
gentoo-2-a97130da9511c0fab3aee509ac38297f030367d8.zip
rm old versions
(Portage version: 2.1.2.9)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/irrlicht/files/digest-irrlicht-0.14.03
-rw-r--r--dev-games/irrlicht/files/digest-irrlicht-1.13
-rw-r--r--dev-games/irrlicht/files/digest-irrlicht-1.1-r13
-rw-r--r--dev-games/irrlicht/files/irrlicht-0.12.0-64bit.patch145
-rw-r--r--dev-games/irrlicht/files/irrlicht-1.1-config.patch26
-rw-r--r--dev-games/irrlicht/files/irrlicht-1.1-demoMake.patch14
-rw-r--r--dev-games/irrlicht/files/irrlicht-1.1-gcc41.patch11
-rw-r--r--dev-games/irrlicht/files/irrlicht-1.1-jpeg.patch21
-rw-r--r--dev-games/irrlicht/files/irrlicht-1.2-opengl.patch (renamed from dev-games/irrlicht/files/irrlicht-0.12.0-opengl.patch)0
-rw-r--r--dev-games/irrlicht/irrlicht-0.14.0.ebuild82
-rw-r--r--dev-games/irrlicht/irrlicht-1.1-r1.ebuild72
-rw-r--r--dev-games/irrlicht/irrlicht-1.1.ebuild65
-rw-r--r--dev-games/irrlicht/irrlicht-1.2.ebuild6
13 files changed, 3 insertions, 448 deletions
diff --git a/dev-games/irrlicht/files/digest-irrlicht-0.14.0 b/dev-games/irrlicht/files/digest-irrlicht-0.14.0
deleted file mode 100644
index 159c9eeb2133..000000000000
--- a/dev-games/irrlicht/files/digest-irrlicht-0.14.0
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 5da8c8f4632d26f971fba2d56e04a652 irrlicht-0.14.0.zip 13925328
-RMD160 6c2abb7822a2fdb0b360983a5ad8094f7bd77eb5 irrlicht-0.14.0.zip 13925328
-SHA256 5b8c2424463cec711298edb77e25f021a11ac09950e085ebaeb8db546421dd97 irrlicht-0.14.0.zip 13925328
diff --git a/dev-games/irrlicht/files/digest-irrlicht-1.1 b/dev-games/irrlicht/files/digest-irrlicht-1.1
deleted file mode 100644
index 905f5ed5b361..000000000000
--- a/dev-games/irrlicht/files/digest-irrlicht-1.1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 c2a3606e037213555e7891f0433fa98a irrlicht-1.1.zip 15647723
-RMD160 1469ade750699b12244e0f38ea07e6a4314e696c irrlicht-1.1.zip 15647723
-SHA256 6ef74629d33b4f2cb2faa91d81cbd0f591ebce620ebfae8e4fd3fb71f1137f19 irrlicht-1.1.zip 15647723
diff --git a/dev-games/irrlicht/files/digest-irrlicht-1.1-r1 b/dev-games/irrlicht/files/digest-irrlicht-1.1-r1
deleted file mode 100644
index 905f5ed5b361..000000000000
--- a/dev-games/irrlicht/files/digest-irrlicht-1.1-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 c2a3606e037213555e7891f0433fa98a irrlicht-1.1.zip 15647723
-RMD160 1469ade750699b12244e0f38ea07e6a4314e696c irrlicht-1.1.zip 15647723
-SHA256 6ef74629d33b4f2cb2faa91d81cbd0f591ebce620ebfae8e4fd3fb71f1137f19 irrlicht-1.1.zip 15647723
diff --git a/dev-games/irrlicht/files/irrlicht-0.12.0-64bit.patch b/dev-games/irrlicht/files/irrlicht-0.12.0-64bit.patch
deleted file mode 100644
index dcb19571b6dd..000000000000
--- a/dev-games/irrlicht/files/irrlicht-0.12.0-64bit.patch
+++ /dev/null
@@ -1,145 +0,0 @@
-Only tested the q3 example but this patch stopped it from segfaulting ;).
-
---- source/Irrlicht/CSceneManager.h
-+++ source/Irrlicht/CSceneManager.h
-@@ -321,13 +321,13 @@
- textureValue = 0;
-
- if (n->getMaterialCount())
-- textureValue = (s32)(n->getMaterial(0).Texture1);
-+ textureValue = (unsigned long)(n->getMaterial(0).Texture1);
-
- node = n;
- }
-
- ISceneNode* node;
-- s32 textureValue;
-+ unsigned long textureValue;
-
- bool operator < (const DefaultNodeEntry& other) const
- {
---- source/Irrlicht/CQ3LevelMesh.cpp
-+++ source/Irrlicht/CQ3LevelMesh.cpp
-@@ -352,15 +352,15 @@
- }
-
- // helper method for creating curved surfaces, sent in by Dean P. Macri.
--inline f32 CQ3LevelMesh::Blend( f32 s[3], f32 t[3], tBSPVertex *v[9], int offset)
-+inline f32 CQ3LevelMesh::Blend( f32 s[3], f32 t[3], tBSPVertex *v[9], unsigned long offset)
- {
- f32 res = 0.0f;
-- f32 *ptr;
-+ unsigned long *ptr;
-
- for( int i=0; i<3; i++ )
- for( int j=0; j<3; j++ )
- {
-- ptr = (f32 *)( (int)v[i*3+j] + offset );
-+ ptr = (unsigned long *)( (unsigned long)v[i*3+j] + offset );
- res += s[i] * t[j] * (*ptr);
- }
- return res;
-@@ -429,52 +429,52 @@
-
- // Vert 1
- currentVertex[0].Color.set(255,255,255,255);
-- currentVertex[0].Pos.X = Blend( cs, ct, v, (int)&v[0]->vPosition[0] - (int)v[0]);
-- currentVertex[0].Pos.Y = Blend( cs, ct, v, (int)&v[0]->vPosition[2] - (int)v[0]);
-- currentVertex[0].Pos.Z = Blend( cs, ct, v, (int)&v[0]->vPosition[1] - (int)v[0]);
-- currentVertex[0].Normal.X = Blend( cs, ct, v, (int)&v[0]->vNormal[0] - (int)v[0]);
-- currentVertex[0].Normal.Y = Blend( cs, ct, v, (int)&v[0]->vNormal[2] - (int)v[0]);
-- currentVertex[0].Normal.Z = Blend( cs, ct, v, (int)&v[0]->vNormal[1] - (int)v[0]);
-- currentVertex[0].TCoords.X = Blend( cs, ct, v, (int)&v[0]->vTextureCoord[0] - (int)v[0]);
-- currentVertex[0].TCoords.Y = Blend( cs, ct, v, (int)&v[0]->vTextureCoord[1] - (int)v[0]);
-- currentVertex[0].TCoords2.X = Blend( cs, ct, v, (int)&v[0]->vLightmapCoord[0] - (int)v[0]);
-- currentVertex[0].TCoords2.Y = Blend( cs, ct, v, (int)&v[0]->vLightmapCoord[1] - (int)v[0]);
-+ currentVertex[0].Pos.X = Blend( cs, ct, v, (unsigned long)&v[0]->vPosition[0] - (unsigned long)v[0]);
-+ currentVertex[0].Pos.Y = Blend( cs, ct, v, (unsigned long)&v[0]->vPosition[2] - (unsigned long)v[0]);
-+ currentVertex[0].Pos.Z = Blend( cs, ct, v, (unsigned long)&v[0]->vPosition[1] - (unsigned long)v[0]);
-+ currentVertex[0].Normal.X = Blend( cs, ct, v, (unsigned long)&v[0]->vNormal[0] - (unsigned long)v[0]);
-+ currentVertex[0].Normal.Y = Blend( cs, ct, v, (unsigned long)&v[0]->vNormal[2] - (unsigned long)v[0]);
-+ currentVertex[0].Normal.Z = Blend( cs, ct, v, (unsigned long)&v[0]->vNormal[1] - (unsigned long)v[0]);
-+ currentVertex[0].TCoords.X = Blend( cs, ct, v, (unsigned long)&v[0]->vTextureCoord[0] - (unsigned long)v[0]);
-+ currentVertex[0].TCoords.Y = Blend( cs, ct, v, (unsigned long)&v[0]->vTextureCoord[1] - (unsigned long)v[0]);
-+ currentVertex[0].TCoords2.X = Blend( cs, ct, v, (unsigned long)&v[0]->vLightmapCoord[0] - (unsigned long)v[0]);
-+ currentVertex[0].TCoords2.Y = Blend( cs, ct, v, (unsigned long)&v[0]->vLightmapCoord[1] - (unsigned long)v[0]);
- // Vert 2
- currentVertex[1].Color.set(255,255,255,255);
-- currentVertex[1].Pos.X = Blend( cs, nxt, v, (int)&v[0]->vPosition[0] - (int)v[0]);
-- currentVertex[1].Pos.Y = Blend( cs, nxt, v, (int)&v[0]->vPosition[2] - (int)v[0]);
-- currentVertex[1].Pos.Z = Blend( cs, nxt, v, (int)&v[0]->vPosition[1] - (int)v[0]);
-- currentVertex[1].Normal.X = Blend( cs, nxt, v, (int)&v[0]->vNormal[0] - (int)v[0]);
-- currentVertex[1].Normal.Y = Blend( cs, nxt, v, (int)&v[0]->vNormal[2] - (int)v[0]);
-- currentVertex[1].Normal.Z = Blend( cs, nxt, v, (int)&v[0]->vNormal[1] - (int)v[0]);
-- currentVertex[1].TCoords.X = Blend( cs, nxt, v, (int)&v[0]->vTextureCoord[0] - (int)v[0]);
-- currentVertex[1].TCoords.Y = Blend( cs, nxt, v, (int)&v[0]->vTextureCoord[1] - (int)v[0]);
-- currentVertex[1].TCoords2.X = Blend( cs, nxt, v, (int)&v[0]->vLightmapCoord[0] - (int)v[0]);
-- currentVertex[1].TCoords2.Y = Blend( cs, nxt, v, (int)&v[0]->vLightmapCoord[1] - (int)v[0]);
-+ currentVertex[1].Pos.X = Blend( cs, nxt, v, (unsigned long)&v[0]->vPosition[0] - (unsigned long)v[0]);
-+ currentVertex[1].Pos.Y = Blend( cs, nxt, v, (unsigned long)&v[0]->vPosition[2] - (unsigned long)v[0]);
-+ currentVertex[1].Pos.Z = Blend( cs, nxt, v, (unsigned long)&v[0]->vPosition[1] - (unsigned long)v[0]);
-+ currentVertex[1].Normal.X = Blend( cs, nxt, v, (unsigned long)&v[0]->vNormal[0] - (unsigned long)v[0]);
-+ currentVertex[1].Normal.Y = Blend( cs, nxt, v, (unsigned long)&v[0]->vNormal[2] - (unsigned long)v[0]);
-+ currentVertex[1].Normal.Z = Blend( cs, nxt, v, (unsigned long)&v[0]->vNormal[1] - (unsigned long)v[0]);
-+ currentVertex[1].TCoords.X = Blend( cs, nxt, v, (unsigned long)&v[0]->vTextureCoord[0] - (unsigned long)v[0]);
-+ currentVertex[1].TCoords.Y = Blend( cs, nxt, v, (unsigned long)&v[0]->vTextureCoord[1] - (unsigned long)v[0]);
-+ currentVertex[1].TCoords2.X = Blend( cs, nxt, v, (unsigned long)&v[0]->vLightmapCoord[0] - (unsigned long)v[0]);
-+ currentVertex[1].TCoords2.Y = Blend( cs, nxt, v, (unsigned long)&v[0]->vLightmapCoord[1] - (unsigned long)v[0]);
- // Vert 3
- currentVertex[2].Color.set(255,255,255,255);
-- currentVertex[2].Pos.X = Blend( nxs, ct, v, (int)&v[0]->vPosition[0] - (int)v[0]);
-- currentVertex[2].Pos.Y = Blend( nxs, ct, v, (int)&v[0]->vPosition[2] - (int)v[0]);
-- currentVertex[2].Pos.Z = Blend( nxs, ct, v, (int)&v[0]->vPosition[1] - (int)v[0]);
-- currentVertex[2].Normal.X = Blend( nxs, ct, v, (int)&v[0]->vNormal[0] - (int)v[0]);
-- currentVertex[2].Normal.Y = Blend( nxs, ct, v, (int)&v[0]->vNormal[2] - (int)v[0]);
-- currentVertex[2].Normal.Z = Blend( nxs, ct, v, (int)&v[0]->vNormal[1] - (int)v[0]);
-- currentVertex[2].TCoords.X = Blend( nxs, ct, v, (int)&v[0]->vTextureCoord[0] - (int)v[0]);
-- currentVertex[2].TCoords.Y = Blend( nxs, ct, v, (int)&v[0]->vTextureCoord[1] - (int)v[0]);
-- currentVertex[2].TCoords2.X = Blend( nxs, ct, v, (int)&v[0]->vLightmapCoord[0] - (int)v[0]);
-- currentVertex[2].TCoords2.Y = Blend( nxs, ct, v, (int)&v[0]->vLightmapCoord[1] - (int)v[0]);
-+ currentVertex[2].Pos.X = Blend( nxs, ct, v, (unsigned long)&v[0]->vPosition[0] - (unsigned long)v[0]);
-+ currentVertex[2].Pos.Y = Blend( nxs, ct, v, (unsigned long)&v[0]->vPosition[2] - (unsigned long)v[0]);
-+ currentVertex[2].Pos.Z = Blend( nxs, ct, v, (unsigned long)&v[0]->vPosition[1] - (unsigned long)v[0]);
-+ currentVertex[2].Normal.X = Blend( nxs, ct, v, (unsigned long)&v[0]->vNormal[0] - (unsigned long)v[0]);
-+ currentVertex[2].Normal.Y = Blend( nxs, ct, v, (unsigned long)&v[0]->vNormal[2] - (unsigned long)v[0]);
-+ currentVertex[2].Normal.Z = Blend( nxs, ct, v, (unsigned long)&v[0]->vNormal[1] - (unsigned long)v[0]);
-+ currentVertex[2].TCoords.X = Blend( nxs, ct, v, (unsigned long)&v[0]->vTextureCoord[0] - (unsigned long)v[0]);
-+ currentVertex[2].TCoords.Y = Blend( nxs, ct, v, (unsigned long)&v[0]->vTextureCoord[1] - (unsigned long)v[0]);
-+ currentVertex[2].TCoords2.X = Blend( nxs, ct, v, (unsigned long)&v[0]->vLightmapCoord[0] - (unsigned long)v[0]);
-+ currentVertex[2].TCoords2.Y = Blend( nxs, ct, v, (unsigned long)&v[0]->vLightmapCoord[1] - (unsigned long)v[0]);
- // Vert 4
- currentVertex[3].Color.set(255,255,255,255);
-- currentVertex[3].Pos.X = Blend( nxs, nxt, v, (int)&v[0]->vPosition[0] - (int)v[0]);
-- currentVertex[3].Pos.Y = Blend( nxs, nxt, v, (int)&v[0]->vPosition[2] - (int)v[0]);
-- currentVertex[3].Pos.Z = Blend( nxs, nxt, v, (int)&v[0]->vPosition[1] - (int)v[0]);
-- currentVertex[3].Normal.X = Blend( nxs, nxt, v, (int)&v[0]->vNormal[0] - (int)v[0]);
-- currentVertex[3].Normal.Y = Blend( nxs, nxt, v, (int)&v[0]->vNormal[2] - (int)v[0]);
-- currentVertex[3].Normal.Z = Blend( nxs, nxt, v, (int)&v[0]->vNormal[1] - (int)v[0]);
-- currentVertex[3].TCoords.X = Blend( nxs, nxt, v, (int)&v[0]->vTextureCoord[0] - (int)v[0]);
-- currentVertex[3].TCoords.Y = Blend( nxs, nxt, v, (int)&v[0]->vTextureCoord[1] - (int)v[0]);
-- currentVertex[3].TCoords2.X = Blend( nxs, nxt, v, (int)&v[0]->vLightmapCoord[0] - (int)v[0]);
-- currentVertex[3].TCoords2.Y = Blend( nxs, nxt, v, (int)&v[0]->vLightmapCoord[1] - (int)v[0]);
-+ currentVertex[3].Pos.X = Blend( nxs, nxt, v, (unsigned long)&v[0]->vPosition[0] - (unsigned long)v[0]);
-+ currentVertex[3].Pos.Y = Blend( nxs, nxt, v, (unsigned long)&v[0]->vPosition[2] - (unsigned long)v[0]);
-+ currentVertex[3].Pos.Z = Blend( nxs, nxt, v, (unsigned long)&v[0]->vPosition[1] - (unsigned long)v[0]);
-+ currentVertex[3].Normal.X = Blend( nxs, nxt, v, (unsigned long)&v[0]->vNormal[0] - (unsigned long)v[0]);
-+ currentVertex[3].Normal.Y = Blend( nxs, nxt, v, (unsigned long)&v[0]->vNormal[2] - (unsigned long)v[0]);
-+ currentVertex[3].Normal.Z = Blend( nxs, nxt, v, (unsigned long)&v[0]->vNormal[1] - (unsigned long)v[0]);
-+ currentVertex[3].TCoords.X = Blend( nxs, nxt, v, (unsigned long)&v[0]->vTextureCoord[0] - (unsigned long)v[0]);
-+ currentVertex[3].TCoords.Y = Blend( nxs, nxt, v, (unsigned long)&v[0]->vTextureCoord[1] - (unsigned long)v[0]);
-+ currentVertex[3].TCoords2.X = Blend( nxs, nxt, v, (unsigned long)&v[0]->vLightmapCoord[0] - (unsigned long)v[0]);
-+ currentVertex[3].TCoords2.Y = Blend( nxs, nxt, v, (unsigned long)&v[0]->vLightmapCoord[1] - (unsigned long)v[0]);
- // Put the vertices in the mesh buffer
- meshBuffer->Vertices.push_back(currentVertex[0]);
- meshBuffer->Vertices.push_back(currentVertex[2]);
---- source/Irrlicht/CQ3LevelMesh.h
-+++ source/Irrlicht/CQ3LevelMesh.h
-@@ -214,7 +214,7 @@
-
- // second parameter i is the zero based index of the current face.
- void createCurvedSurface(SMeshBufferLightMap* meshBuffer, s32 i);
-- f32 Blend( f32 s[3], f32 t[3], tBSPVertex *v[9], int offset);
-+ f32 Blend( f32 s[3], f32 t[3], tBSPVertex *v[9], unsigned long offset);
-
- tBSPLump Lumps[kMaxLumps];
-
diff --git a/dev-games/irrlicht/files/irrlicht-1.1-config.patch b/dev-games/irrlicht/files/irrlicht-1.1-config.patch
deleted file mode 100644
index e6ba8795f0d6..000000000000
--- a/dev-games/irrlicht/files/irrlicht-1.1-config.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- include/IrrCompileConfig.h.old 2006-09-16 12:42:28.000000000 +0200
-+++ include/IrrCompileConfig.h 2006-09-16 12:42:58.000000000 +0200
-@@ -68,7 +68,6 @@
- //! Define _IRR_USE_NON_SYSTEM_ZLIB_ to let irrlicht use the zlib which comes with irrlicht.
- /** If this is commented out, Irrlicht will try to compile using the zlib installed in the system.
- This is only used when _IRR_COMPILE_WITH_ZLIB_ is defined. */
--#define _IRR_USE_NON_SYSTEM_ZLIB_
-
-
- //! Define _IRR_COMPILE_WITH_JPEGLIB_ to enable compiling the engine using libjpeg.
-@@ -79,7 +78,6 @@
- //! Define _IRR_USE_NON_SYSTEM_JPEG_LIB_ to let irrlicht use the jpeglib which comes with irrlicht.
- /** If this is commented out, Irrlicht will try to compile using the jpeg lib installed in the system.
- This is only used when _IRR_COMPILE_WITH_LIBJPEG_ is defined. */
--#define _IRR_USE_NON_SYSTEM_JPEG_LIB_
-
-
- //! Define _IRR_COMPILE_WITH_LIBPNG_ to enable compiling the engine using libpng.
-@@ -90,7 +88,6 @@
- //! Define _IRR_USE_NON_SYSTEM_LIBPNG_ to let irrlicht use the libpng which comes with irrlicht.
- /** If this is commented out, Irrlicht will try to compile using the libpng installed in the system.
- This is only used when _IRR_COMPILE_WITH_LIBPNG_ is defined. */
--#define _IRR_USE_NON_SYSTEM_LIB_PNG_
-
-
- //! Define _IRR_D3D_NO_SHADER_DEBUGGING to disable shader debugging in D3D9
diff --git a/dev-games/irrlicht/files/irrlicht-1.1-demoMake.patch b/dev-games/irrlicht/files/irrlicht-1.1-demoMake.patch
deleted file mode 100644
index 56de8ca5c8e8..000000000000
--- a/dev-games/irrlicht/files/irrlicht-1.1-demoMake.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- ../../examples/Demo/Makefile.old 2006-10-14 13:06:42.000000000 +0200
-+++ ../../examples/Demo/Makefile 2006-10-14 13:08:32.000000000 +0200
-@@ -2,9 +2,9 @@
- # Handwritten by me, made with Kate. So it is far from being perfect. :)
-
- CXX = g++
--CPPFLAGS = -I"../../include" -I"/usr/X11R6/include"
-+CPPFLAGS = -I/usr/include/irrlicht
- CXXFLAGS = -O3 -ffast-math
--LDFLAGS = -L"/usr/X11R6/lib" -L"../../lib/Linux" -lIrrlicht -lGL -lGLU -lXxf86vm -lXext -lX11
-+LDFLAGS = -lIrrlicht -lGL -lGLU -lXxf86vm -lXext -lX11 -lpng -ljpeg
- # if you enable sound add the proper library for linking
- # -laudiere
- # -lSDL_mixer -lSDL
diff --git a/dev-games/irrlicht/files/irrlicht-1.1-gcc41.patch b/dev-games/irrlicht/files/irrlicht-1.1-gcc41.patch
deleted file mode 100644
index 5f0efbe7c141..000000000000
--- a/dev-games/irrlicht/files/irrlicht-1.1-gcc41.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- source/Irrlicht/CSceneManager.h.old 2006-09-16 12:15:36.000000000 +0200
-+++ source/Irrlicht/CSceneManager.h 2006-09-16 12:15:45.000000000 +0200
-@@ -146,7 +146,7 @@
-
- //! Adds a skydome scene node. A skydome is a large (half-) sphere with a
- //! panoramic texture on it and is drawn around the camera position.
-- virtual ISceneNode* CSceneManager::addSkyDomeSceneNode(video::ITexture* texture,
-+ virtual ISceneNode* addSkyDomeSceneNode(video::ITexture* texture,
- u32 horiRes, u32 vertRes, f64 texturePercentage,
- f64 spherePercentage, ISceneNode* parent, s32 id);
-
diff --git a/dev-games/irrlicht/files/irrlicht-1.1-jpeg.patch b/dev-games/irrlicht/files/irrlicht-1.1-jpeg.patch
deleted file mode 100644
index 0097aa28839c..000000000000
--- a/dev-games/irrlicht/files/irrlicht-1.1-jpeg.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- CImageLoaderJPG.h.old 2006-10-14 12:18:56.000000000 +0200
-+++ CImageLoaderJPG.h 2006-10-14 12:19:55.000000000 +0200
-@@ -12,8 +12,6 @@
- #include "IrrCompileConfig.h"
- #ifdef _IRR_COMPILE_WITH_LIBJPEG_
- extern "C" {
-- #include "jpeglib/jconfig.h"
-- #define JCONFIG_INCLUDED
- #ifndef _IRR_USE_NON_SYSTEM_JPEG_LIB_
- #include <jpeglib.h> // use system lib
- #else // _IRR_USE_NON_SYSTEM_JPEG_LIB_
---- CImageWriterJPG.cpp.old 2006-10-14 12:20:14.000000000 +0200
-+++ CImageWriterJPG.cpp 2006-10-14 12:20:35.000000000 +0200
-@@ -10,7 +10,6 @@
- #ifdef _IRR_COMPILE_WITH_LIBJPEG_
- extern "C"
- {
-- #include "jpeglib/jconfig.h"
- #ifndef _IRR_USE_NON_SYSTEM_JPEG_LIB_
- #include <jpeglib.h>
- #include <jerror.h>
diff --git a/dev-games/irrlicht/files/irrlicht-0.12.0-opengl.patch b/dev-games/irrlicht/files/irrlicht-1.2-opengl.patch
index f527f22cacd5..f527f22cacd5 100644
--- a/dev-games/irrlicht/files/irrlicht-0.12.0-opengl.patch
+++ b/dev-games/irrlicht/files/irrlicht-1.2-opengl.patch
diff --git a/dev-games/irrlicht/irrlicht-0.14.0.ebuild b/dev-games/irrlicht/irrlicht-0.14.0.ebuild
deleted file mode 100644
index 4eec31b52f34..000000000000
--- a/dev-games/irrlicht/irrlicht-0.14.0.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/irrlicht/irrlicht-0.14.0.ebuild,v 1.5 2006/07/27 16:17:14 wolf31o2 Exp $
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="open source high performance realtime 3D engine written in C++"
-HOMEPAGE="http://irrlicht.sourceforge.net/"
-SRC_URI="mirror://sourceforge/irrlicht/${P}.zip
- mirror://sourceforge/irrlicht/${P}.zip"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="doc"
-
-RDEPEND="media-libs/jpeg
- media-libs/libpng
- sys-libs/zlib
- virtual/opengl
- || (
- (
- virtual/glu
- x11-libs/libX11 )
- virtual/x11 )"
-DEPEND="${RDEPEND}
- app-arch/unzip
- || (
- (
- x11-proto/xproto
- x11-proto/xf86vidmodeproto )
- virtual/x11 )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"/source
- unzip -qo source.zip || die "unpacking source.zip"
- rm -f source.zip
- cd Irrlicht
- epatch "${FILESDIR}/${P}"-gcc41.patch
-
- # stupid nvidia / xorg GL differences
- # still needed - bug #114335
- if echo -e '#include <GL/glx.h>\nglXGetProcAddress blah;' | \
- $(tc-getCC) -E - | \
- grep -q glXGetProcAddressARB
- then
- epatch "${FILESDIR}"/${PN}-0.12.0-opengl.patch
- fi
-
- # use the system zlib/jpeg/png
- rm -r zlib jpeglib libpng
- sed -i -e 's:zlib.zlib\.h:zlib.h:' CZipReader.cpp || die "zlib sed"
- sed -i -e '/include/s:jpeglib/::' CImageLoaderJPG.h || die "jpeg sed"
- sed -i -e '/include/s:libpng/::' CImageLoaderPNG.cpp || die "png sed"
- sed -i -r \
- -e '/^CXXFLAGS/s:=:+=:' \
- -e '/^LINKOBJ/s:(zlib|jpeglib|libpng)/[^.]+\.o::g' \
- Makefile || die "sed objs"
- for x in z jpeg png ; do
- mkdir ${x} && cd ${x} || die
- $(tc-getAR) x $($(tc-getCC) -print-file-name=lib${x}.a) || die "explode lib${x}.a"
- cd ..
- done
- sed -i \
- -e '/^LINKOBJ/s:$: $(wildcard z/*.o) $(wildcard jpeg/*.o) $(wildcard png/*.o):' \
- Makefile || die "sed objs two"
-}
-
-src_compile() {
- emake -C source/Irrlicht || die "emake failed"
-}
-
-src_install() {
- dolib.a lib/Linux/libIrrlicht.a || die "dolib.a failed"
- insinto /usr/include/${PN}
- doins include/* || die "doins failed"
- dodoc changes.txt readme.txt
- if use doc ; then
- cp -r examples media "${D}"/usr/share/doc/${PF}/ || die "cp failed"
- fi
-}
diff --git a/dev-games/irrlicht/irrlicht-1.1-r1.ebuild b/dev-games/irrlicht/irrlicht-1.1-r1.ebuild
deleted file mode 100644
index bdb7ad2b5134..000000000000
--- a/dev-games/irrlicht/irrlicht-1.1-r1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/irrlicht/irrlicht-1.1-r1.ebuild,v 1.1 2006/10/14 11:29:13 tupone Exp $
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="open source high performance realtime 3D engine written in C++"
-HOMEPAGE="http://irrlicht.sourceforge.net/"
-SRC_URI="mirror://sourceforge/irrlicht/${P}.zip"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="doc"
-
-RDEPEND="media-libs/jpeg
- media-libs/libpng
- sys-libs/zlib
- virtual/opengl
- virtual/glu
- x11-libs/libX11"
-DEPEND="${RDEPEND}
- app-arch/unzip
- x11-proto/xproto
- x11-proto/xf86vidmodeproto"
-
-S=${WORKDIR}/${P}/source/Irrlicht
-
-src_unpack() {
- unpack ${A}
- cd "${WORKDIR}"/${P}
- edos2unix source/Irrlicht/CSceneManager.h \
- include/IrrCompileConfig.h
- epatch "${FILESDIR}"/${P}-gcc41.patch \
- "${FILESDIR}/"${P}-config.patch
- cd "${S}"
-
- edos2unix CImageLoaderJPG.h \
- CImageWriterJPG.cpp \
- ../../examples/Demo/Makefile
- epatch "${FILESDIR}/"${P}-jpeg.patch \
- "${FILESDIR}/"${P}-demoMake.patch
-
- # stupid nvidia / xorg GL differences
- # still needed - bug #114335
- if echo -e '#include <GL/glx.h>\nglXGetProcAddress blah;' | \
- $(tc-getCC) -E - | \
- grep -q glXGetProcAddressARB
- then
- epatch "${FILESDIR}"/${PN}-0.12.0-opengl.patch
- fi
-
- # use the system zlib/jpeg/png
- sed -i -r \
- -e '/^CXXFLAGS/s:=:+=:' \
- -e '/^CXXINCS/s:-Izlib -Ijpeglib -Ilibpng::' \
- -e '/^ZLIBOBJ/d' \
- -e '/^JPEGLIBOBJ/d' \
- -e '/^LIBPNGOBJ/d' \
- Makefile || die "sed objs"
-}
-
-src_install() {
- cd ../..
- dolib.a lib/Linux/libIrrlicht.a || die "dolib.a failed"
- insinto /usr/include/${PN}
- doins include/* || die "doins failed"
- dodoc changes.txt readme.txt
- if use doc ; then
- cp -r examples media "${D}"/usr/share/doc/${PF}/ || die "cp failed"
- fi
-}
diff --git a/dev-games/irrlicht/irrlicht-1.1.ebuild b/dev-games/irrlicht/irrlicht-1.1.ebuild
deleted file mode 100644
index e902b0b6cb09..000000000000
--- a/dev-games/irrlicht/irrlicht-1.1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/irrlicht/irrlicht-1.1.ebuild,v 1.1 2006/09/16 11:29:59 tupone Exp $
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="open source high performance realtime 3D engine written in C++"
-HOMEPAGE="http://irrlicht.sourceforge.net/"
-SRC_URI="mirror://sourceforge/irrlicht/${P}.zip"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="doc"
-
-RDEPEND="media-libs/jpeg
- media-libs/libpng
- sys-libs/zlib
- virtual/opengl
- virtual/glu
- x11-libs/libX11"
-DEPEND="${RDEPEND}
- app-arch/unzip
- x11-proto/xproto
- x11-proto/xf86vidmodeproto"
-
-S=${WORKDIR}/${P}/source/Irrlicht
-
-src_unpack() {
- unpack ${A}
- cd "${WORKDIR}"/${P}
- edos2unix source/Irrlicht/CSceneManager.h \
- include/IrrCompileConfig.h
- epatch "${FILESDIR}"/${P}-gcc41.patch \
- "${FILESDIR}/"${P}-config.patch
- cd "${S}"
-
- # stupid nvidia / xorg GL differences
- # still needed - bug #114335
- if echo -e '#include <GL/glx.h>\nglXGetProcAddress blah;' | \
- $(tc-getCC) -E - | \
- grep -q glXGetProcAddressARB
- then
- epatch "${FILESDIR}"/${PN}-0.12.0-opengl.patch
- fi
-
- # use the system zlib/jpeg/png
- sed -i -r \
- -e '/^CXXFLAGS/s:=:+=:' \
- -e '/^ZLIBOBJ/d' \
- -e '/^JPEGLIBOBJ/d' \
- -e '/^LIBPNGOBJ/d' \
- Makefile || die "sed objs"
-}
-
-src_install() {
- cd ../..
- dolib.a lib/Linux/libIrrlicht.a || die "dolib.a failed"
- insinto /usr/include/${PN}
- doins include/* || die "doins failed"
- dodoc changes.txt readme.txt
- if use doc ; then
- cp -r examples media "${D}"/usr/share/doc/${PF}/ || die "cp failed"
- fi
-}
diff --git a/dev-games/irrlicht/irrlicht-1.2.ebuild b/dev-games/irrlicht/irrlicht-1.2.ebuild
index 395dfc0f63e1..cc07eb6fd19d 100644
--- a/dev-games/irrlicht/irrlicht-1.2.ebuild
+++ b/dev-games/irrlicht/irrlicht-1.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/irrlicht/irrlicht-1.2.ebuild,v 1.2 2007/04/10 12:23:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/irrlicht/irrlicht-1.2.ebuild,v 1.3 2007/06/01 18:09:07 nyhm Exp $
inherit eutils toolchain-funcs
@@ -42,7 +42,7 @@ src_unpack() {
$(tc-getCC) -E - | \
grep -q glXGetProcAddressARB
then
- epatch "${FILESDIR}"/${PN}-0.12.0-opengl.patch
+ epatch "${FILESDIR}"/${P}-opengl.patch
fi
# use the system zlib/jpeg/png