summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-03-08 20:08:59 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-03-08 20:08:59 +0000
commit6eacc68ffed980d27a16c364a47fa5424798980b (patch)
treee84b1d2a07ff30425a0d64aab0748374bd77f86e /dev-games
parentTransition to EAPI 2 usedeps (diff)
downloadgentoo-2-6eacc68ffed980d27a16c364a47fa5424798980b.tar.gz
gentoo-2-6eacc68ffed980d27a16c364a47fa5424798980b.tar.bz2
gentoo-2-6eacc68ffed980d27a16c364a47fa5424798980b.zip
Adding use based dep on poppler bindings. Should fix bug #261575 by Andrey Sh.
Adding pdf use flag to eventually disable poppler usage. Adding further dependency (Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/openscenegraph/ChangeLog8
-rw-r--r--dev-games/openscenegraph/files/openscenegraph-2.8.0-magicoff.patch17
-rw-r--r--dev-games/openscenegraph/openscenegraph-2.8.0.ebuild15
3 files changed, 34 insertions, 6 deletions
diff --git a/dev-games/openscenegraph/ChangeLog b/dev-games/openscenegraph/ChangeLog
index e94bc2f19f33..2f47dafff0a0 100644
--- a/dev-games/openscenegraph/ChangeLog
+++ b/dev-games/openscenegraph/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-games/openscenegraph
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/openscenegraph/ChangeLog,v 1.5 2009/03/03 07:56:36 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/openscenegraph/ChangeLog,v 1.6 2009/03/08 20:08:59 tupone Exp $
+
+ 08 Mar 2009; Tupone Alfredo <tupone@gentoo.org>
+ files/openscenegraph-2.8.0-magicoff.patch, openscenegraph-2.8.0.ebuild:
+ Adding use based dep on poppler bindings. Should fix bug #261575 by Andrey Sh.
+ Adding pdf use flag to eventually disable poppler usage.
+ Adding further dependency
03 Mar 2009; Alfredo Tupone <tupone@gentoo.org>
openscenegraph-2.8.0.ebuild:
diff --git a/dev-games/openscenegraph/files/openscenegraph-2.8.0-magicoff.patch b/dev-games/openscenegraph/files/openscenegraph-2.8.0-magicoff.patch
index 18ffd9c0270f..bc12e74a438d 100644
--- a/dev-games/openscenegraph/files/openscenegraph-2.8.0-magicoff.patch
+++ b/dev-games/openscenegraph/files/openscenegraph-2.8.0-magicoff.patch
@@ -1,10 +1,11 @@
--- CMakeLists.txt.old 2009-02-25 10:26:47.000000000 +0100
+++ CMakeLists.txt 2009-02-25 10:33:07.000000000 +0100
-@@ -287,6 +287,8 @@
+@@ -287,6 +287,9 @@
INCLUDE(Find3rdPartyDependencies)
ENDIF(WIN32)
+OPTION(ENABLE_XUL "Enable plugin gecko if xulrunner is available" ON)
++OPTION(ENABLE_PDF "Enable plugin pdf if poppler-glib and cairo are available" ON)
+
# Common to all platforms:
FIND_PACKAGE(FreeType)
@@ -19,3 +20,17 @@
#use pkg-config to find various modues
INCLUDE(FindPkgConfig OPTIONAL)
+--- src/osgPlugins/CMakeLists.txt.old 2009-03-08 17:02:24.000000000 +0100
++++ src/osgPlugins/CMakeLists.txt 2009-03-08 17:02:56.000000000 +0100
+@@ -211,9 +211,9 @@
+ ADD_SUBDIRECTORY(svg)
+ ENDIF(RSVG_FOUND AND CAIRO_FOUND)
+
+-IF (POPPLER_FOUND AND CAIRO_FOUND)
++IF(ENABLE_PDF AND POPPLER_FOUND AND CAIRO_FOUND)
+ ADD_SUBDIRECTORY(pdf)
+-ENDIF(POPPLER_FOUND AND CAIRO_FOUND)
++ENDIF(ENABLE_PDF AND POPPLER_FOUND AND CAIRO_FOUND)
+
+ IF (LIBVNCSERVER_FOUND)
+ ADD_SUBDIRECTORY(vnc)
diff --git a/dev-games/openscenegraph/openscenegraph-2.8.0.ebuild b/dev-games/openscenegraph/openscenegraph-2.8.0.ebuild
index a172f28d9ea5..39181bf50299 100644
--- a/dev-games/openscenegraph/openscenegraph-2.8.0.ebuild
+++ b/dev-games/openscenegraph/openscenegraph-2.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/openscenegraph/openscenegraph-2.8.0.ebuild,v 1.5 2009/03/03 07:56:36 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/openscenegraph/openscenegraph-2.8.0.ebuild,v 1.6 2009/03/08 20:08:59 tupone Exp $
EAPI=2
inherit eutils versionator cmake-utils
@@ -16,7 +16,7 @@ SRC_URI="http://www.openscenegraph.org/downloads/stable_releases/${MY_P_MAJOR}/s
LICENSE="wxWinLL-3 LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~sparc ~x86"
-IUSE="osgapps xulrunner"
+IUSE="osgapps pdf xulrunner"
RDEPEND="virtual/opengl
virtual/glu
@@ -26,8 +26,14 @@ RDEPEND="virtual/opengl
media-libs/jpeg
media-libs/giflib
media-libs/tiff
- app-text/poppler-bindings"
-
+ media-libs/jasper
+ media-libs/xine-lib
+ pdf? (
+ || (
+ app-text/poppler-bindings[gtk]
+ app-text/poppler-bindings[cairo]
+ )
+ )"
DEPEND="${RDEPEND}
app-arch/unzip"
@@ -45,5 +51,6 @@ src_configure() {
mycmakeargs="${mycmakeargs} -DBUILD_OSG_APPLICATIONS=OFF"
fi
mycmakeargs="${mycmakeargs} $(cmake-utils_use_enable xulrunner XUL)"
+ mycmakeargs="${mycmakeargs} $(cmake-utils_use_enable pdf PDF)"
cmake-utils_src_configure
}