summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2013-02-20 21:21:43 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2013-02-20 21:21:43 +0000
commit6a6f26069c73283a921b164412c3e3de88cf144d (patch)
tree6eab05973f77d114c3fe9347fa28d16117a6639f /dev-games
parentvanilla-3.7.9 + genpatches-3.7-11 + grsecurity-2.9.1-3.7.9-201302171808 (diff)
downloadgentoo-2-6a6f26069c73283a921b164412c3e3de88cf144d.tar.gz
gentoo-2-6a6f26069c73283a921b164412c3e3de88cf144d.tar.bz2
gentoo-2-6a6f26069c73283a921b164412c3e3de88cf144d.zip
Version bump, bug 458202. Thanks to Christian Schmitt.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key B1E955DB)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/simgear/ChangeLog10
-rw-r--r--dev-games/simgear/files/simgear-2.4.0-boost148.patch29
-rw-r--r--dev-games/simgear/simgear-2.10.0.ebuild49
-rw-r--r--dev-games/simgear/simgear-2.4.0.ebuild41
4 files changed, 57 insertions, 72 deletions
diff --git a/dev-games/simgear/ChangeLog b/dev-games/simgear/ChangeLog
index fd63e3208072..ff699e7257ca 100644
--- a/dev-games/simgear/ChangeLog
+++ b/dev-games/simgear/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-games/simgear
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/simgear/ChangeLog,v 1.57 2012/12/09 15:10:08 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/simgear/ChangeLog,v 1.58 2013/02/20 21:21:42 reavertm Exp $
+
+*simgear-2.10.0 (20 Feb 2013)
+
+ 20 Feb 2013; Maciej Mrozowski <reavertm@gentoo.org> +simgear-2.10.0.ebuild,
+ -files/simgear-2.4.0-boost148.patch, -simgear-2.4.0.ebuild:
+ Version bump, bug 458202. Thanks to Christian Schmitt.
09 Dec 2012; Agostino Sarubbo <ago@gentoo.org> simgear-2.8.0-r1.ebuild:
Stable for ppc, wrt bug #425838
diff --git a/dev-games/simgear/files/simgear-2.4.0-boost148.patch b/dev-games/simgear/files/simgear-2.4.0-boost148.patch
deleted file mode 100644
index a8b1aacc9cc3..000000000000
--- a/dev-games/simgear/files/simgear-2.4.0-boost148.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- simgear-2.4.0/simgear/structure/Singleton.hxx
-+++ simgear-2.4.0/simgear/structure/Singleton.hxx
-@@ -1,7 +1,7 @@
- #ifndef SIMGEAR_SINGLETON_HXX
- #define SIMGEAR_SINGLETON_HXX 1
-
--#include <boost/pool/detail/singleton.hpp>
-+#include "boost/thread/detail/singleton.hpp"
-
- #include <osg/Referenced>
- #include <osg/ref_ptr>
-@@ -22,7 +22,7 @@
- static Class* instance()
- {
- Class& singleton
-- = boost::details::pool::singleton_default<Class>::instance();
-+ = boost::detail::thread::singleton<Class>::instance();
- return &singleton;
- }
- };
-@@ -38,7 +38,7 @@
- static RefClass* instance()
- {
- SingletonRefPtr& singleton
-- = boost::details::pool::singleton_default<SingletonRefPtr>::instance();
-+ = boost::detail::thread::singleton<SingletonRefPtr>::instance();
- return singleton.ptr.get();
- }
- private:
diff --git a/dev-games/simgear/simgear-2.10.0.ebuild b/dev-games/simgear/simgear-2.10.0.ebuild
new file mode 100644
index 000000000000..ba957a05c755
--- /dev/null
+++ b/dev-games/simgear/simgear-2.10.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/simgear/simgear-2.10.0.ebuild,v 1.1 2013/02/20 21:21:42 reavertm Exp $
+
+EAPI=5
+
+inherit eutils cmake-utils
+
+DESCRIPTION="Development library for simulation games"
+HOMEPAGE="http://www.simgear.org/"
+SRC_URI="http://mirrors.ibiblio.org/pub/mirrors/simgear/ftp/Source/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE="debug jpeg subversion test"
+
+COMMON_DEPEND="
+ dev-libs/expat
+ >=dev-games/openscenegraph-3.0.1
+ media-libs/openal
+ sys-libs/zlib
+ virtual/opengl
+ jpeg? ( virtual/jpeg )
+ subversion? (
+ dev-libs/apr
+ dev-vcs/subversion
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/boost-1.44
+"
+RDEPEND="${COMMON_DEPEND}"
+
+DOCS=(AUTHORS ChangeLog NEWS README Thanks)
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_RTI=OFF
+ -DENABLE_SOUND=ON
+ -DSIMGEAR_HEADLESS=OFF
+ -DSIMGEAR_SHARED=ON
+ -DSYSTEM_EXPAT=ON
+ $(cmake-utils_use jpeg JPEG_FACTORY)
+ $(cmake-utils_use_enable subversion LIBSVN)
+ $(cmake-utils_use_enable test TESTS)
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-games/simgear/simgear-2.4.0.ebuild b/dev-games/simgear/simgear-2.4.0.ebuild
deleted file mode 100644
index 721ab823196a..000000000000
--- a/dev-games/simgear/simgear-2.4.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/simgear/simgear-2.4.0.ebuild,v 1.5 2012/07/10 04:52:20 xmw Exp $
-
-EAPI=4
-
-inherit autotools-utils eutils
-
-DESCRIPTION="Development library for simulation games"
-HOMEPAGE="http://www.simgear.org/"
-SRC_URI="http://mirrors.ibiblio.org/pub/mirrors/simgear/ftp/Source/${P}.tar.bz2"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="debug"
-
-RESTRICT="test"
-
-RDEPEND=">=dev-games/openscenegraph-3.0.1
- >=dev-libs/boost-1.37
- dev-vcs/subversion
- media-libs/freealut
- media-libs/openal
- >=media-libs/plib-1.8.5"
-DEPEND="${RDEPEND}"
-
-DOCS=(AUTHORS NEWS TODO)
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-boost148.patch
-}
-
-src_configure() {
- myeconfargs=(
- --with-jpeg-factory
- $(use_with debug logging)
- )
-
- autotools-utils_src_configure
-}