diff options
author | Michael Sterrett <mr_bones_@gentoo.org> | 2011-04-08 03:21:08 +0000 |
---|---|---|
committer | Michael Sterrett <mr_bones_@gentoo.org> | 2011-04-08 03:21:08 +0000 |
commit | 66945337f3cf0a62be873218048942bbf05d448a (patch) | |
tree | 908bd9638d61e93c8e5d8441464201e0a09d7637 /dev-games | |
parent | Mask app-crypt/ekey-egd-linux for removal. (diff) | |
download | gentoo-2-66945337f3cf0a62be873218048942bbf05d448a.tar.gz gentoo-2-66945337f3cf0a62be873218048942bbf05d448a.tar.bz2 gentoo-2-66945337f3cf0a62be873218048942bbf05d448a.zip |
add patch for building with gcc46 (bug #362371)
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'dev-games')
-rw-r--r-- | dev-games/irrlicht/ChangeLog | 7 | ||||
-rw-r--r-- | dev-games/irrlicht/files/irrlicht-1.7.2-config.patch | 4 | ||||
-rw-r--r-- | dev-games/irrlicht/files/irrlicht-1.7.2-gcc46.patch | 11 | ||||
-rw-r--r-- | dev-games/irrlicht/files/irrlicht-1.7.2-gentoo.patch | 10 | ||||
-rw-r--r-- | dev-games/irrlicht/irrlicht-1.7.2.ebuild | 5 |
5 files changed, 26 insertions, 11 deletions
diff --git a/dev-games/irrlicht/ChangeLog b/dev-games/irrlicht/ChangeLog index bf5de1bc5a1f..d7ca513d2630 100644 --- a/dev-games/irrlicht/ChangeLog +++ b/dev-games/irrlicht/ChangeLog @@ -1,6 +1,11 @@ # ChangeLog for dev-games/irrlicht # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2 -# $Header: /var/cvsroot/gentoo-x86/dev-games/irrlicht/ChangeLog,v 1.48 2011/03/04 12:59:22 ranger Exp $ +# $Header: /var/cvsroot/gentoo-x86/dev-games/irrlicht/ChangeLog,v 1.49 2011/04/08 03:21:08 mr_bones_ Exp $ + + 08 Apr 2011; Michael Sterrett <mr_bones_@gentoo.org> + irrlicht-1.7.2.ebuild, files/irrlicht-1.7.2-config.patch, + +files/irrlicht-1.7.2-gcc46.patch, files/irrlicht-1.7.2-gentoo.patch: + add patch for building with gcc46 (bug #362371) 04 Mar 2011; Brent Baude <ranger@gentoo.org> irrlicht-1.7.2.ebuild: stable ppc, bug 353991 diff --git a/dev-games/irrlicht/files/irrlicht-1.7.2-config.patch b/dev-games/irrlicht/files/irrlicht-1.7.2-config.patch index d71044e502f3..da553ed8ab58 100644 --- a/dev-games/irrlicht/files/irrlicht-1.7.2-config.patch +++ b/dev-games/irrlicht/files/irrlicht-1.7.2-config.patch @@ -1,5 +1,5 @@ ---- include/IrrCompileConfig.h.old 2010-03-14 17:36:10.000000000 +0100 -+++ include/IrrCompileConfig.h 2010-03-14 18:25:01.000000000 +0100 +--- include/IrrCompileConfig.h.old ++++ include/IrrCompileConfig.h @@ -176,7 +176,7 @@ //! Define _IRR_USE_NON_SYSTEM_JPEG_LIB_ to let irrlicht use the jpeglib which comes with irrlicht. /** If this is commented out, Irrlicht will try to compile using the jpeg lib installed in the system. diff --git a/dev-games/irrlicht/files/irrlicht-1.7.2-gcc46.patch b/dev-games/irrlicht/files/irrlicht-1.7.2-gcc46.patch new file mode 100644 index 000000000000..bb7ef961238b --- /dev/null +++ b/dev-games/irrlicht/files/irrlicht-1.7.2-gcc46.patch @@ -0,0 +1,11 @@ +--- ./source/Irrlicht/Makefile.orig ++++ ./source/Irrlicht/Makefile +@@ -75,7 +75,7 @@ + LIB_PATH = ../../lib/$(SYSTEM)
+ INSTALL_DIR = /usr/local/lib
+ sharedlib install: SHARED_LIB = libIrrlicht.so
+-staticlib sharedlib: LDFLAGS += --no-export-all-symbols --add-stdcall-alias
++staticlib sharedlib: LDFLAGS += --Wl,--add-stdcall-alias
+ sharedlib: LDFLAGS += -L/usr/X11R6/lib$(LIBSELECT) -lGL -lXxf86vm
+ staticlib sharedlib: CXXINCS += -I/usr/X11R6/include
+
diff --git a/dev-games/irrlicht/files/irrlicht-1.7.2-gentoo.patch b/dev-games/irrlicht/files/irrlicht-1.7.2-gentoo.patch index 781b0aa89add..e23c98f243ae 100644 --- a/dev-games/irrlicht/files/irrlicht-1.7.2-gentoo.patch +++ b/dev-games/irrlicht/files/irrlicht-1.7.2-gentoo.patch @@ -1,6 +1,5 @@ -diff -ru irrlicht-1.7.2.orig/source/Irrlicht/CImageLoaderPNG.cpp irrlicht-1.7.2/source/Irrlicht/CImageLoaderPNG.cpp ---- irrlicht-1.7.2.orig/source/Irrlicht/CImageLoaderPNG.cpp 2010-10-24 09:42:46.000000000 -0400 -+++ irrlicht-1.7.2/source/Irrlicht/CImageLoaderPNG.cpp 2011-01-03 12:14:01.213269510 -0500 +--- irrlicht-1.7.2.orig/source/Irrlicht/CImageLoaderPNG.cpp ++++ irrlicht-1.7.2/source/Irrlicht/CImageLoaderPNG.cpp @@ -162,7 +162,7 @@ if (BitDepth < 8)
{
@@ -10,9 +9,8 @@ diff -ru irrlicht-1.7.2.orig/source/Irrlicht/CImageLoaderPNG.cpp irrlicht-1.7.2/ else
png_set_packing(png_ptr);
}
-diff -ru irrlicht-1.7.2.orig/source/Irrlicht/Makefile irrlicht-1.7.2/source/Irrlicht/Makefile ---- irrlicht-1.7.2.orig/source/Irrlicht/Makefile 2010-10-31 17:53:30.000000000 -0400 -+++ irrlicht-1.7.2/source/Irrlicht/Makefile 2011-01-03 12:15:41.593882605 -0500 +--- irrlicht-1.7.2.orig/source/Irrlicht/Makefile ++++ irrlicht-1.7.2/source/Irrlicht/Makefile @@ -39,11 +39,7 @@ IRRIOOBJ = CFileList.o CFileSystem.o CLimitReadFile.o CMemoryFile.o CReadFile.o CWriteFile.o CXMLReader.o CXMLWriter.o CZipReader.o CPakReader.o CNPKReader.o CTarReader.o CMountPointReader.o irrXML.o CAttributes.o lzma/LzmaDec.o
IRROTHEROBJ = CIrrDeviceSDL.o CIrrDeviceLinux.o CIrrDeviceConsole.o CIrrDeviceStub.o CIrrDeviceWin32.o CIrrDeviceFB.o CLogger.o COSOperator.o Irrlicht.o os.o
diff --git a/dev-games/irrlicht/irrlicht-1.7.2.ebuild b/dev-games/irrlicht/irrlicht-1.7.2.ebuild index 79361a5250f2..fb89de0dab23 100644 --- a/dev-games/irrlicht/irrlicht-1.7.2.ebuild +++ b/dev-games/irrlicht/irrlicht-1.7.2.ebuild @@ -1,6 +1,6 @@ # Copyright 1999-2011 Gentoo Foundation # Distributed under the terms of the GNU General Public License v2 -# $Header: /var/cvsroot/gentoo-x86/dev-games/irrlicht/irrlicht-1.7.2.ebuild,v 1.4 2011/03/04 12:59:22 ranger Exp $ +# $Header: /var/cvsroot/gentoo-x86/dev-games/irrlicht/irrlicht-1.7.2.ebuild,v 1.5 2011/04/08 03:21:08 mr_bones_ Exp $ EAPI=2 inherit eutils toolchain-funcs @@ -32,7 +32,8 @@ src_prepare() { edos2unix include/IrrCompileConfig.h epatch \ "${FILESDIR}"/${P}-config.patch \ - "${FILESDIR}"/${P}-demoMake.patch + "${FILESDIR}"/${P}-demoMake.patch \ + "${FILESDIR}"/${P}-gcc46.patch sed -i \ -e 's:\.\./\.\./media:../media:g' \ |