summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-05-20 14:46:58 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-05-20 14:46:58 +0000
commit537ae780d4f45a2271a852576b822c8586f2c8ef (patch)
tree639d7e18a81bc7de81d9496957512a725137bf87 /dev-games
parentmarking gst-plugins-modplug-0.10.11 ~ppc for bug 266927 (diff)
downloadgentoo-2-537ae780d4f45a2271a852576b822c8586f2c8ef.tar.gz
gentoo-2-537ae780d4f45a2271a852576b822c8586f2c8ef.tar.bz2
gentoo-2-537ae780d4f45a2271a852576b822c8586f2c8ef.zip
Fix build with gcc-4.4.0 Bug #270116
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/simgear/ChangeLog6
-rw-r--r--dev-games/simgear/files/simgear-1.9.1-gcc44.patch10
-rw-r--r--dev-games/simgear/simgear-1.9.1.ebuild7
3 files changed, 21 insertions, 2 deletions
diff --git a/dev-games/simgear/ChangeLog b/dev-games/simgear/ChangeLog
index 686f8e052474..646ed55d9676 100644
--- a/dev-games/simgear/ChangeLog
+++ b/dev-games/simgear/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-games/simgear
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/simgear/ChangeLog,v 1.39 2009/03/20 14:52:36 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/simgear/ChangeLog,v 1.40 2009/05/20 14:46:57 tupone Exp $
+
+ 20 May 2009; Alfredo Tupone <tupone@gentoo.org>
+ +files/simgear-1.9.1-gcc44.patch, simgear-1.9.1.ebuild:
+ Fix build with gcc-4.4.0 Bug #270116 by Victor Ostorga
20 Mar 2009; Joseph Jezak <josejx@gentoo.org> simgear-1.9.1.ebuild:
Marked ~ppc for bug #252202.
diff --git a/dev-games/simgear/files/simgear-1.9.1-gcc44.patch b/dev-games/simgear/files/simgear-1.9.1-gcc44.patch
new file mode 100644
index 000000000000..96e6a1c8c702
--- /dev/null
+++ b/dev-games/simgear/files/simgear-1.9.1-gcc44.patch
@@ -0,0 +1,10 @@
+--- simgear/debug/logstream.hxx.old 2009-05-20 16:27:26.000000000 +0200
++++ simgear/debug/logstream.hxx 2009-05-20 16:27:59.000000000 +0200
+@@ -30,6 +30,7 @@
+ #ifdef _MSC_VER
+ # include <windows.h>
+ #endif
++#include <cstdio>
+
+ #include <streambuf>
+ #include <ostream>
diff --git a/dev-games/simgear/simgear-1.9.1.ebuild b/dev-games/simgear/simgear-1.9.1.ebuild
index a826320b991c..546e453d11dd 100644
--- a/dev-games/simgear/simgear-1.9.1.ebuild
+++ b/dev-games/simgear/simgear-1.9.1.ebuild
@@ -1,6 +1,7 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/simgear/simgear-1.9.1.ebuild,v 1.2 2009/03/20 14:52:36 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/simgear/simgear-1.9.1.ebuild,v 1.3 2009/05/20 14:46:57 tupone Exp $
+EAPI=2
inherit eutils
@@ -25,6 +26,10 @@ RESTRICT="test"
S=${WORKDIR}/${MY_P}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+}
+
src_install() {
make DESTDIR="${D}" install || die "make install failed"
dodoc NEWS AUTHORS TODO