summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-09-02 12:04:56 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-09-02 12:04:56 +0000
commit1063d8ef5b8989d06de1e17f5d94742b49cae406 (patch)
tree45ce5c4d0cfae7cd0b44540d895d9872a40eb9a4 /dev-games
parentfix stupid typo in HOMEPAGE (diff)
downloadgentoo-2-1063d8ef5b8989d06de1e17f5d94742b49cae406.tar.gz
gentoo-2-1063d8ef5b8989d06de1e17f5d94742b49cae406.tar.bz2
gentoo-2-1063d8ef5b8989d06de1e17f5d94742b49cae406.zip
Version bump
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/libgrapple/ChangeLog8
-rw-r--r--dev-games/libgrapple/files/libgrapple-0.9.8-build.patch13
-rw-r--r--dev-games/libgrapple/libgrapple-0.9.8.ebuild38
3 files changed, 58 insertions, 1 deletions
diff --git a/dev-games/libgrapple/ChangeLog b/dev-games/libgrapple/ChangeLog
index 2c75b60cc60d..5c57574beff6 100644
--- a/dev-games/libgrapple/ChangeLog
+++ b/dev-games/libgrapple/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-games/libgrapple
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/libgrapple/ChangeLog,v 1.5 2009/05/07 21:01:58 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/libgrapple/ChangeLog,v 1.6 2009/09/02 12:04:55 nyhm Exp $
+
+*libgrapple-0.9.8 (02 Sep 2009)
+
+ 02 Sep 2009; Tristan Heaven <nyhm@gentoo.org> +libgrapple-0.9.8.ebuild,
+ +files/libgrapple-0.9.8-build.patch:
+ Version bump
07 May 2009; Tristan Heaven <nyhm@gentoo.org> libgrapple-0.9.7.ebuild:
Add src_test
diff --git a/dev-games/libgrapple/files/libgrapple-0.9.8-build.patch b/dev-games/libgrapple/files/libgrapple-0.9.8-build.patch
new file mode 100644
index 000000000000..2f4af2ee55d3
--- /dev/null
+++ b/dev-games/libgrapple/files/libgrapple-0.9.8-build.patch
@@ -0,0 +1,13 @@
+--- configure.in
++++ configure.in
+@@ -54,8 +54,8 @@
+ ACX_PTHREAD(have_pthreads=yes, have_pthreads=no)
+
+ dnl Check for SSL
+-AC_ARG_ENABLE([openssl], AC_HELP_STRING([--disable-openssl], [do not compile with OpenSSL support]), [want_ssl=no], [want_ssl=yes])
+-if test "$want_ssl" = "yes"; then
++AC_ARG_ENABLE([openssl], AS_HELP_STRING([--disable-openssl], [do not compile with OpenSSL support]))
++if test "$enable_openssl" != "no"; then
+ PKG_CHECK_MODULES([OPENSSL], [openssl])
+ CFLAGS="$CFLAGS $OPENSSL_CFLAGS -DSOCK_SSL"
+ LIBS="$LIBS $OPENSSL_LIBS"
diff --git a/dev-games/libgrapple/libgrapple-0.9.8.ebuild b/dev-games/libgrapple/libgrapple-0.9.8.ebuild
new file mode 100644
index 000000000000..82d36cb593c3
--- /dev/null
+++ b/dev-games/libgrapple/libgrapple-0.9.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/libgrapple/libgrapple-0.9.8.ebuild,v 1.1 2009/09/02 12:04:55 nyhm Exp $
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="A high level network layer for multiuser applications"
+HOMEPAGE="http://grapple.linuxgamepublishing.com/"
+SRC_URI="http://osfiles.linuxgamepublishing.com/${P}.tbz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl"
+
+RDEPEND="ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable ssl openssl)
+}
+
+src_test() {
+ test/unittest | tee "${T}"/test.log
+ tail -n 1 "${T}"/test.log | grep -q " 0 fail" || die "test failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc CREDITS README* UPDATES
+}