summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-01-09 06:06:19 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-01-09 06:06:19 +0000
commit5a6cfc6adbd7a9f3d8d16753dfc42849bba4ac83 (patch)
treef6fff96e2cbe35208f4e42406bcc312a4b8ee815 /dev-games/openscenegraph
parentBump -5.11 development version (diff)
downloadgentoo-2-5a6cfc6adbd7a9f3d8d16753dfc42849bba4ac83.tar.gz
gentoo-2-5a6cfc6adbd7a9f3d8d16753dfc42849bba4ac83.tar.bz2
gentoo-2-5a6cfc6adbd7a9f3d8d16753dfc42849bba4ac83.zip
Fix compability with xine-lib >= 1.2.x wrt #397643 by Martin von Gagern
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-games/openscenegraph')
-rw-r--r--dev-games/openscenegraph/ChangeLog8
-rw-r--r--dev-games/openscenegraph/files/openscenegraph-3.0.1-xinelib12x.patch19
-rw-r--r--dev-games/openscenegraph/openscenegraph-3.0.1.ebuild9
3 files changed, 30 insertions, 6 deletions
diff --git a/dev-games/openscenegraph/ChangeLog b/dev-games/openscenegraph/ChangeLog
index d903010d935e..7152589a6b1a 100644
--- a/dev-games/openscenegraph/ChangeLog
+++ b/dev-games/openscenegraph/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-games/openscenegraph
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/openscenegraph/ChangeLog,v 1.44 2011/11/17 18:57:24 reavertm Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/openscenegraph/ChangeLog,v 1.45 2012/01/09 06:06:19 ssuominen Exp $
+
+ 09 Jan 2012; Samuli Suominen <ssuominen@gentoo.org>
+ openscenegraph-3.0.1.ebuild, +files/openscenegraph-3.0.1-xinelib12x.patch:
+ Fix compability with xine-lib >= 1.2.x wrt #397643 by Martin von Gagern
17 Nov 2011; Maciej Mrozowski <reavertm@gentoo.org>
+files/openscenegraph-3.0.1-libav-0.7.patch, openscenegraph-3.0.1.ebuild:
diff --git a/dev-games/openscenegraph/files/openscenegraph-3.0.1-xinelib12x.patch b/dev-games/openscenegraph/files/openscenegraph-3.0.1-xinelib12x.patch
new file mode 100644
index 000000000000..a69a6604e003
--- /dev/null
+++ b/dev-games/openscenegraph/files/openscenegraph-3.0.1-xinelib12x.patch
@@ -0,0 +1,19 @@
+http://bugs.gentoo.org/397643
+
+--- src/osgPlugins/xine/video_out_rgb.c
++++ src/osgPlugins/xine/video_out_rgb.c
+@@ -2769,8 +2769,14 @@ init_class(xine_t* xine, void* vo_visual
+ clear(rgb_class, sizeof(rgbout_class_t));
+
+ rgb_class->driver_class.open_plugin = open_plugin;
++#if XINE_MAJOR_VERSION < 1 || (XINE_MAJOR_VERSION == 1 && XINE_MINOR_VERSION < 2)
+ rgb_class->driver_class.get_identifier = get_identifier;
+ rgb_class->driver_class.get_description = get_description;
++#else
++ rgb_class->driver_class.identifier = get_identifier(NULL);
++ rgb_class->driver_class.description = get_description(NULL);
++#endif
++
+ rgb_class->driver_class.dispose = dispose_class;
+
+ return(rgb_class);
diff --git a/dev-games/openscenegraph/openscenegraph-3.0.1.ebuild b/dev-games/openscenegraph/openscenegraph-3.0.1.ebuild
index 5b591903b193..dfd480862cab 100644
--- a/dev-games/openscenegraph/openscenegraph-3.0.1.ebuild
+++ b/dev-games/openscenegraph/openscenegraph-3.0.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/openscenegraph/openscenegraph-3.0.1.ebuild,v 1.2 2011/11/17 18:57:24 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/openscenegraph/openscenegraph-3.0.1.ebuild,v 1.3 2012/01/09 06:06:19 ssuominen Exp $
EAPI=3
@@ -83,8 +83,9 @@ S=${WORKDIR}/${MY_P}
DOCS=(AUTHORS.txt ChangeLog NEWS.txt)
PATCHES=(
- "${FILESDIR}/${P}-cmake.patch"
- "${FILESDIR}/${PN}-3.0.1-libav-0.7.patch"
+ "${FILESDIR}"/${PN}-3.0.1-cmake.patch
+ "${FILESDIR}"/${PN}-3.0.1-libav-0.7.patch
+ "${FILESDIR}"/${PN}-3.0.1-xinelib12x.patch
)
src_configure() {