summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-06-16 15:40:45 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-06-16 15:40:45 +0000
commitac72f21c77108d73f3d2c75ba2c308ba2ab4dc7c (patch)
tree45692e1f7bc2970b53f08f1881ae9a8a67ce77af /dev-games/ogre
parentRevert truncation of ChangeLog (diff)
downloadgentoo-2-ac72f21c77108d73f3d2c75ba2c308ba2ab4dc7c.tar.gz
gentoo-2-ac72f21c77108d73f3d2c75ba2c308ba2ab4dc7c.tar.bz2
gentoo-2-ac72f21c77108d73f3d2c75ba2c308ba2ab4dc7c.zip
remove test useflag completely and disable build of tests wrt bug #412675
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'dev-games/ogre')
-rw-r--r--dev-games/ogre/ChangeLog6
-rw-r--r--dev-games/ogre/ogre-1.7.4-r1.ebuild9
-rw-r--r--dev-games/ogre/ogre-1.8.0.ebuild9
3 files changed, 13 insertions, 11 deletions
diff --git a/dev-games/ogre/ChangeLog b/dev-games/ogre/ChangeLog
index 93a61b921064..6c46b4b1541b 100644
--- a/dev-games/ogre/ChangeLog
+++ b/dev-games/ogre/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-games/ogre
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ChangeLog,v 1.80 2012/06/13 07:03:30 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ChangeLog,v 1.81 2012/06/16 15:40:45 hasufell Exp $
+
+ 16 Jun 2012; Julian Ospald <hasufell@gentoo.org> ogre-1.7.4-r1.ebuild,
+ ogre-1.8.0.ebuild:
+ remove test useflag completely and disable build of tests wrt bug #412675
13 Jun 2012; Michael Sterrett <mr_bones_@gentoo.org> -ogre-1.7.4.ebuild:
old
diff --git a/dev-games/ogre/ogre-1.7.4-r1.ebuild b/dev-games/ogre/ogre-1.7.4-r1.ebuild
index 04befd3fc1b4..6c88f8dd3645 100644
--- a/dev-games/ogre/ogre-1.7.4-r1.ebuild
+++ b/dev-games/ogre/ogre-1.7.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ogre-1.7.4-r1.ebuild,v 1.2 2012/06/04 17:16:42 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ogre-1.7.4-r1.ebuild,v 1.3 2012/06/16 15:40:45 hasufell Exp $
EAPI="4"
@@ -14,7 +14,7 @@ SRC_URI="mirror://sourceforge/${PN}/${PN}_src_v${MY_PV}.tar.bz2"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~x86"
-IUSE="+boost cg doc double-precision examples +freeimage ois +opengl poco profile tbb test threads tools +zip"
+IUSE="+boost cg doc double-precision examples +freeimage ois +opengl poco profile tbb threads tools +zip"
REQUIRED_USE="threads? ( || ( boost poco tbb ) )"
RESTRICT="test" #139905
@@ -37,8 +37,7 @@ RDEPEND="media-libs/freetype:2
DEPEND="${RDEPEND}
x11-proto/xf86vidmodeproto
virtual/pkgconfig
- doc? ( app-doc/doxygen )
- test? ( dev-util/cppunit )"
+ doc? ( app-doc/doxygen )"
S=${WORKDIR}/${PN}_src_v${MY_PV}
@@ -65,7 +64,7 @@ src_configure() {
$(cmake-utils_use freeimage OGRE_CONFIG_ENABLE_FREEIMAGE)
$(cmake-utils_use opengl OGRE_BUILD_RENDERSYSTEM_GL)
$(cmake-utils_use profile OGRE_PROFILING)
- $(cmake-utils_use test OGRE_BUILD_TESTS)
+ -DOGRE_BUILD_TESTS=FALSE
$(usex threads "-DOGRE_CONFIG_THREADS=2" "-DOGRE_CONFIG_THREADS=0")
$(cmake-utils_use tools OGRE_BUILD_TOOLS)
$(cmake-utils_use zip OGRE_CONFIG_ENABLE_ZIP)
diff --git a/dev-games/ogre/ogre-1.8.0.ebuild b/dev-games/ogre/ogre-1.8.0.ebuild
index c3c689827110..4ebe1d2dad9e 100644
--- a/dev-games/ogre/ogre-1.8.0.ebuild
+++ b/dev-games/ogre/ogre-1.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ogre-1.8.0.ebuild,v 1.3 2012/06/13 01:52:54 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ogre-1.8.0.ebuild,v 1.4 2012/06/16 15:40:45 hasufell Exp $
EAPI=4
inherit eutils cmake-utils
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/${PN}/${PN}_src_v${MY_PV}.tar.bz2"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+boost cg doc double-precision examples +freeimage gles2 ois +opengl poco profile tbb test threads tools +zip"
+IUSE="+boost cg doc double-precision examples +freeimage gles2 ois +opengl poco profile tbb threads tools +zip"
REQUIRED_USE="threads? ( || ( boost poco tbb ) )"
RESTRICT="test" #139905
@@ -38,8 +38,7 @@ RDEPEND="media-libs/freetype:2
DEPEND="${RDEPEND}
x11-proto/xf86vidmodeproto
virtual/pkgconfig
- doc? ( app-doc/doxygen )
- test? ( dev-util/cppunit )"
+ doc? ( app-doc/doxygen )"
S=${WORKDIR}/${PN}_src_v${MY_PV}
@@ -69,7 +68,7 @@ src_configure() {
-DOGRE_BUILD_RENDERSYSTEM_GLES=OFF
$(cmake-utils_use gles2 OGRE_BUILD_RENDERSYSTEM_GLES2)
$(cmake-utils_use profile OGRE_PROFILING)
- $(cmake-utils_use test OGRE_BUILD_TESTS)
+ -DOGRE_BUILD_TESTS=FALSE
$(usex threads "-DOGRE_CONFIG_THREADS=2" "-DOGRE_CONFIG_THREADS=0")
$(cmake-utils_use tools OGRE_BUILD_TOOLS)
$(cmake-utils_use zip OGRE_CONFIG_ENABLE_ZIP)