summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-04-27 04:52:22 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-04-27 04:52:22 +0000
commit82f2ce924ad24042a73ee97434c2d3f998acdd3f (patch)
treee4d0dcabdd0ce55cbf966dc77fad0dcba885fa86 /dev-games/guichan/guichan-0.8.1.ebuild
parentmask newer guichan since tmw doesn't build against it. (diff)
downloadgentoo-2-82f2ce924ad24042a73ee97434c2d3f998acdd3f.tar.gz
gentoo-2-82f2ce924ad24042a73ee97434c2d3f998acdd3f.tar.bz2
gentoo-2-82f2ce924ad24042a73ee97434c2d3f998acdd3f.zip
version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-games/guichan/guichan-0.8.1.ebuild')
-rw-r--r--dev-games/guichan/guichan-0.8.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-games/guichan/guichan-0.8.1.ebuild b/dev-games/guichan/guichan-0.8.1.ebuild
new file mode 100644
index 000000000000..d70d717226cf
--- /dev/null
+++ b/dev-games/guichan/guichan-0.8.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/guichan-0.8.1.ebuild,v 1.1 2008/04/27 04:52:22 mr_bones_ Exp $
+
+DESCRIPTION="a portable C++ GUI library designed for games using Allegro, SDL and/or OpenGL"
+HOMEPAGE="http://guichan.sourceforge.net/"
+SRC_URI="http://guichan.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="allegro opengl sdl"
+
+DEPEND="allegro? ( media-libs/allegro )
+ opengl? ( virtual/opengl )
+ sdl? (
+ media-libs/libsdl
+ media-libs/sdl-image
+ )"
+
+src_compile() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable allegro) \
+ $(use_enable opengl) \
+ $(use_enable sdl) \
+ $(use_enable sdl sdlimage) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}