summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-06-23 23:59:04 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-06-23 23:59:04 +0000
commit6bf77c3e6abfe58d6a6248b1e36a4212e2359998 (patch)
tree2706bc118c7567f9ea6f73973a5ec10907ad7b10 /dev-games/clanlib
parentcinelerra: fix libtool 2.2 build (diff)
downloadgentoo-2-6bf77c3e6abfe58d6a6248b1e36a4212e2359998.tar.gz
gentoo-2-6bf77c3e6abfe58d6a6248b1e36a4212e2359998.tar.bz2
gentoo-2-6bf77c3e6abfe58d6a6248b1e36a4212e2359998.zip
old
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-games/clanlib')
-rw-r--r--dev-games/clanlib/clanlib-0.7.8-r2.ebuild84
-rw-r--r--dev-games/clanlib/files/0.7.8-install-opengl-wrap.patch11
-rw-r--r--dev-games/clanlib/files/0.7.8-port.patch11
-rw-r--r--dev-games/clanlib/files/clanlib-0.7.8-gcc41.patch37
-rw-r--r--dev-games/clanlib/files/clanlib-0.7.8-ndebug.patch21
-rw-r--r--dev-games/clanlib/files/clanlib-0.7.8-refreshfix.patch11
6 files changed, 0 insertions, 175 deletions
diff --git a/dev-games/clanlib/clanlib-0.7.8-r2.ebuild b/dev-games/clanlib/clanlib-0.7.8-r2.ebuild
deleted file mode 100644
index 569c8de1d5fc..000000000000
--- a/dev-games/clanlib/clanlib-0.7.8-r2.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/clanlib-0.7.8-r2.ebuild,v 1.5 2008/06/20 16:07:24 gentoofan23 Exp $
-
-inherit flag-o-matic eutils
-
-DESCRIPTION="multi-platform game development library"
-HOMEPAGE="http://www.clanlib.org/"
-SRC_URI="http://www.clanlib.org/download/files/ClanLib-${PV}-1.tar.bz2"
-
-LICENSE="LGPL-2"
-SLOT="0.7"
-KEYWORDS="amd64 x86" #not big endian safe #82779
-IUSE="opengl sdl vorbis doc mikmod ipv6"
-
-# opengl keyword does not drop the GL/GLU requirement.
-# Autoconf files need to be fixed
-RDEPEND="media-libs/libpng
- media-libs/jpeg
- virtual/opengl
- virtual/glu
- sdl? (
- media-libs/libsdl
- media-libs/sdl-gfx
- )
- x11-libs/libXmu
- x11-libs/libXxf86vm
- mikmod? ( >=media-libs/libmikmod-3.1.9 )
- vorbis? ( media-libs/libvorbis )"
-DEPEND="${RDEPEND}
- x11-libs/libXt
- x11-proto/xf86vidmodeproto"
-
-S="${WORKDIR}/ClanLib-${PV}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- find . -name .cvsignore -exec rm -f '{}' \;
- epatch "${FILESDIR}"/${PV}-port.patch \
- "${FILESDIR}"/${PV}-install-opengl-wrap.patch \
- "${FILESDIR}"/${P}-gcc41.patch \
- "${FILESDIR}"/${P}-refreshfix.patch \
- "${FILESDIR}"/${P}-ndebug.patch
-
- if ! use doc ; then
- sed -i \
- -e '/^SUBDIRS/s:Documentation::' \
- Makefile.in \
- || die "sed Makefile.in failed"
- fi
-}
-
-src_compile() {
- #clanSound only controls mikmod/vorbis so there's
- # no need to pass --{en,dis}able-clanSound ...
- #clanDisplay only controls X, SDL, OpenGL plugins
- # so no need to pass --{en,dis}able-clanDisplay
- # also same reason why we don't have to use clanGUI
- econf \
- --enable-dyn \
- --enable-clanNetwork \
- --disable-dependency-tracking \
- $(use_enable x86 asm386) \
- $(use_enable doc docs) \
- $(use_enable opengl clanGL) \
- $(use_enable sdl clanSDL) \
- $(use_enable vorbis clanVorbis) \
- $(use_enable mikmod clanMikMod) \
- $(use_enable ipv6 getaddr) \
- || die
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- if use doc ; then
- dodir "/usr/share/doc/${PF}/html"
- mv "${D}/usr/share/doc/clanlib/"* "${D}/usr/share/doc/${PF}/html/"
- rm -rf "${D}/usr/share/doc/clanlib"
- cp -r Examples "${D}/usr/share/doc/${PF}/"
- fi
- dodoc CODING_STYLE CREDITS NEWS PATCHES README* INSTALL.linux
-}
diff --git a/dev-games/clanlib/files/0.7.8-install-opengl-wrap.patch b/dev-games/clanlib/files/0.7.8-install-opengl-wrap.patch
deleted file mode 100644
index c507552c419a..000000000000
--- a/dev-games/clanlib/files/0.7.8-install-opengl-wrap.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- Sources/API/Makefile.in.orig 2005-01-02 02:23:16.668233920 -0500
-+++ Sources/API/Makefile.in 2005-01-02 02:23:34.674496552 -0500
-@@ -211,7 +211,7 @@
- GL/opengl_state.h \
- GL/opengl_state_data.h \
- GL/viewpoint.h \
-- GL/light_source.h
-+ GL/light_source.h GL/opengl_wrap.h
-
-
- clanSmallJPEG_includes = smalljpeg.h SmallJPEG/jpgd_provider.h
diff --git a/dev-games/clanlib/files/0.7.8-port.patch b/dev-games/clanlib/files/0.7.8-port.patch
deleted file mode 100644
index a1da63f81147..000000000000
--- a/dev-games/clanlib/files/0.7.8-port.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- Sources/Network/Socket/ip_address_getsock.h.orig 2003-11-15 17:33:34.075094400 -0500
-+++ Sources/Network/Socket/ip_address_getsock.h 2003-11-15 17:33:39.688241072 -0500
-@@ -105,7 +105,7 @@
- unsigned int ip;
-
- // IP port in host byte order.
-- unsigned short port;
-+ unsigned int port;
- };
-
- #endif
diff --git a/dev-games/clanlib/files/clanlib-0.7.8-gcc41.patch b/dev-games/clanlib/files/clanlib-0.7.8-gcc41.patch
deleted file mode 100644
index 7dc4ca303f74..000000000000
--- a/dev-games/clanlib/files/clanlib-0.7.8-gcc41.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-diff -ur ClanLib-0.7.8-orig/Sources/API/Display/Collision/collision_outline.h ClanLib-0.7.8/Sources/API/Display/Collision/collision_outline.h
---- ClanLib-0.7.8-orig/Sources/API/Display/Collision/collision_outline.h 2005-12-18 03:11:10.000000000 -0500
-+++ ClanLib-0.7.8/Sources/API/Display/Collision/collision_outline.h 2005-12-18 03:12:20.000000000 -0500
-@@ -104,7 +104,7 @@
- const std::vector<CL_Pointf> &get_collision_points() const;
-
- //: Return the normal vectors of the other outline, at the points of collision.
-- const std::vector<CL_Pointf> &CL_CollisionOutline::get_collision_normals() const;
-+ const std::vector<CL_Pointf> &get_collision_normals() const;
-
- //! Operations:
- public:
-diff -ur ClanLib-0.7.8-orig/Sources/GUI/inputdialog_generic.h ClanLib-0.7.8/Sources/GUI/inputdialog_generic.h
---- ClanLib-0.7.8-orig/Sources/GUI/inputdialog_generic.h 2005-12-18 03:11:13.000000000 -0500
-+++ ClanLib-0.7.8/Sources/GUI/inputdialog_generic.h 2005-12-18 03:17:00.000000000 -0500
-@@ -37,7 +37,7 @@
- const std::string &button2,
- const std::string &button3);
-
-- CL_InputDialog_Generic::~CL_InputDialog_Generic();
-+ ~CL_InputDialog_Generic();
-
- CL_InputDialog *inputdialog;
-
-diff -ur ClanLib-0.7.8-orig/Sources/GUI/messagebox_generic.h ClanLib-0.7.8/Sources/GUI/messagebox_generic.h
---- ClanLib-0.7.8-orig/Sources/GUI/messagebox_generic.h 2005-12-18 03:11:13.000000000 -0500
-+++ ClanLib-0.7.8/Sources/GUI/messagebox_generic.h 2005-12-18 03:20:26.000000000 -0500
-@@ -31,7 +31,7 @@
- const std::string &button2,
- const std::string &button3);
-
-- CL_MessageBox_Generic::~CL_MessageBox_Generic();
-+ ~CL_MessageBox_Generic();
-
- std::string text;
-
-
diff --git a/dev-games/clanlib/files/clanlib-0.7.8-ndebug.patch b/dev-games/clanlib/files/clanlib-0.7.8-ndebug.patch
deleted file mode 100644
index e41bae1a3296..000000000000
--- a/dev-games/clanlib/files/clanlib-0.7.8-ndebug.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Patch for clanlib-0.7.8-r2 Bug 154513:
-
-Signal handler deinit() was not declared.
-
-This leads to a compilation failure when a release version
-rather than a debug version is built (-DNDEBUG).
-
-This patch adds the missing declaration, thus make the
-file compile with or without -DNDEBUG.
-
-diff -Naur clanlib-0.7.8-r2.orig/work/ClanLib-0.7.8/Sources/Core/System/Unix/init_linux.cpp clanlib-0.7.8-r2/work/ClanLib-0.7.8/Sources/Core/System/Unix/init_linux.cpp
---- clanlib-0.7.8-r2.orig/work/ClanLib-0.7.8/Sources/Core/System/Unix/init_linux.cpp 2003-09-19 10:33:02.000000000 +0000
-+++ clanlib-0.7.8-r2/work/ClanLib-0.7.8/Sources/Core/System/Unix/init_linux.cpp 2007-10-26 13:36:39.000000000 +0000
-@@ -52,6 +52,7 @@
- _begin_time = (long) tv.tv_sec*(long) 1000+(long) tv.tv_usec/(long) 1000;
-
- #ifdef NDEBUG
-+ sighandler_t deinit;
- signal(SIGSEGV, deinit);
- #endif
- }
diff --git a/dev-games/clanlib/files/clanlib-0.7.8-refreshfix.patch b/dev-games/clanlib/files/clanlib-0.7.8-refreshfix.patch
deleted file mode 100644
index 93c6dfd9f441..000000000000
--- a/dev-games/clanlib/files/clanlib-0.7.8-refreshfix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- Sources/Display/display_mode.cpp.original 2006-03-26 21:06:33.000000000 +0200
-+++ Sources/Display/display_mode.cpp 2006-03-26 21:08:30.000000000 +0200
-@@ -117,6 +117,8 @@
-
- for (int i = 0; i < nmodes; i++)
- {
-+ if (!vmodes[i]->htotal || !vmodes[i]->vtotal)
-+ continue;
- if ((vmodes[i]->flags) & V_DBLSCAN)
- refresh_rate = vmodes[i]->dotclock * 500 / (vmodes[i]->htotal * vmodes[i]->vtotal);
- else