summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-25 09:13:51 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-25 09:13:51 +0000
commit460e8f1cc16326856760abeccaff77d5f8ebe24d (patch)
tree5e522f1797cde2253510b80a6110c40f41944a3a /dev-games/clanlib
parentver bump (diff)
downloadgentoo-2-460e8f1cc16326856760abeccaff77d5f8ebe24d.tar.gz
gentoo-2-460e8f1cc16326856760abeccaff77d5f8ebe24d.tar.bz2
gentoo-2-460e8f1cc16326856760abeccaff77d5f8ebe24d.zip
ver bump
Diffstat (limited to 'dev-games/clanlib')
-rw-r--r--dev-games/clanlib/ChangeLog11
-rw-r--r--dev-games/clanlib/clanlib-0.7.5.ebuild71
-rw-r--r--dev-games/clanlib/files/0.7.5-gcc3.patch11
-rw-r--r--dev-games/clanlib/files/digest-clanlib-0.7.51
4 files changed, 91 insertions, 3 deletions
diff --git a/dev-games/clanlib/ChangeLog b/dev-games/clanlib/ChangeLog
index 88c8319f6866..4cc3ebcfba11 100644
--- a/dev-games/clanlib/ChangeLog
+++ b/dev-games/clanlib/ChangeLog
@@ -1,13 +1,18 @@
# ChangeLog for dev-games/clanlib
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/ChangeLog,v 1.7 2003/10/20 14:38:02 port001 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/ChangeLog,v 1.8 2003/10/25 09:13:51 vapier Exp $
+
+*clanlib-0.7.5 (25 Oct 2003)
+
+ 25 Oct 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump.
+
+*clanlib-0.7.4 (06 Oct 2003)
20 Oct 2003; Ian Leitch <port001@gentoo.org> clanlib-0.6.5-r1.ebuild,
clanlib-0.7.2-r1.ebuild, clanlib-0.7.4.ebuild:
Install the INSTALL.linux document. #31594
-*clanlib-0.7.4 (06 Oct 2003)
-
06 Oct 2003; Mike Frysinger <vapier@gentoo.org> :
Version bump to fix #30488.
diff --git a/dev-games/clanlib/clanlib-0.7.5.ebuild b/dev-games/clanlib/clanlib-0.7.5.ebuild
new file mode 100644
index 000000000000..1af64bdff0bd
--- /dev/null
+++ b/dev-games/clanlib/clanlib-0.7.5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/clanlib-0.7.5.ebuild,v 1.1 2003/10/25 09:13:51 vapier Exp $
+
+inherit flag-o-matic
+replace-flags -O? -O2
+
+DESCRIPTION="multi-platform game development library"
+HOMEPAGE="http://www.clanlib.org/"
+SRC_URI="http://www.clanlib.org/~sphair/download/ClanLib-${PV}-1.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0.7"
+KEYWORDS="x86"
+IUSE="opengl X sdl oggvorbis doc mikmod clanVoice clanJavaScript ipv6"
+
+DEPEND=">=media-libs/hermes-1.3.2
+ media-libs/libpng
+ media-libs/jpeg
+ opengl? ( virtual/opengl )
+ sdl? ( media-libs/libsdl )
+ X? ( virtual/x11 )
+ mikmod? ( >=media-libs/libmikmod-3.1.9 )
+ oggvorbis? ( media-libs/libvorbis )"
+
+S=${WORKDIR}/ClanLib-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-gcc3.patch
+}
+
+src_compile() {
+ #clanSound only controls mikmod/vorbis so theres
+ # no need to pass --{en,dis}able-clanSound ...
+ #clanDisplay only controls X, SDL, OpenGL plugins
+ # so no need to pass --{en,dis}able-clanDisplay
+ # also same reason why we dont have to use clanGUI
+ [ `use doc` ] || sed -i '/^SUBDIRS/s:Documentation::' Makefile.in
+ econf \
+ --libdir=/usr/lib/${P} \
+ `use_enable x86 asm386` \
+ `use_enable doc docs` \
+ --enable-dyn \
+ `use_enable clanVoice` \
+ `use_enable clanJavaScript` \
+ --enable-clanNetwork \
+ `use_enable opengl clanGL` \
+ `use_enable sdl clanSDL` \
+ `use_enable oggvorbis clanVorbis` \
+ `use_enable mikmod clanMikMod` \
+ `use_enable ipv6 getaddr` \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/share/doc/clanlib/* ${D}/usr/share/doc/${PF}/html/
+ rm -rf ${D}/usr/share/doc/clanlib
+ mv ${D}/usr/include/{ClanLib-*/ClanLib,${P}}
+ rm -rf ${D}/usr/include/ClanLib-*
+ dobin ${FILESDIR}/clanlib-config
+ dodoc CODING_STYLE CREDITS NEWS PATCHES README* INSTALL.linux
+}
+
+pkg_postinst() {
+ clanlib-config ${PV}
+}
diff --git a/dev-games/clanlib/files/0.7.5-gcc3.patch b/dev-games/clanlib/files/0.7.5-gcc3.patch
new file mode 100644
index 000000000000..0be07538c848
--- /dev/null
+++ b/dev-games/clanlib/files/0.7.5-gcc3.patch
@@ -0,0 +1,11 @@
+--- Sources/Network/Socket/socket_generic.h.orig 2003-10-25 05:09:55.768228944 -0400
++++ Sources/Network/Socket/socket_generic.h 2003-10-25 05:10:04.888842400 -0400
+@@ -114,7 +114,7 @@
+ //: Internal function to shutdown a socket that has disconnected
+ void disconnect();
+
+- friend CL_Socket_KeepAliveHelper;
++ friend class CL_Socket_KeepAliveHelper;
+ };
+
+ #endif
diff --git a/dev-games/clanlib/files/digest-clanlib-0.7.5 b/dev-games/clanlib/files/digest-clanlib-0.7.5
new file mode 100644
index 000000000000..dd2be7177bc2
--- /dev/null
+++ b/dev-games/clanlib/files/digest-clanlib-0.7.5
@@ -0,0 +1 @@
+MD5 4bd365ff0a083b47a602cd6eb63aad0b ClanLib-0.7.5-1.tar.bz2 3980134