summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-12-02 15:16:02 +0000
committerMike Frysinger <vapier@gentoo.org>2010-12-02 15:16:02 +0000
commit7ad6a4b897eab7f3b206e42e3d2f43f160bd6d7b (patch)
treeb7d1f4c21071dc0f4bf8d82b0c4da446298b36fa /dev-embedded
parentInitial package by me. (diff)
downloadgentoo-2-7ad6a4b897eab7f3b206e42e3d2f43f160bd6d7b.tar.gz
gentoo-2-7ad6a4b897eab7f3b206e42e3d2f43f160bd6d7b.tar.bz2
gentoo-2-7ad6a4b897eab7f3b206e42e3d2f43f160bd6d7b.zip
Initial package by me.
(Portage version: 2.2.0_alpha5/cvs/Linux x86_64)
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/sgpp-lite-arm-uclinux-bin/ChangeLog10
-rw-r--r--dev-embedded/sgpp-lite-arm-uclinux-bin/metadata.xml5
-rw-r--r--dev-embedded/sgpp-lite-arm-uclinux-bin/sgpp-lite-arm-uclinux-bin-2010.09.58.ebuild48
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-embedded/sgpp-lite-arm-uclinux-bin/ChangeLog b/dev-embedded/sgpp-lite-arm-uclinux-bin/ChangeLog
new file mode 100644
index 000000000000..01b26536ade8
--- /dev/null
+++ b/dev-embedded/sgpp-lite-arm-uclinux-bin/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-embedded/sgpp-lite-arm-uclinux-bin
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/sgpp-lite-arm-uclinux-bin/ChangeLog,v 1.1 2010/12/02 15:16:02 vapier Exp $
+
+*sgpp-lite-arm-uclinux-bin-2010.09.58 (02 Dec 2010)
+
+ 02 Dec 2010; Mike Frysinger <vapier@gentoo.org>
+ +sgpp-lite-arm-uclinux-bin-2010.09.58.ebuild, +metadata.xml:
+ Initial package by me.
+
diff --git a/dev-embedded/sgpp-lite-arm-uclinux-bin/metadata.xml b/dev-embedded/sgpp-lite-arm-uclinux-bin/metadata.xml
new file mode 100644
index 000000000000..92114080841c
--- /dev/null
+++ b/dev-embedded/sgpp-lite-arm-uclinux-bin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>dev-embedded</herd>
+</pkgmetadata>
diff --git a/dev-embedded/sgpp-lite-arm-uclinux-bin/sgpp-lite-arm-uclinux-bin-2010.09.58.ebuild b/dev-embedded/sgpp-lite-arm-uclinux-bin/sgpp-lite-arm-uclinux-bin-2010.09.58.ebuild
new file mode 100644
index 000000000000..f1a67a82a729
--- /dev/null
+++ b/dev-embedded/sgpp-lite-arm-uclinux-bin/sgpp-lite-arm-uclinux-bin-2010.09.58.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/sgpp-lite-arm-uclinux-bin/sgpp-lite-arm-uclinux-bin-2010.09.58.ebuild,v 1.1 2010/12/02 15:16:02 vapier Exp $
+
+CPU="arm"
+TARGET="arm-uclinuxeabi"
+HOST="i686-pc-linux-gnu"
+MY_P="${CPU}-${PV%.*}-${PV##*.}-${TARGET}-${HOST}"
+
+DESCRIPTION="regular, validated releases of the GNU Toolchain for ${CPU} processors by CodeSourcery"
+HOMEPAGE="http://www.codesourcery.com/sgpp/lite/${CPU}"
+SRC_URI="http://www.codesourcery.com/public/gnu_toolchain/${TARGET}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+RESTRICT="strip" # package is already stripped, and contains target bins
+QA_EXECSTACK="opt/${P}/*"
+
+RDEPEND="sys-libs/glibc"
+DEPEND=""
+
+S=${WORKDIR}/${CPU}-${PV%.*}
+
+src_install() {
+ local d="/opt/${P}"
+ dodir ${d}
+ cp -pPR * "${D}"/${d}/ || die
+
+ pushd "${D}"/${d}/share/doc/${CPU}-${TARGET} >/dev/null
+ if use doc ; then
+ dohtml -r html/* || die
+ dodoc pdf/* || die
+ fi
+ rm -rf html pdf
+ rm LICENSE.txt man/man7/{fsf-funding,gpl,gfdl}.7 || die
+ mv man info ../..
+ popd >/dev/null
+ find "${D}" -depth -type d -empty -delete
+
+ cat <<-EOF > "${T}"/15${P}
+ PATH=${d}/bin
+ MANPATH=${d}/share/man
+ INFOPATH=${d}/share/info
+ EOF
+ doenvd "${T}"/15${P} || die
+}