summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2008-09-21 03:30:11 +0000
committerJoseph Jezak <josejx@gentoo.org>2008-09-21 03:30:11 +0000
commit76334dd22b32c1334c1aac6eafac9a095e509005 (patch)
tree8ccb119311266b2989c4291f36ba155e750e3b3b /dev-embedded
parentAdd -5.7 development version (diff)
downloadgentoo-2-76334dd22b32c1334c1aac6eafac9a095e509005.tar.gz
gentoo-2-76334dd22b32c1334c1aac6eafac9a095e509005.tar.bz2
gentoo-2-76334dd22b32c1334c1aac6eafac9a095e509005.zip
Added patch to allow pk2cmd to find the device file without changing the path.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/pk2cmd/ChangeLog9
-rw-r--r--dev-embedded/pk2cmd/files/pk2cmd-add-share-dir-for-dev-file.patch17
-rw-r--r--dev-embedded/pk2cmd/pk2cmd-1.12.0-r1.ebuild (renamed from dev-embedded/pk2cmd/pk2cmd-1.12.0.ebuild)7
3 files changed, 30 insertions, 3 deletions
diff --git a/dev-embedded/pk2cmd/ChangeLog b/dev-embedded/pk2cmd/ChangeLog
index c12b3ea3702c..65bfdd4e21b3 100644
--- a/dev-embedded/pk2cmd/ChangeLog
+++ b/dev-embedded/pk2cmd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-embedded/pk2cmd
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/pk2cmd/ChangeLog,v 1.1 2008/09/19 06:58:18 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/pk2cmd/ChangeLog,v 1.2 2008/09/21 03:30:10 josejx Exp $
+
+*pk2cmd-1.12.0-r1 (21 Sep 2008)
+
+ 21 Sep 2008; Joseph Jezak <josejx@gentoo.org>
+ +files/pk2cmd-add-share-dir-for-dev-file.patch, -pk2cmd-1.12.0.ebuild,
+ +pk2cmd-1.12.0-r1.ebuild:
+ Added patch to allow pk2cmd to find the device file without changing the path.
*pk2cmd-1.12.0 (19 Sep 2008)
diff --git a/dev-embedded/pk2cmd/files/pk2cmd-add-share-dir-for-dev-file.patch b/dev-embedded/pk2cmd/files/pk2cmd-add-share-dir-for-dev-file.patch
new file mode 100644
index 000000000000..448fecfca935
--- /dev/null
+++ b/dev-embedded/pk2cmd/files/pk2cmd-add-share-dir-for-dev-file.patch
@@ -0,0 +1,17 @@
+--- cmd_app.cpp.bak 2008-07-11 15:49:56.000000000 -0400
++++ cmd_app.cpp 2008-09-20 23:18:17.000000000 -0400
+@@ -63,7 +63,13 @@
+ _tsearchenv_s("PK2DeviceFile.dat", "PATH", tempString);
+ if (_tcslen(tempString) < 17)
+ {
+- _tcsncpy_s(tempString, "PK2DeviceFile.dat", 17);
++ // Try /usr/share/pk2 first
++ _tcsncpy_s(tempString, "/usr/share/pk2/PK2DeviceFile.dat", 32);
++
++ if(access(tempString, 0))
++ // Well, that didn't work, default to the current directory
++ _tcsncpy_s(tempString, "PK2DeviceFile.dat", 17);
++
+ //_tcsncpy_s(tempString, "C:\\PICkit_2\\pk2cmd\\debug\\PK2DeviceFile.dat", 42);
+ //printf("DEBUG DEVICE FILE SETTING!!!!\n");
+ }
diff --git a/dev-embedded/pk2cmd/pk2cmd-1.12.0.ebuild b/dev-embedded/pk2cmd/pk2cmd-1.12.0-r1.ebuild
index 6ab4225b791c..b2aab383a16c 100644
--- a/dev-embedded/pk2cmd/pk2cmd-1.12.0.ebuild
+++ b/dev-embedded/pk2cmd/pk2cmd-1.12.0-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/pk2cmd/pk2cmd-1.12.0.ebuild,v 1.1 2008/09/19 06:58:18 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/pk2cmd/pk2cmd-1.12.0-r1.ebuild,v 1.1 2008/09/21 03:30:10 josejx Exp $
-inherit toolchain-funcs
+inherit eutils toolchain-funcs
DESCRIPTION="An application for working with the Microchip PicKit2 PIC programmer"
HOMEPAGE="http://www.microchip.com/pickit2"
@@ -22,6 +22,9 @@ src_unpack() {
unpack ${A}
cd "${S}"
+ # Patch adds /usr/share/pk2 to the default search for the device file
+ epatch "${FILESDIR}/${PN}-add-share-dir-for-dev-file.patch"
+
# Fix up the Makefile
sed -i 's:#TARGET=linux:TARGET=linux:' Makefile
sed -i 's:DBG=-O2:DBG=:' Makefile