summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Kapusta <ayoy@gentoo.org>2009-12-12 09:36:20 +0000
committerDominik Kapusta <ayoy@gentoo.org>2009-12-12 09:36:20 +0000
commit25392df38b85c837eec0d65f39bbf17aae38d40d (patch)
tree315955bcd17b632b0d8bab914b56380193153fdc /dev-embedded
parentDrop old patch (diff)
downloadgentoo-2-25392df38b85c837eec0d65f39bbf17aae38d40d.tar.gz
gentoo-2-25392df38b85c837eec0d65f39bbf17aae38d40d.tar.bz2
gentoo-2-25392df38b85c837eec0d65f39bbf17aae38d40d.zip
Use in-system lua instead of bundled one (bug #296552).
(Portage version: 2.2_rc58/cvs/Linux x86_64)
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/scratchbox2/ChangeLog8
-rw-r--r--dev-embedded/scratchbox2/files/scratchbox2-2.0-use-system-lua.patch77
-rw-r--r--dev-embedded/scratchbox2/scratchbox2-2.0-r1.ebuild (renamed from dev-embedded/scratchbox2/scratchbox2-2.0.ebuild)10
3 files changed, 90 insertions, 5 deletions
diff --git a/dev-embedded/scratchbox2/ChangeLog b/dev-embedded/scratchbox2/ChangeLog
index 1aea8cc94b9c..345cba365c0c 100644
--- a/dev-embedded/scratchbox2/ChangeLog
+++ b/dev-embedded/scratchbox2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-embedded/scratchbox2
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/scratchbox2/ChangeLog,v 1.2 2009/11/22 22:49:53 ayoy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/scratchbox2/ChangeLog,v 1.3 2009/12/12 09:36:19 ayoy Exp $
+
+*scratchbox2-2.0-r1 (12 Dec 2009)
+
+ 12 Dec 2009; Dominik Kapusta <ayoy@gentoo.org> -scratchbox2-2.0.ebuild,
+ +scratchbox2-2.0-r1.ebuild, +files/scratchbox2-2.0-use-system-lua.patch:
+ Use in-system lua instead of bundled one (bug #296552).
22 Nov 2009; Dominik Kapusta <ayoy@gentoo.org> scratchbox2-2.0.ebuild:
Moving slot back to 0
diff --git a/dev-embedded/scratchbox2/files/scratchbox2-2.0-use-system-lua.patch b/dev-embedded/scratchbox2/files/scratchbox2-2.0-use-system-lua.patch
new file mode 100644
index 000000000000..d4c231c74db2
--- /dev/null
+++ b/dev-embedded/scratchbox2/files/scratchbox2-2.0-use-system-lua.patch
@@ -0,0 +1,77 @@
+diff --git a/Makefile b/Makefile
+index c5b26cc..da48ea0 100644
+--- a/Makefile
++++ b/Makefile
+@@ -60,7 +60,7 @@ subdirs = luaif preload utils
+ -include config.mak
+
+ CFLAGS += -I$(OBJDIR)/include -I$(SRCDIR)/include
+-CFLAGS += -I$(SRCDIR)/luaif/lua-5.1.4/src
++# CFLAGS += -I$(SRCDIR)/luaif/lua-5.1.4/src
+ CFLAGS += -D_GNU_SOURCE=1 -D_LARGEFILE_SOURCE=1 -D_LARGEFILE64_SOURCE=1
+ CFLAGS += -DSCRATCHBOX_ROOT="$(prefix)"
+ CFLAGS += $(MACH_CFLAG)
+@@ -103,10 +103,7 @@ regular: .configure .version
+ @$(MAKE) -f $(SRCDIR)/Makefile --include-dir=$(SRCDIR) SRCDIR=$(SRCDIR) do-all
+
+ multilib:
+- @mkdir -p obj-32
+- @mkdir -p obj-64
+- @$(MAKE) MACH_CFLAG=-m32 -C obj-32 --include-dir=.. -f ../Makefile SRCDIR=.. regular
+- @$(MAKE) MACH_CFLAG=-m64 -C obj-64 --include-dir=.. -f ../Makefile SRCDIR=.. regular
++ @$(MAKE) MACH_CFLAG=-m64 regular
+
+
+ gcc_bins = addr2line ar as cc c++ c++filt cpp g++ gcc gcov gdb gdbtui gprof ld nm objcopy objdump ranlib rdi-stub readelf run size strings strip
+@@ -230,8 +227,7 @@ endif
+ multilib_prefix=$(prefix)
+
+ install-multilib: multilib
+- @$(MAKE) -C obj-32 --include-dir=.. -f ../Makefile SRCDIR=.. do-install-multilib bitness=32
+- @$(MAKE) -C obj-64 --include-dir=.. -f ../Makefile SRCDIR=.. do-install-multilib bitness=64
++ @$(MAKE) do-install-multilib bitness=64
+
+ do-install-multilib: install-noarch
+ $(P)INSTALL
+diff --git a/luaif/Makefile b/luaif/Makefile
+index 28e8885..5e1af6f 100644
+--- a/luaif/Makefile
++++ b/luaif/Makefile
+@@ -5,7 +5,7 @@ objs := $(D)/luaif.o $(D)/sb_log.o $(D)/paths.o $(D)/argvenvp.o
+ $(D)/sb_log.o: preload/exported.h
+
+ luaif/libluaif.a: $(objs)
+-luaif/libluaif.a: override CFLAGS := $(CFLAGS) -O2 -g -fPIC -Wall -W -I$(SRCDIR)/$(LUASRC) -I$(OBJDIR)/preload -I$(SRCDIR)/preload
++luaif/libluaif.a: override CFLAGS := $(CFLAGS) -O2 -g -fPIC -Wall -W -I$(OBJDIR)/preload -I$(SRCDIR)/preload
+ luaif/libluaif.a: override LDFLAGS := $(LDFLAGS)
+ luaif/libluaif.a: override LIBS :=
+
+@@ -24,5 +24,5 @@ luaif/liblua.a: override CFLAGS := -O2 -g -fPIC -Wall -W $(CFLAGS)
+ luaif/liblua.a: override LDFLAGS := $(LDFLAGS)
+ luaif/liblua.a: override LIBS :=
+
+-targets := $(targets) $(D)/libluaif.a $(D)/liblua.a
++targets := $(targets) $(D)/libluaif.a
+
+diff --git a/preload/Makefile b/preload/Makefile
+index 9f785ba..5094dbc 100644
+--- a/preload/Makefile
++++ b/preload/Makefile
+@@ -8,7 +8,7 @@ LIBSB2_LDFLAGS = -Wl,-soname=$(LIBSB2_SONAME) \
+ # DO NOT add any libraries that depend on libpthread to
+ # LIBSB2_LIBS or LIBS!! see the comments in luaif.c.
+
+-LIBSB2_LIBS =
++LIBSB2_LIBS = -llua
+ SHLIBEXT = so
+ else
+ LIBSB2_LIBS =
+@@ -17,7 +17,7 @@ endif
+
+
+ $(D)/libsb2.$(SHLIBEXT): $(call O,$(objs))
+-$(D)/libsb2.$(SHLIBEXT): luaif/libluaif.a luaif/liblua.a
++$(D)/libsb2.$(SHLIBEXT): luaif/libluaif.a
+ $(D)/libsb2.$(SHLIBEXT): CFLAGS := $(CFLAGS) -fPIC -Wall -W \
+ -I$(SRCDIR)/preload -Ipreload/ $(PROTOTYPEWARNINGS)
+ $(D)/libsb2.$(SHLIBEXT): LDFLAGS := $(LDFLAGS) $(LIBSB2_LDFLAGS)
diff --git a/dev-embedded/scratchbox2/scratchbox2-2.0.ebuild b/dev-embedded/scratchbox2/scratchbox2-2.0-r1.ebuild
index aee40f44570b..0003182f49a8 100644
--- a/dev-embedded/scratchbox2/scratchbox2-2.0.ebuild
+++ b/dev-embedded/scratchbox2/scratchbox2-2.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/scratchbox2/scratchbox2-2.0.ebuild,v 1.2 2009/11/22 22:49:53 ayoy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/scratchbox2/scratchbox2-2.0-r1.ebuild,v 1.1 2009/12/12 09:36:19 ayoy Exp $
EAPI="2"
@@ -18,7 +18,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=""
+DEPEND=">=dev-lang/lua-5.1.4"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
@@ -26,6 +26,8 @@ S="${WORKDIR}/${MY_P}"
src_prepare() {
epatch "${FILESDIR}/${P}-glibc-2.10.patch"
epatch "${FILESDIR}/${P}-gentoo.patch"
+ # bug 296552
+ epatch "${FILESDIR}/${P}-use-system-lua.patch"
sed -e "s/^\(CC = \).*/\1$(tc-getCC)/" \
-e "s/^\(CXX = \).*/\1$(tc-getCXX)/" \
@@ -40,7 +42,7 @@ src_compile() {
}
src_install() {
- emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ emake prefix="${D}/usr" install || die "emake install failed"
# List all the multilib libdirs
local libdirs=
@@ -53,5 +55,5 @@ src_install() {
EOF
doenvd "${T}/55scratchbox2" || die "doenvd failed"
- dodoc AUTHORS README || die "dodoc failed"
+ dodoc AUTHORS README TODO || die "dodoc failed"
}