summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-09-26 18:14:10 +0000
committerMike Frysinger <vapier@gentoo.org>2011-09-26 18:14:10 +0000
commit4ee8914356ba249ed1dcf0a7671c2723eb858191 (patch)
tree33fa076cb789c8e163f0036141e9caf08993dae4 /dev-embedded/libftdi
parentAdd support for USE=static-libs. (diff)
downloadgentoo-2-4ee8914356ba249ed1dcf0a7671c2723eb858191.tar.gz
gentoo-2-4ee8914356ba249ed1dcf0a7671c2723eb858191.tar.bz2
gentoo-2-4ee8914356ba249ed1dcf0a7671c2723eb858191.zip
Version bump.
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'dev-embedded/libftdi')
-rw-r--r--dev-embedded/libftdi/ChangeLog7
-rw-r--r--dev-embedded/libftdi/libftdi-0.19.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-embedded/libftdi/ChangeLog b/dev-embedded/libftdi/ChangeLog
index 28c2b2faff79..aa24bb90e8bb 100644
--- a/dev-embedded/libftdi/ChangeLog
+++ b/dev-embedded/libftdi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-embedded/libftdi
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/ChangeLog,v 1.55 2011/09/26 18:13:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/ChangeLog,v 1.56 2011/09/26 18:14:10 vapier Exp $
+
+*libftdi-0.19 (26 Sep 2011)
+
+ 26 Sep 2011; Mike Frysinger <vapier@gentoo.org> +libftdi-0.19.ebuild:
+ Version bump.
26 Sep 2011; Mike Frysinger <vapier@gentoo.org> libftdi-9999.ebuild,
libftdi-9999.1.0.ebuild:
diff --git a/dev-embedded/libftdi/libftdi-0.19.ebuild b/dev-embedded/libftdi/libftdi-0.19.ebuild
new file mode 100644
index 000000000000..520eb35dbd6e
--- /dev/null
+++ b/dev-embedded/libftdi/libftdi-0.19.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/libftdi-0.19.ebuild,v 1.1 2011/09/26 18:14:10 vapier Exp $
+
+EAPI="2"
+
+if [[ ${PV} == 9999* ]] ; then
+ EGIT_REPO_URI="git://developer.intra2net.com/${PN}"
+ inherit git-2 autotools
+else
+ SRC_URI="http://www.intra2net.com/en/developer/${PN}/download/${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Userspace access to FTDI USB interface chips"
+HOMEPAGE="http://www.intra2net.com/en/developer/libftdi/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="cxx doc examples python static-libs"
+
+RDEPEND="virtual/libusb:0
+ cxx? ( dev-libs/boost )
+ python? ( dev-lang/python )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ if [[ ${PV} == 9999* ]] ; then
+ mkdir -p m4
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable cxx libftdipp) \
+ $(use_with doc docs) \
+ $(use_with examples) \
+ $(use_enable python python-binding) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ use static-libs || find "${D}" -name '*.la' -delete
+ dodoc ChangeLog README
+
+ if use doc ; then
+ doman doc/man/man3/*
+ dohtml doc/html/*
+ fi
+ if use examples ; then
+ docinto examples
+ dodoc examples/*.c
+ fi
+}