summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-06-29 23:32:22 +0000
committerMike Frysinger <vapier@gentoo.org>2010-06-29 23:32:22 +0000
commit49f0ddf2331290759508ecc48eb517dfb274b971 (patch)
tree7cee9e7be5b177c876802f99f538e2a4ce667cc4 /dev-embedded/libftdi
parentold (diff)
downloadgentoo-2-49f0ddf2331290759508ecc48eb517dfb274b971.tar.gz
gentoo-2-49f0ddf2331290759508ecc48eb517dfb274b971.tar.bz2
gentoo-2-49f0ddf2331290759508ecc48eb517dfb274b971.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-embedded/libftdi')
-rw-r--r--dev-embedded/libftdi/ChangeLog8
-rw-r--r--dev-embedded/libftdi/libftdi-0.18.ebuild55
-rw-r--r--dev-embedded/libftdi/libftdi-9999.1.0.ebuild16
-rw-r--r--dev-embedded/libftdi/libftdi-9999.ebuild12
4 files changed, 75 insertions, 16 deletions
diff --git a/dev-embedded/libftdi/ChangeLog b/dev-embedded/libftdi/ChangeLog
index 245ee48cd110..5c2401b64c0c 100644
--- a/dev-embedded/libftdi/ChangeLog
+++ b/dev-embedded/libftdi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-embedded/libftdi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/ChangeLog,v 1.51 2010/06/22 23:10:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/ChangeLog,v 1.52 2010/06/29 23:32:22 vapier Exp $
+
+*libftdi-0.18 (29 Jun 2010)
+
+ 29 Jun 2010; Mike Frysinger <vapier@gentoo.org> +libftdi-0.18.ebuild,
+ libftdi-9999.ebuild, libftdi-9999.1.0.ebuild:
+ Version bump.
*libftdi-9999.1.0 (22 Jun 2010)
*libftdi-9999 (22 Jun 2010)
diff --git a/dev-embedded/libftdi/libftdi-0.18.ebuild b/dev-embedded/libftdi/libftdi-0.18.ebuild
new file mode 100644
index 000000000000..2d73b7303e3a
--- /dev/null
+++ b/dev-embedded/libftdi/libftdi-0.18.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/libftdi-0.18.ebuild,v 1.1 2010/06/29 23:32:22 vapier Exp $
+
+EAPI="2"
+
+if [[ ${PV} == 9999* ]] ; then
+ EGIT_REPO_URI="git://developer.intra2net.com/libftdi"
+ inherit git autotools
+else
+ SRC_URI="http://www.intra2net.com/en/developer/libftdi/download/${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Userspace access to FTDI USB interface chips"
+HOMEPAGE="http://www.intra2net.com/en/developer/libftdi/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="cxx doc examples python"
+
+RDEPEND="virtual/libusb:0
+ cxx? ( dev-libs/boost )
+ python? ( dev-lang/python )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ if [[ ${PV} == 9999* ]] ; then
+ mkdir -p m4
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable cxx libftdipp) \
+ $(use_with doc docs) \
+ $(use_with examples) \
+ $(use_enable python python-binding)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog README
+
+ if use doc ; then
+ doman doc/man/man3/*
+ dohtml doc/html/*
+ fi
+ if use examples ; then
+ docinto examples
+ dodoc examples/*.c
+ fi
+}
diff --git a/dev-embedded/libftdi/libftdi-9999.1.0.ebuild b/dev-embedded/libftdi/libftdi-9999.1.0.ebuild
index 61a703a42c04..ec1ebbb7f1c0 100644
--- a/dev-embedded/libftdi/libftdi-9999.1.0.ebuild
+++ b/dev-embedded/libftdi/libftdi-9999.1.0.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/libftdi-9999.1.0.ebuild,v 1.1 2010/06/22 23:10:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/libftdi-9999.1.0.ebuild,v 1.2 2010/06/29 23:32:22 vapier Exp $
EAPI="2"
if [[ ${PV} == 9999* ]] ; then
+ EGIT_PROJECT="libftdi-1.0"
EGIT_REPO_URI="git://developer.intra2net.com/libftdi-1.0"
inherit git autotools
else
@@ -19,7 +20,7 @@ LICENSE="LGPL-2"
SLOT="0"
IUSE="cxx doc examples python"
-RDEPEND="virtual/libusb:0
+RDEPEND="virtual/libusb:1
cxx? ( dev-libs/boost )
python? ( dev-lang/python )"
DEPEND="${RDEPEND}
@@ -27,23 +28,22 @@ DEPEND="${RDEPEND}
src_prepare() {
if [[ ${PV} == 9999* ]] ; then
+ mkdir -p m4
eautoreconf
fi
-
- # don't bother building examples as we dont want the binaries
- # installed and the Makefile has broken install targets
- sed -i '/^SUBDIRS =/s:examples::' Makefile.in
}
src_configure() {
- use doc || export ac_cv_path_DOXYGEN=true
econf \
+ --with-async-mode \
$(use_enable cxx libftdipp) \
+ $(use_with doc docs) \
+ $(use_with examples) \
$(use_enable python python-binding)
}
src_install() {
- emake DESTDIR="${D}" install || die "Installation failed"
+ emake DESTDIR="${D}" install || die
dodoc ChangeLog README
if use doc ; then
diff --git a/dev-embedded/libftdi/libftdi-9999.ebuild b/dev-embedded/libftdi/libftdi-9999.ebuild
index 638c085e7ad7..95eb9ad60206 100644
--- a/dev-embedded/libftdi/libftdi-9999.ebuild
+++ b/dev-embedded/libftdi/libftdi-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/libftdi-9999.ebuild,v 1.1 2010/06/22 23:10:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/libftdi-9999.ebuild,v 1.2 2010/06/29 23:32:22 vapier Exp $
EAPI="2"
@@ -27,23 +27,21 @@ DEPEND="${RDEPEND}
src_prepare() {
if [[ ${PV} == 9999* ]] ; then
+ mkdir -p m4
eautoreconf
fi
-
- # don't bother building examples as we dont want the binaries
- # installed and the Makefile has broken install targets
- sed -i '/^SUBDIRS =/s:examples::' Makefile.in
}
src_configure() {
- use doc || export ac_cv_path_DOXYGEN=true
econf \
$(use_enable cxx libftdipp) \
+ $(use_with doc docs) \
+ $(use_with examples) \
$(use_enable python python-binding)
}
src_install() {
- emake DESTDIR="${D}" install || die "Installation failed"
+ emake DESTDIR="${D}" install || die
dodoc ChangeLog README
if use doc ; then