summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-03-30 03:46:34 +0000
committerMike Frysinger <vapier@gentoo.org>2012-03-30 03:46:34 +0000
commitfc9a17a2d19b7d1f25ba427e5fcb3e101ae4903e (patch)
tree23347f9ad3ebb0b045fc79e8817890c446045738 /dev-embedded/libftdi/libftdi-0.20.ebuild
parentConvert to cmake as upstream dropped autotools #410117 by Matthias Nagl. (diff)
downloadgentoo-2-fc9a17a2d19b7d1f25ba427e5fcb3e101ae4903e.tar.gz
gentoo-2-fc9a17a2d19b7d1f25ba427e5fcb3e101ae4903e.tar.bz2
gentoo-2-fc9a17a2d19b7d1f25ba427e5fcb3e101ae4903e.zip
Version bump.
(Portage version: 2.2.0_alpha95/cvs/Linux x86_64)
Diffstat (limited to 'dev-embedded/libftdi/libftdi-0.20.ebuild')
-rw-r--r--dev-embedded/libftdi/libftdi-0.20.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-embedded/libftdi/libftdi-0.20.ebuild b/dev-embedded/libftdi/libftdi-0.20.ebuild
new file mode 100644
index 000000000000..3a9632ad7f82
--- /dev/null
+++ b/dev-embedded/libftdi/libftdi-0.20.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/libftdi-0.20.ebuild,v 1.1 2012/03/30 03:46:34 vapier Exp $
+
+EAPI="2"
+
+inherit cmake-utils
+
+if [[ ${PV} == 9999* ]] ; then
+ EGIT_REPO_URI="git://developer.intra2net.com/${PN}"
+ inherit git-2 autotools
+else
+ SRC_URI="http://www.intra2net.com/en/developer/${PN}/download/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Userspace access to FTDI USB interface chips"
+HOMEPAGE="http://www.intra2net.com/en/developer/libftdi/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="cxx doc examples python"
+
+RDEPEND="virtual/libusb:0
+ cxx? ( dev-libs/boost )
+ python? ( dev-lang/python )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use cxx FTDIPP)
+ $(cmake-utils_use doc DOCUMENTATION)
+ $(cmake-utils_use examples EXAMPLES)
+ $(cmake-utils_use python PYTHON_BINDINGS)
+ -DCMAKE_SKIP_BUILD_RPATH=ON
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc ChangeLog README
+
+ if use doc ; then
+ doman doc/man/man3/*
+ dohtml doc/html/*
+ fi
+ if use examples ; then
+ docinto examples
+ dodoc examples/*.c
+ fi
+}