summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-07-21 16:37:50 +0000
committerPacho Ramos <pacho@gentoo.org>2012-07-21 16:37:50 +0000
commitf497eb55513ad045f1ee7cdbf71a39014bf60740 (patch)
tree9754e44e246efefef858cca7ffb4f7baad7d4d01 /dev-embedded/gpsim
parentold (diff)
downloadgentoo-2-f497eb55513ad045f1ee7cdbf71a39014bf60740.tar.gz
gentoo-2-f497eb55513ad045f1ee7cdbf71a39014bf60740.tar.bz2
gentoo-2-f497eb55513ad045f1ee7cdbf71a39014bf60740.zip
Fix build against glib-2.32 and latest gtk+extra, thanks a lot to Peter Volkov.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-embedded/gpsim')
-rw-r--r--dev-embedded/gpsim/ChangeLog8
-rw-r--r--dev-embedded/gpsim/files/gpsim-0.26.1-glib-single-include.patch13
-rw-r--r--dev-embedded/gpsim/files/gpsim-0.26.1-gtkextra.patch29
-rw-r--r--dev-embedded/gpsim/gpsim-0.26.1.ebuild11
4 files changed, 58 insertions, 3 deletions
diff --git a/dev-embedded/gpsim/ChangeLog b/dev-embedded/gpsim/ChangeLog
index 5fbd12723b2c..aabcb73aeeda 100644
--- a/dev-embedded/gpsim/ChangeLog
+++ b/dev-embedded/gpsim/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-embedded/gpsim
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/gpsim/ChangeLog,v 1.55 2012/05/03 02:35:37 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/gpsim/ChangeLog,v 1.56 2012/07/21 16:37:50 pacho Exp $
+
+ 21 Jul 2012; Pacho Ramos <pacho@gentoo.org>
+ +files/gpsim-0.26.1-glib-single-include.patch,
+ +files/gpsim-0.26.1-gtkextra.patch, gpsim-0.26.1.ebuild:
+ Fix build against glib-2.32 and latest gtk+extra, thanks a lot to Peter
+ Volkov.
03 May 2012; Jeff Horelick <jdhore@gentoo.org> gpsim-0.24.0-r1.ebuild,
gpsim-0.25.0.ebuild, gpsim-0.26.1.ebuild:
diff --git a/dev-embedded/gpsim/files/gpsim-0.26.1-glib-single-include.patch b/dev-embedded/gpsim/files/gpsim-0.26.1-glib-single-include.patch
new file mode 100644
index 000000000000..cd0f798281b5
--- /dev/null
+++ b/dev-embedded/gpsim/files/gpsim-0.26.1-glib-single-include.patch
@@ -0,0 +1,13 @@
+http://gpsim.svn.sourceforge.net/viewvc/gpsim/trunk/src/bitlog.h?r1=2107&r2=2182
+
+--- trunk/src/bitlog.h 2010/06/05 06:41:12 2107
++++ trunk/src/bitlog.h 2012/01/03 02:54:49 2182
+@@ -25,7 +25,7 @@
+
+ // include the absolute minimum portion of GLIB to get the definitions
+ // for guint64, etc.
+-#include <glibconfig.h>
++#include <glib.h>
+
+ /**********************************************************************
+ * boolean event logging
diff --git a/dev-embedded/gpsim/files/gpsim-0.26.1-gtkextra.patch b/dev-embedded/gpsim/files/gpsim-0.26.1-gtkextra.patch
new file mode 100644
index 000000000000..913290970516
--- /dev/null
+++ b/dev-embedded/gpsim/files/gpsim-0.26.1-gtkextra.patch
@@ -0,0 +1,29 @@
+=== modified file 'configure.ac'
+--- configure.ac 2012-06-02 20:11:32 +0000
++++ configure.ac 2012-06-02 20:11:44 +0000
+@@ -79,15 +79,20 @@
+ else
+ dnl gtk2 checks
+
+- $PKGCONFIG --exists gtkextra-2.0
++ GTKEXTRAMOD="gtkextra-2.0"
++ $PKGCONFIG --exists $GTKEXTRAMOD
+ if test $? != 0; then
+- AC_MSG_ERROR(Cannot find gtkextra-2.0 package)
++ GTKEXTRAMOD="gtkextra-3.0"
++ $PKGCONFIG --exists $GTKEXTRAMOD
++ if test $? != 0; then
++ AC_MSG_ERROR(Cannot find gtkextra-2.0 or gtkextra-3.0 package)
++ fi
+ fi
+
+ X_LDFLAGS=`$PKGCONFIG --libs gtk+-2.0 gthread-2.0`
+ X_CFLAGS=`$PKGCONFIG --cflags gtk+-2.0`
+- Y_LDFLAGS=`$PKGCONFIG --libs gtkextra-2.0`
+- Y_CFLAGS=`$PKGCONFIG --cflags gtkextra-2.0`
++ Y_LDFLAGS=`$PKGCONFIG --libs $GTKEXTRAMOD`
++ Y_CFLAGS=`$PKGCONFIG --cflags $GTKEXTRAMOD`
+ GTK_VERSION_T=`$PKGCONFIG --modversion gtk+-2.0`
+ echo linking with gtk-$GTK_VERSION_T
+ AC_DEFINE_UNQUOTED([GTK_VERSION],"$GTK_VERSION_T",[gtk version])
+
diff --git a/dev-embedded/gpsim/gpsim-0.26.1.ebuild b/dev-embedded/gpsim/gpsim-0.26.1.ebuild
index a2418fd53876..9e98a87ec55c 100644
--- a/dev-embedded/gpsim/gpsim-0.26.1.ebuild
+++ b/dev-embedded/gpsim/gpsim-0.26.1.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/gpsim/gpsim-0.26.1.ebuild,v 1.2 2012/05/03 02:35:37 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/gpsim/gpsim-0.26.1.ebuild,v 1.3 2012/07/21 16:37:50 pacho Exp $
EAPI=4
+inherit eutils autotools
DESCRIPTION="A simulator for the Microchip PIC microcontrollers"
HOMEPAGE="http://gpsim.sourceforge.net"
SRC_URI="mirror://sourceforge/gpsim/${P}.tar.gz"
@@ -25,6 +26,12 @@ DEPEND="${RDEPEND}
DOCS=(ANNOUNCE AUTHORS ChangeLog HISTORY PROCESSORS README README.MODULES TODO)
+src_prepare() {
+ epatch "${FILESDIR}/gpsim-0.26.1-glib-single-include.patch"
+ epatch "${FILESDIR}/gpsim-0.26.1-gtkextra.patch"
+ eautoreconf
+}
+
src_configure() {
econf \
$(use_enable gtk gui) \
@@ -36,5 +43,5 @@ src_install() {
use doc && dodoc doc/gpsim.pdf
# remove useless .la files
- use static-libs || find "${ED}" -name '*.la' -exec rm -f '{}' +
+ use static-libs || find "${D}" -name '*.la' -exec rm -f '{}' +
}