summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Cort <tcort@gentoo.org>2006-08-06 02:02:28 +0000
committerThomas Cort <tcort@gentoo.org>2006-08-06 02:02:28 +0000
commitf204f983744cc37eb388cb3287e9f7a9b62d6d74 (patch)
tree75ebd1f9df58766432297f000d9e4580dbb7b0a1 /dev-dotnet
parentAdding perl dep; fixed DEPEND (diff)
downloadgentoo-2-f204f983744cc37eb388cb3287e9f7a9b62d6d74.tar.gz
gentoo-2-f204f983744cc37eb388cb3287e9f7a9b62d6d74.tar.bz2
gentoo-2-f204f983744cc37eb388cb3287e9f7a9b62d6d74.zip
Version bump to 0.7.4 ; Bug #121110.
(Portage version: 2.1-r1)
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/pnet/ChangeLog7
-rw-r--r--dev-dotnet/pnet/files/digest-pnet-0.7.43
-rw-r--r--dev-dotnet/pnet/pnet-0.7.4.ebuild45
3 files changed, 54 insertions, 1 deletions
diff --git a/dev-dotnet/pnet/ChangeLog b/dev-dotnet/pnet/ChangeLog
index 50672f7088d2..486fdb18e93a 100644
--- a/dev-dotnet/pnet/ChangeLog
+++ b/dev-dotnet/pnet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-dotnet/pnet
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pnet/ChangeLog,v 1.31 2006/06/20 04:24:18 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pnet/ChangeLog,v 1.32 2006/08/06 02:02:28 tcort Exp $
+
+*pnet-0.7.4 (06 Aug 2006)
+
+ 06 Aug 2006; Thomas Cort <tcort@gentoo.org> +pnet-0.7.4.ebuild:
+ Version bump to 0.7.4 ; Bug #121110.
20 Jun 2006; Peter Johanson <latexer@gentoo.org> pnet-0.6.10.ebuild,
pnet-0.6.12.ebuild, pnet-0.7.0.ebuild, pnet-0.7.2.ebuild:
diff --git a/dev-dotnet/pnet/files/digest-pnet-0.7.4 b/dev-dotnet/pnet/files/digest-pnet-0.7.4
new file mode 100644
index 000000000000..8cdebfd6c293
--- /dev/null
+++ b/dev-dotnet/pnet/files/digest-pnet-0.7.4
@@ -0,0 +1,3 @@
+MD5 064baa390e6b1ae9463f68c929e36f74 pnet-0.7.4.tar.gz 3625274
+RMD160 bdc683433e159a5b0af73ac9b8c05b94886fa296 pnet-0.7.4.tar.gz 3625274
+SHA256 fe1367cbc3e69dea77aef20438fb024864ed41b09dbd6817b08ec36128361ea5 pnet-0.7.4.tar.gz 3625274
diff --git a/dev-dotnet/pnet/pnet-0.7.4.ebuild b/dev-dotnet/pnet/pnet-0.7.4.ebuild
new file mode 100644
index 000000000000..717d63dde779
--- /dev/null
+++ b/dev-dotnet/pnet/pnet-0.7.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pnet/pnet-0.7.4.ebuild,v 1.1 2006/08/06 02:02:28 tcort Exp $
+
+inherit autotools
+
+DESCRIPTION="Portable.NET runtime, compiler, tools"
+HOMEPAGE="http://www.dotgnu.org/"
+SRC_URI="http://www.southern-storm.com.au/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-util/treecc-0.3.0"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Fix symlink for renamed executables ; Bug #39369
+ # Renamed to avoid conflicting with dev-lang/mono
+ # This should be removed again once we have 'dotnet-config'
+ sed -i "s:ilasm.1.gz:ilasm.pnet.1.gz:" ilasm/Makefile.am
+ sed -i "s:al.1.gz:al.pnet.1.gz:" ilasm/Makefile.am
+
+ eautoreconf || die "eautoreconf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # move fixes for the mono conflict
+ mv ${D}/usr/bin/al ${D}/usr/bin/al.pnet
+ mv ${D}/usr/bin/ilasm ${D}/usr/bin/ilasm.pnet
+ mv ${D}/usr/bin/resgen ${D}/usr/bin/resgen.pnet
+ mv ${D}/usr/share/man/man1/ilasm.1 ${D}/usr/share/man/man1/ilasm.pnet.1
+ mv ${D}/usr/share/man/man1/resgen.1 ${D}/usr/share/man/man1/resgen.pnet.1
+
+ dodoc AUTHORS ChangeLog HACKING NEWS README
+ dodoc doc/gtk-sharp.HOWTO
+ dohtml doc/*.html
+}