summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-12-31 16:32:29 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-12-31 16:32:29 +0000
commite1bd66807c08232a3962539ee227fc8147c82b77 (patch)
treecc683b421a9a824534682ac7b2f9e8de32ca0718 /dev-dotnet
parentMarked 0.9.3 ppc stable for bug #145000 and marked 1.0_pre2306 ~ppc. (diff)
downloadgentoo-2-e1bd66807c08232a3962539ee227fc8147c82b77.tar.gz
gentoo-2-e1bd66807c08232a3962539ee227fc8147c82b77.tar.bz2
gentoo-2-e1bd66807c08232a3962539ee227fc8147c82b77.zip
dev-dotnet/nant-0.85: fixed threading issue (bug #199748)
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/nant/ChangeLog6
-rw-r--r--dev-dotnet/nant/files/nant-0.85-threadingfix.patch22
-rw-r--r--dev-dotnet/nant/nant-0.85.ebuild15
3 files changed, 36 insertions, 7 deletions
diff --git a/dev-dotnet/nant/ChangeLog b/dev-dotnet/nant/ChangeLog
index 217b91665d38..fa956fd500cd 100644
--- a/dev-dotnet/nant/ChangeLog
+++ b/dev-dotnet/nant/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-dotnet/nant
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/nant/ChangeLog,v 1.16 2007/08/11 04:19:49 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/nant/ChangeLog,v 1.17 2007/12/31 16:32:28 jurek Exp $
+
+ 31 Dec 2007; Jurek Bartuszek <jurek@gentoo.org>
+ +files/nant-0.85-threadingfix.patch, nant-0.85.ebuild:
+ Fixed threading issue (bug #199748)
10 Aug 2007; Steve Dibb <beandog@gentoo.org> nant-0.85.ebuild:
amd64 stable, bug 186686
diff --git a/dev-dotnet/nant/files/nant-0.85-threadingfix.patch b/dev-dotnet/nant/files/nant-0.85-threadingfix.patch
new file mode 100644
index 000000000000..7e91abaa2b8c
--- /dev/null
+++ b/dev-dotnet/nant/files/nant-0.85-threadingfix.patch
@@ -0,0 +1,22 @@
+--- src/NAnt.Core/Tasks/ExternalProgramBase.cs 2005-04-04 14:08:28.000000000 +0200
++++ src/NAnt.Core/Tasks/ExternalProgramBase.cs.new 2007-12-31 17:28:09.000000000 +0100
+@@ -452,7 +452,8 @@
+ }
+ }
+ }
+- OutputWriter.Flush();
++ lock (_lockObject)
++ OutputWriter.Flush();
+ }
+ /// <summary> /// Reads from the stream until the external program is ended. /// </summary>
+ private void StreamReaderThread_Error() {
+@@ -476,7 +477,8 @@
+ }
+ }
+ }
+- ErrorWriter.Flush();
++ lock (_lockObject)
++ ErrorWriter.Flush();
+ }
+
+ /// <summary>
diff --git a/dev-dotnet/nant/nant-0.85.ebuild b/dev-dotnet/nant/nant-0.85.ebuild
index 5c00e1a03385..1648c094658b 100644
--- a/dev-dotnet/nant/nant-0.85.ebuild
+++ b/dev-dotnet/nant/nant-0.85.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/nant/nant-0.85.ebuild,v 1.7 2007/08/11 04:19:49 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/nant/nant-0.85.ebuild,v 1.8 2007/12/31 16:32:28 jurek Exp $
inherit mono eutils
@@ -21,19 +21,22 @@ MAKEOPTS="${MAKEOPTS} -j1"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# Fix a problem with duplicate building caused by the doc= target
- for file in $(find ${S}/src -name '*.build') ; do
+ for file in $(find "${S}"/src -name '*.build') ; do
sed -i "s: doc=.*>:>:" ${file}
done
# Build against the .NET 2.0 Framework, as it is backwards compatible
sed -i -e "s/-f:NAnt.build/-t:mono-2.0 -f:NAnt.build/" \
- ${S}/Makefile || die "sed failed"
+ "${S}"/Makefile || die "sed failed"
+
+ # Patch to prevent build from failing due to threading issues (see bug #199748)
+ epatch "${FILESDIR}"/${P}-threadingfix.patch
# Patch to allow building on current mono releases
- epatch ${FILESDIR}/${PN}-0.85-obselencense.patch
+ epatch "${FILESDIR}"/${PN}-0.85-obselencense.patch
}
src_compile() {
@@ -53,7 +56,7 @@ src_install() {
sed -i \
-e "s:${D}::" \
-e "2iexport MONO_SILENT_WARNING=1" \
- ${D}/usr/bin/nant
+ "${D}"/usr/bin/nant
dodoc README.txt
}