summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2006-04-28 21:53:49 +0000
committerDaniel Drake <dsd@gentoo.org>2006-04-28 21:53:49 +0000
commit542d6342b2dcf4238df26fad92a2be6aa123a2d8 (patch)
treec580b4adf43e815a88a8e2f92789f8941318d108 /dev-dotnet
parentwork around bug #97196 (diff)
downloadgentoo-2-542d6342b2dcf4238df26fad92a2be6aa123a2d8.tar.gz
gentoo-2-542d6342b2dcf4238df26fad92a2be6aa123a2d8.tar.bz2
gentoo-2-542d6342b2dcf4238df26fad92a2be6aa123a2d8.zip
Version bump, really fixes evo-2.6 compatibility, thanks to Tim Heinrich and others in bug #126979
(Portage version: 2.1_pre9-r5)
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/evolution-sharp/ChangeLog13
-rw-r--r--dev-dotnet/evolution-sharp/evolution-sharp-0.11.0.ebuild39
-rw-r--r--dev-dotnet/evolution-sharp/files/digest-evolution-sharp-0.11.03
-rw-r--r--dev-dotnet/evolution-sharp/files/evolution-sharp-0.11.0-evo-shell-libdir.patch16
4 files changed, 70 insertions, 1 deletions
diff --git a/dev-dotnet/evolution-sharp/ChangeLog b/dev-dotnet/evolution-sharp/ChangeLog
index fcca6fd3c79f..5c3454a390f3 100644
--- a/dev-dotnet/evolution-sharp/ChangeLog
+++ b/dev-dotnet/evolution-sharp/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for dev-dotnet/evolution-sharp
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/evolution-sharp/ChangeLog,v 1.7 2006/04/09 15:24:49 cretin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/evolution-sharp/ChangeLog,v 1.8 2006/04/28 21:53:49 dsd Exp $
+
+*evolution-sharp-0.11.0 (28 Apr 2006)
+
+ 28 Apr 2006; Daniel Drake <dsd@gentoo.org>
+ -files/evolution-sharp-0.10.2-check-evo-2.6.patch,
+ -files/evolution-sharp-0.10.2-use-glibsharpglue-2.patch,
+ +files/evolution-sharp-0.11.0-evo-shell-libdir.patch,
+ -evolution-sharp-0.10.2-r1.ebuild, -evolution-sharp-0.10.2-r2.ebuild,
+ +evolution-sharp-0.11.0.ebuild:
+ Version bump, really fixes evo-2.6 compatibility, thanks to Tim Heinrich and
+ others in bug #126979
*evolution-sharp-0.10.2-r2 (09 Apr 2006)
diff --git a/dev-dotnet/evolution-sharp/evolution-sharp-0.11.0.ebuild b/dev-dotnet/evolution-sharp/evolution-sharp-0.11.0.ebuild
new file mode 100644
index 000000000000..8a79f0f3f22f
--- /dev/null
+++ b/dev-dotnet/evolution-sharp/evolution-sharp-0.11.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/evolution-sharp/evolution-sharp-0.11.0.ebuild,v 1.1 2006/04/28 21:53:49 dsd Exp $
+
+inherit mono versionator eutils autotools
+DESCRIPTION="Mono bindings for Evolution"
+HOMEPAGE="http://www.gnome.org/projects/beagle/"
+SRC_URI="mirror://gnome/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+
+DEPEND=">=gnome-extra/evolution-data-server-1.2
+ >=dev-lang/mono-1.0
+ >=dev-dotnet/gtk-sharp-2.4.0
+ >=mail-client/evolution-2.2.0"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Use correct libdir in pkgconfig files
+ sed -i -e 's:^libdir.*:libdir=@libdir@:' \
+ ${S}/*.pc.in || die
+
+ # fixed upstream
+ epatch ${FILESDIR}/${P}-evo-shell-libdir.patch
+
+ eautoconf
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog MAINTAINERS NEWS README
+}
+
diff --git a/dev-dotnet/evolution-sharp/files/digest-evolution-sharp-0.11.0 b/dev-dotnet/evolution-sharp/files/digest-evolution-sharp-0.11.0
new file mode 100644
index 000000000000..579db7c34d74
--- /dev/null
+++ b/dev-dotnet/evolution-sharp/files/digest-evolution-sharp-0.11.0
@@ -0,0 +1,3 @@
+MD5 c6e3b0a64f3cead77dd626dfe76e88e0 evolution-sharp-0.11.0.tar.bz2 305271
+RMD160 46ec83030fd82080f97f663cbb5bdc32a59e278c evolution-sharp-0.11.0.tar.bz2 305271
+SHA256 e44c62bc2e2adc5318d1fb8bc6b49a819792b1ae54978b4583bfec88da3a4b5b evolution-sharp-0.11.0.tar.bz2 305271
diff --git a/dev-dotnet/evolution-sharp/files/evolution-sharp-0.11.0-evo-shell-libdir.patch b/dev-dotnet/evolution-sharp/files/evolution-sharp-0.11.0-evo-shell-libdir.patch
new file mode 100644
index 000000000000..470702744301
--- /dev/null
+++ b/dev-dotnet/evolution-sharp/files/evolution-sharp-0.11.0-evo-shell-libdir.patch
@@ -0,0 +1,16 @@
+Index: configure.in
+===================================================================
+RCS file: /cvs/gnome/evolution-sharp/configure.in,v
+retrieving revision 1.30
+diff -u -B -p -r1.30 configure.in
+--- configure.in 26 Apr 2006 22:53:42 -0000 1.30
++++ configure.in 26 Apr 2006 23:18:11 -0000
+@@ -131,7 +131,7 @@ PKG_CHECK_MODULES(EVO_SHELL, "evolution-
+ AC_SUBST(EVO_SHELL_CFLAGS)
+ AC_SUBST(EVO_SHELL_LIBS)
+
+-EVO_SHELL_LIBDIR=`$PKG_CONFIG --variable=privlibdir evolution-shell-2.6`
++EVO_SHELL_LIBDIR=`$PKG_CONFIG --variable=privlibdir evolution-shell-$eshellver`
+ AC_SUBST(EVO_SHELL_LIBDIR)
+
+ API_VERSION=2.0.0.0