summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-19 14:28:58 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-19 14:28:58 +0000
commit3e3db03b42aea001885ea31ad270be91e4823510 (patch)
tree57fe700cfa7087e5857391e7ead5c17c856bb60b /dev-dotnet
parentppc stable #274507 (diff)
downloadgentoo-2-3e3db03b42aea001885ea31ad270be91e4823510.tar.gz
gentoo-2-3e3db03b42aea001885ea31ad270be91e4823510.tar.bz2
gentoo-2-3e3db03b42aea001885ea31ad270be91e4823510.zip
Upstream patch to fix issue where podcast playlist is empty while it shouldn't wrt #273050, thanks to Jürgen Geuter.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/ipod-sharp/ChangeLog9
-rw-r--r--dev-dotnet/ipod-sharp/ipod-sharp-0.8.2-r1.ebuild42
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-dotnet/ipod-sharp/ChangeLog b/dev-dotnet/ipod-sharp/ChangeLog
index 951a94458853..8dc8c07417f3 100644
--- a/dev-dotnet/ipod-sharp/ChangeLog
+++ b/dev-dotnet/ipod-sharp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-dotnet/ipod-sharp
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/ipod-sharp/ChangeLog,v 1.25 2009/05/22 01:02:43 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/ipod-sharp/ChangeLog,v 1.26 2009/07/19 14:28:58 ssuominen Exp $
+
+*ipod-sharp-0.8.2-r1 (19 Jul 2009)
+
+ 19 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +ipod-sharp-0.8.2-r1.ebuild:
+ Upstream patch to fix issue where podcast playlist is empty while it
+ shouldn't wrt #273050, thanks to Jürgen Geuter.
22 May 2009; Peter Alfredsen <loki_val@gentoo.org>
-ipod-sharp-0.6.3.ebuild:
diff --git a/dev-dotnet/ipod-sharp/ipod-sharp-0.8.2-r1.ebuild b/dev-dotnet/ipod-sharp/ipod-sharp-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..b99332265a48
--- /dev/null
+++ b/dev-dotnet/ipod-sharp/ipod-sharp-0.8.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/ipod-sharp/ipod-sharp-0.8.2-r1.ebuild,v 1.1 2009/07/19 14:28:58 ssuominen Exp $
+
+EAPI=2
+inherit eutils mono
+
+DESCRIPTION="ipod-sharp provides high-level feature support for Apple's iPod and binds libipoddevice."
+HOMEPAGE="http://banshee-project.org/Ipod-sharp"
+SRC_URI="http://banshee-project.org/files/${PN}/${P}.tar.gz
+ http://dev.gentoo.org/~ssuominen/${P}-fix_ipod_podcast_playlist.patch.bz2
+ mirror://gentoo/${P}-fix_ipod_podcast_playlist.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/mono-2
+ dev-dotnet/dbus-glib-sharp
+ >=dev-dotnet/podsleuth-0.6.4
+ >=dev-dotnet/gtk-sharp-2.12"
+DEPEND="${RDEPEND}
+ doc? ( >=virtual/monodoc-1.1.8 )
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${WORKDIR}"/ipod-sharp-0.8.2-fix_ipod_podcast_playlist.patch
+}
+
+src_configure() {
+ econf $(use_enable doc docs)
+}
+
+src_compile() {
+ emake -j1 || die "emake failed."
+}
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README
+ mono_multilib_comply
+}