summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-02-16 12:06:28 +0000
committerPacho Ramos <pacho@gentoo.org>2012-02-16 12:06:28 +0000
commit3525f9a743518f6881818681c816276f47e03093 (patch)
treef9feb7577793a2d6a018143e44c65aaae07633de /dev-dotnet
parentSecurity bump. #404071 (diff)
downloadgentoo-2-3525f9a743518f6881818681c816276f47e03093.tar.gz
gentoo-2-3525f9a743518f6881818681c816276f47e03093.tar.bz2
gentoo-2-3525f9a743518f6881818681c816276f47e03093.zip
Fix compilation against latest glib, bug #389919 by Alain Toussaint, Rolf S. Arvidson.
(Portage version: 2.1.10.46/cvs/Linux x86_64)
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/glib-sharp/ChangeLog9
-rw-r--r--dev-dotnet/glib-sharp/files/glib-sharp-2.12.10-glib-header.patch36
-rw-r--r--dev-dotnet/glib-sharp/glib-sharp-2.12.10.ebuild8
3 files changed, 48 insertions, 5 deletions
diff --git a/dev-dotnet/glib-sharp/ChangeLog b/dev-dotnet/glib-sharp/ChangeLog
index 684b18a3e57f..753cf00eb29c 100644
--- a/dev-dotnet/glib-sharp/ChangeLog
+++ b/dev-dotnet/glib-sharp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-dotnet/glib-sharp
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/glib-sharp/ChangeLog,v 1.13 2010/10/07 19:22:07 pacho Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/glib-sharp/ChangeLog,v 1.14 2012/02/16 12:06:28 pacho Exp $
+
+ 16 Feb 2012; Pacho Ramos <pacho@gentoo.org>
+ +files/glib-sharp-2.12.10-glib-header.patch, glib-sharp-2.12.10.ebuild:
+ Fix compilation against latest glib, bug #389919 by Alain Toussaint, Rolf S.
+ Arvidson.
07 Oct 2010; Pacho Ramos <pacho@gentoo.org> -glib-sharp-2.12.9.ebuild:
Remove old.
diff --git a/dev-dotnet/glib-sharp/files/glib-sharp-2.12.10-glib-header.patch b/dev-dotnet/glib-sharp/files/glib-sharp-2.12.10-glib-header.patch
new file mode 100644
index 000000000000..760d55494395
--- /dev/null
+++ b/dev-dotnet/glib-sharp/files/glib-sharp-2.12.10-glib-header.patch
@@ -0,0 +1,36 @@
+diff -urN 1/glib/glue/list.c 2/glib/glue/list.c
+--- 1/glib/glue/list.c 2009-01-07 10:54:06.000000000 -0600
++++ 2/glib/glue/list.c 2012-02-14 20:50:32.116877699 -0600
+@@ -20,7 +20,7 @@
+ */
+
+
+-#include <glib/glist.h>
++#include <glib.h>
+
+ /* Forward declarations */
+ gpointer gtksharp_list_get_data (GList *l);
+diff -urN 1/glib/glue/slist.c 2/glib/glue/slist.c
+--- 1/glib/glue/slist.c 2009-01-07 10:54:06.000000000 -0600
++++ 2/glib/glue/slist.c 2012-02-14 20:50:43.721718553 -0600
+@@ -20,7 +20,7 @@
+ */
+
+
+-#include <glib/gslist.h>
++#include <glib.h>
+
+ /* Forward declarations */
+ gpointer gtksharp_slist_get_data (GSList *l);
+diff -urN 1/glib/glue/thread.c 2/glib/glue/thread.c
+--- 1/glib/glue/thread.c 2009-01-07 10:54:06.000000000 -0600
++++ 2/glib/glue/thread.c 2012-02-14 20:50:51.922605985 -0600
+@@ -20,7 +20,7 @@
+ */
+
+
+-#include <glib/gthread.h>
++#include <glib.h>
+
+ gboolean glibsharp_g_thread_supported (void);
+
diff --git a/dev-dotnet/glib-sharp/glib-sharp-2.12.10.ebuild b/dev-dotnet/glib-sharp/glib-sharp-2.12.10.ebuild
index 91b9c520d1b9..48ce96293fc0 100644
--- a/dev-dotnet/glib-sharp/glib-sharp-2.12.10.ebuild
+++ b/dev-dotnet/glib-sharp/glib-sharp-2.12.10.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/glib-sharp/glib-sharp-2.12.10.ebuild,v 1.4 2010/09/12 04:28:33 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/glib-sharp/glib-sharp-2.12.10.ebuild,v 1.5 2012/02/16 12:06:28 pacho Exp $
-EAPI=2
+EAPI="4"
inherit gtk-sharp-module
@@ -11,3 +11,5 @@ KEYWORDS="amd64 ppc x86 ~x86-fbsd"
IUSE=""
RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${PN}-2.12.10-glib-header.patch" )