summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Cort <tcort@gentoo.org>2006-08-06 02:04:16 +0000
committerThomas Cort <tcort@gentoo.org>2006-08-06 02:04:16 +0000
commit1efef107a6590c7256817dc1a64f593d491e5de2 (patch)
tree6c87dfe36e0c84cd43c8b8dcd00e70232e71d2cb /dev-dotnet
parentAdding perl dep; fixed DEPEND (diff)
downloadgentoo-2-1efef107a6590c7256817dc1a64f593d491e5de2.tar.gz
gentoo-2-1efef107a6590c7256817dc1a64f593d491e5de2.tar.bz2
gentoo-2-1efef107a6590c7256817dc1a64f593d491e5de2.zip
Version bump to 0.7.4 ; Bug #121110.
(Portage version: 2.1-r1)
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/pnetlib/ChangeLog7
-rw-r--r--dev-dotnet/pnetlib/files/digest-pnetlib-0.7.43
-rw-r--r--dev-dotnet/pnetlib/pnetlib-0.7.4.ebuild49
3 files changed, 58 insertions, 1 deletions
diff --git a/dev-dotnet/pnetlib/ChangeLog b/dev-dotnet/pnetlib/ChangeLog
index da515626c0de..04ceca728393 100644
--- a/dev-dotnet/pnetlib/ChangeLog
+++ b/dev-dotnet/pnetlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-dotnet/pnetlib
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pnetlib/ChangeLog,v 1.28 2006/07/22 21:56:32 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pnetlib/ChangeLog,v 1.29 2006/08/06 02:04:16 tcort Exp $
+
+*pnetlib-0.7.4 (06 Aug 2006)
+
+ 06 Aug 2006; Thomas Cort <tcort@gentoo.org> +pnetlib-0.7.4.ebuild:
+ Version bump to 0.7.4 ; Bug #121110.
22 Jul 2006; Thomas Cort <tcort@gentoo.org> pnetlib-0.6.10.ebuild,
pnetlib-0.6.12.ebuild, pnetlib-0.7.0.ebuild, pnetlib-0.7.2.ebuild:
diff --git a/dev-dotnet/pnetlib/files/digest-pnetlib-0.7.4 b/dev-dotnet/pnetlib/files/digest-pnetlib-0.7.4
new file mode 100644
index 000000000000..3b70ae0c8888
--- /dev/null
+++ b/dev-dotnet/pnetlib/files/digest-pnetlib-0.7.4
@@ -0,0 +1,3 @@
+MD5 cab8de4301bea6e4777ca95cc8a860bd pnetlib-0.7.4.tar.gz 4100640
+RMD160 8ee753dfd4078f439b274be48fc90c3993fbc1c8 pnetlib-0.7.4.tar.gz 4100640
+SHA256 d6d1a2ab67a6291307c06007c7378d1da1654abb6b1b32dad442fd1711b1568a pnetlib-0.7.4.tar.gz 4100640
diff --git a/dev-dotnet/pnetlib/pnetlib-0.7.4.ebuild b/dev-dotnet/pnetlib/pnetlib-0.7.4.ebuild
new file mode 100644
index 000000000000..7f4430138510
--- /dev/null
+++ b/dev-dotnet/pnetlib/pnetlib-0.7.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pnetlib/pnetlib-0.7.4.ebuild,v 1.1 2006/08/06 02:04:16 tcort Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="Portable.NET C# library"
+HOMEPAGE="http://www.dotgnu.org/"
+SRC_URI="http://www.southern-storm.com.au/download/${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="doc truetype X"
+
+DEPEND="=dev-dotnet/pnet-${PV}*
+ X? ( || (
+ ( x11-libs/libSM
+ x11-libs/libXft )
+ virtual/x11 ) )
+ truetype? ( virtual/xft )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # patch configure.in to detect renamed resgen.pnet ; bug #39369
+ epatch ${FILESDIR}/0.7.0-resgen.patch
+
+ eautoreconf || die "eautoreconf failed"
+}
+
+src_compile() {
+ local lib_profile="default1.1"
+
+ elog "Using profile: ${lib_profile}"
+ econf --with-profile=${lib_profile} \
+ $(use_enable truetype xft) || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog HACKING NEWS README
+
+ use doc && dodoc doc/*.txt
+ use doc && dohtml doc/*.html
+}