summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-08-31 21:21:57 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-08-31 21:21:57 +0000
commit0ee5912e80725547fa6dc21376753e1a2659df3a (patch)
treea524fb56985cc2210382364008ca009b8cb8892c /dev-dotnet
parentsparc stable wrt #236057 (diff)
downloadgentoo-2-0ee5912e80725547fa6dc21376753e1a2659df3a.tar.gz
gentoo-2-0ee5912e80725547fa6dc21376753e1a2659df3a.tar.bz2
gentoo-2-0ee5912e80725547fa6dc21376753e1a2659df3a.zip
Bump
(Portage version: 2.2_rc8/cvs/Linux 2.6.25.8 i686)
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/mono-zeroconf/ChangeLog8
-rw-r--r--dev-dotnet/mono-zeroconf/mono-zeroconf-0.7.6.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-dotnet/mono-zeroconf/ChangeLog b/dev-dotnet/mono-zeroconf/ChangeLog
index 87ccd567b06f..2f6f2e24c16e 100644
--- a/dev-dotnet/mono-zeroconf/ChangeLog
+++ b/dev-dotnet/mono-zeroconf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-dotnet/mono-zeroconf
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono-zeroconf/ChangeLog,v 1.3 2008/02/28 14:32:48 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono-zeroconf/ChangeLog,v 1.4 2008/08/31 21:21:57 loki_val Exp $
+
+*mono-zeroconf-0.7.6 (31 Aug 2008)
+
+ 31 Aug 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +mono-zeroconf-0.7.6.ebuild:
+ Bump
28 Feb 2008; Samuli Suominen <drac@gentoo.org> mono-zeroconf-0.7.5.ebuild:
Default to avahi instead of mDNSResponder, thanks to armin76 for reminding
diff --git a/dev-dotnet/mono-zeroconf/mono-zeroconf-0.7.6.ebuild b/dev-dotnet/mono-zeroconf/mono-zeroconf-0.7.6.ebuild
new file mode 100644
index 000000000000..ea44ada1f032
--- /dev/null
+++ b/dev-dotnet/mono-zeroconf/mono-zeroconf-0.7.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono-zeroconf/mono-zeroconf-0.7.6.ebuild,v 1.1 2008/08/31 21:21:57 loki_val Exp $
+
+EAPI=1
+
+inherit eutils mono
+
+DESCRIPTION="a cross platform Zero Configuration Networking library for Mono and .NET."
+HOMEPAGE="http://www.mono-project.com/Mono.Zeroconf"
+SRC_URI="http://banshee-project.org/files/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+avahi"
+
+RDEPEND=">=dev-lang/mono-1.1.10
+ avahi? ( >=net-dns/avahi-0.6 )
+ !avahi? ( net-misc/mDNSResponder )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ local fail="Re-emerge net-dns/avahi with USE mono."
+ if use avahi && ! built_with_use net-dns/avahi mono; then
+ eerror "${fail}"
+ die "${fail}"
+ fi
+}
+
+src_compile() {
+ local myconf
+ use avahi || myconf="--disable-avahi"
+ use avahi && myconf="--disable-mdnsresponder"
+ econf --disable-docs ${myconf}
+ emake -j1 || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README
+}