summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-02-27 13:57:23 +0000
committerPacho Ramos <pacho@gentoo.org>2011-02-27 13:57:23 +0000
commit033262bf992e598c121b153f48baa5d1fa01efb0 (patch)
treee2501785b9cbae29bb8b41274e9805a7df700849 /dev-dotnet
parentStable on amd64 wrt bug #325069 (diff)
downloadgentoo-2-033262bf992e598c121b153f48baa5d1fa01efb0.tar.gz
gentoo-2-033262bf992e598c121b153f48baa5d1fa01efb0.tar.bz2
gentoo-2-033262bf992e598c121b153f48baa5d1fa01efb0.zip
Version bump.
(Portage version: 2.1.9.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/monotorrent/ChangeLog9
-rw-r--r--dev-dotnet/monotorrent/monotorrent-0.80.ebuild49
2 files changed, 56 insertions, 2 deletions
diff --git a/dev-dotnet/monotorrent/ChangeLog b/dev-dotnet/monotorrent/ChangeLog
index c296d5f455c2..d56218f47923 100644
--- a/dev-dotnet/monotorrent/ChangeLog
+++ b/dev-dotnet/monotorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-dotnet/monotorrent
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/monotorrent/ChangeLog,v 1.6 2009/08/31 13:58:26 loki_val Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/monotorrent/ChangeLog,v 1.7 2011/02/27 13:57:23 pacho Exp $
+
+*monotorrent-0.80 (27 Feb 2011)
+
+ 27 Feb 2011; Pacho Ramos <pacho@gentoo.org> +monotorrent-0.80.ebuild:
+ Version bump.
31 Aug 2009; Peter Alfredsen <loki_val@gentoo.org>
-monotorrent-0.70.ebuild, monotorrent-0.72.ebuild, -files/mono.snk:
diff --git a/dev-dotnet/monotorrent/monotorrent-0.80.ebuild b/dev-dotnet/monotorrent/monotorrent-0.80.ebuild
new file mode 100644
index 000000000000..e0bffcabd207
--- /dev/null
+++ b/dev-dotnet/monotorrent/monotorrent-0.80.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/monotorrent/monotorrent-0.80.ebuild,v 1.1 2011/02/27 13:57:23 pacho Exp $
+
+EAPI=2
+
+inherit mono multilib
+
+DESCRIPTION="Monotorrent is an open source C# bittorrent library"
+HOMEPAGE="http://projects.qnetp.net/projects/show/monotorrent"
+SRC_URI="http://projects.qnetp.net/attachments/download/28/${P}.tar.gz
+ mirror://gentoo/mono.snk.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND=">=dev-lang/mono-2.0.1"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.23"
+
+# The hack we do to get the dll installed in the GAC makes the unit-tests
+# defunct.
+RESTRICT="test"
+
+src_prepare() {
+ sed -i \
+ -e "/InternalsVisibleTo/d" \
+ MonoTorrent/AssemblyInfo.cs* || die
+}
+
+src_compile() {
+ emake -j1 ASSEMBLY_COMPILER_COMMAND="/usr/bin/gmcs -keyfile:${WORKDIR}/mono.snk"
+}
+
+src_install() {
+ egacinstall $(find . -name "MonoTorrent.dll")
+ dodir /usr/$(get_libdir)/pkgconfig
+ ebegin "Installing .pc file"
+ sed \
+ -e "s:@LIBDIR@:$(get_libdir):" \
+ -e "s:@PACKAGENAME@:${PN}:" \
+ -e "s:@DESCRIPTION@:${DESCRIPTION}:" \
+ -e "s:@VERSION@:${PV}:" \
+ -e 's;@LIBS@;-r:${libdir}/mono/monotorrent/MonoTorrent.dll;' \
+ "${FILESDIR}"/${PN}.pc.in > "${D}"/usr/$(get_libdir)/pkgconfig/${PN}.pc
+ PKG_CONFIG_PATH="${D}/usr/$(get_libdir)/pkgconfig/" pkg-config --exists monotorrent || die ".pc file failed to validate."
+ eend $?
+}