summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-28 10:55:11 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-28 10:55:11 +0000
commit45ebe7508078bbd1ef8c359ae46cb461bf64d32f (patch)
treed164c5753f6fdd9ba2db9ce5ef8ef8d8773e6ae2 /dev-dotnet/zeitgeist-sharp
parentbinary 0.5.1.0 is a ghc 7.4.2 core lib (diff)
downloadgentoo-2-45ebe7508078bbd1ef8c359ae46cb461bf64d32f.tar.gz
gentoo-2-45ebe7508078bbd1ef8c359ae46cb461bf64d32f.tar.bz2
gentoo-2-45ebe7508078bbd1ef8c359ae46cb461bf64d32f.zip
dev-dotnet/zeitgeist-sharp: Correct version of zeitgeist dep (missing zeitgeist-daemon.pc), #423937; fix building with automake-1.12
(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)
Diffstat (limited to 'dev-dotnet/zeitgeist-sharp')
-rw-r--r--dev-dotnet/zeitgeist-sharp/ChangeLog7
-rw-r--r--dev-dotnet/zeitgeist-sharp/files/zeitgeist-sharp-0.8.0.0-automake-1.12.patch28
-rw-r--r--dev-dotnet/zeitgeist-sharp/zeitgeist-sharp-0.8.0.0.ebuild6
3 files changed, 38 insertions, 3 deletions
diff --git a/dev-dotnet/zeitgeist-sharp/ChangeLog b/dev-dotnet/zeitgeist-sharp/ChangeLog
index 91b089e79213..21e5102ff398 100644
--- a/dev-dotnet/zeitgeist-sharp/ChangeLog
+++ b/dev-dotnet/zeitgeist-sharp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-dotnet/zeitgeist-sharp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/zeitgeist-sharp/ChangeLog,v 1.2 2012/05/04 03:56:57 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/zeitgeist-sharp/ChangeLog,v 1.3 2012/06/28 10:55:11 jlec Exp $
+
+ 28 Jun 2012; Justin Lecher <jlec@gentoo.org> zeitgeist-sharp-0.8.0.0.ebuild,
+ +files/zeitgeist-sharp-0.8.0.0-automake-1.12.patch:
+ Correct version of zeitgeist dep (missing zeitgeist-daemon.pc), #423937; fix
+ building with automake-1.12
04 May 2012; Jeff Horelick <jdhore@gentoo.org>
zeitgeist-sharp-0.8.0.0.ebuild:
diff --git a/dev-dotnet/zeitgeist-sharp/files/zeitgeist-sharp-0.8.0.0-automake-1.12.patch b/dev-dotnet/zeitgeist-sharp/files/zeitgeist-sharp-0.8.0.0-automake-1.12.patch
new file mode 100644
index 000000000000..b451be8464b7
--- /dev/null
+++ b/dev-dotnet/zeitgeist-sharp/files/zeitgeist-sharp-0.8.0.0-automake-1.12.patch
@@ -0,0 +1,28 @@
+Description: Use a custom target, programfilesdir, to install to pkglibdir.
+ Automake 1.11.2 changed behaviour here, breaking the build.
+Author: Iain Lane <laney@debian.org>
+Forwarded: no
+
+Index: b/Makefile.am
+===================================================================
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,3 +1,3 @@
+ EXTRA_DIST = expansions.m4
+ SUBDIRS = Zeitgeist
+-EXTRA_DIST = LICENSE MAINTAINERS NEWS
++EXTRA_DIST += LICENSE MAINTAINERS NEWS
+Index: b/Zeitgeist/Makefile.am
+===================================================================
+--- a/Zeitgeist/Makefile.am
++++ b/Zeitgeist/Makefile.am
+@@ -13,7 +13,8 @@
+ ZS_GACUTIL_UNINSTALL = $(GACUTIL) -u $(ZS_ASSEMBLY_NAME) $(GACUTIL_FLAGS)
+
+ # magic automake variables
+-pkglib_DATA = \
++programfilesdir = $(pkglibdir)
++programfiles_DATA = \
+ $(ZS_ASSEMBLY_TARGET) $(ZS_ASSEMBLY_TARGET).mdb
+
+ EXTRA_DIST = \
diff --git a/dev-dotnet/zeitgeist-sharp/zeitgeist-sharp-0.8.0.0.ebuild b/dev-dotnet/zeitgeist-sharp/zeitgeist-sharp-0.8.0.0.ebuild
index b1aceda4a43a..61c4b785b17a 100644
--- a/dev-dotnet/zeitgeist-sharp/zeitgeist-sharp-0.8.0.0.ebuild
+++ b/dev-dotnet/zeitgeist-sharp/zeitgeist-sharp-0.8.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/zeitgeist-sharp/zeitgeist-sharp-0.8.0.0.ebuild,v 1.2 2012/05/04 03:56:57 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/zeitgeist-sharp/zeitgeist-sharp-0.8.0.0.ebuild,v 1.3 2012/06/28 10:55:11 jlec Exp $
EAPI=4
@@ -25,12 +25,14 @@ RDEPEND="
dev-dotnet/dbus-sharp-glib
dev-dotnet/glib-sharp
dev-lang/mono
- gnome-extra/zeitgeist"
+ <gnome-extra/zeitgeist-0.9"
DEPEND="${RDEPEND}
virtual/pkgconfig"
AUTOTOOLS_IN_SOURCE_BUILD=1
+PATCHES=( "${FILESDIR}"/${P}-automake-1.12.patch )
+
src_install() {
autotools-utils_src_install
use doc && dohtml -r "${WORKDIR}"/${PN}-docs/*