summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRainer Groesslinger <scandium@gentoo.org>2004-08-08 07:46:29 +0000
committerRainer Groesslinger <scandium@gentoo.org>2004-08-08 07:46:29 +0000
commit3cf8be43d0ac93d47b5a2124f789f392cc1e4f32 (patch)
tree345647dc8cdc487066ae146927e96801fbfa1157 /dev-dotnet/pnet
parentInitial commit - A library that implements Just-In-Time compilation functiona... (diff)
downloadgentoo-2-3cf8be43d0ac93d47b5a2124f789f392cc1e4f32.tar.gz
gentoo-2-3cf8be43d0ac93d47b5a2124f789f392cc1e4f32.tar.bz2
gentoo-2-3cf8be43d0ac93d47b5a2124f789f392cc1e4f32.zip
new version
Diffstat (limited to 'dev-dotnet/pnet')
-rw-r--r--dev-dotnet/pnet/ChangeLog7
-rw-r--r--dev-dotnet/pnet/Manifest16
-rw-r--r--dev-dotnet/pnet/files/digest-pnet-0.6.81
-rw-r--r--dev-dotnet/pnet/pnet-0.6.8.ebuild43
4 files changed, 54 insertions, 13 deletions
diff --git a/dev-dotnet/pnet/ChangeLog b/dev-dotnet/pnet/ChangeLog
index 5b3ed59f7847..10c53ebbba73 100644
--- a/dev-dotnet/pnet/ChangeLog
+++ b/dev-dotnet/pnet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-dotnet/pnet
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pnet/ChangeLog,v 1.16 2004/06/24 22:04:36 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pnet/ChangeLog,v 1.17 2004/08/08 07:44:38 scandium Exp $
+
+*pnet-0.6.8 (08 Aug 2004)
+
+ 08 Aug 2004; Rainer Groesslinger <scandium@gentoo.org> +pnet-0.6.8.ebuild:
+ new version
15 Jun 2004; Jason Wever <weeve@gentoo.org> pnet-0.6.6.ebuild:
Stable on sparc.
diff --git a/dev-dotnet/pnet/Manifest b/dev-dotnet/pnet/Manifest
index a69b57a795fa..98d86c2c1597 100644
--- a/dev-dotnet/pnet/Manifest
+++ b/dev-dotnet/pnet/Manifest
@@ -1,15 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 02f9ab5b5a75a08f954f1e7bbf4af37b pnet-0.6.6.ebuild 1276
+MD5 1aae775a288becdc8886d0a570a7f68a pnet-0.6.8.ebuild 1134
MD5 ddc01ea1fd66477dbf0e6602a2923a2c ChangeLog 3143
MD5 76b314cc7b7b79b298dd4889dff8c9cd metadata.xml 159
-MD5 02f9ab5b5a75a08f954f1e7bbf4af37b pnet-0.6.6.ebuild 1276
-MD5 e037d34aa40e555d9a9a193104770ea4 files/digest-pnet-0.6.6 63
MD5 97a60b64bbeb718a8c070c92ca94e5ab files/verify_branch.c.patch 389
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.8 (GNU/Linux)
-
-iD8DBQFA4X7uHTu7gpaalycRAmlaAKD9EENfsRDYjv1SqnmSxLGI0DV5uACfXTnL
-SDfbkljKykjFnkUs+NkiPZM=
-=HYjj
------END PGP SIGNATURE-----
+MD5 e037d34aa40e555d9a9a193104770ea4 files/digest-pnet-0.6.6 63
+MD5 667e6fd9c070460b9b0b7293a5ecb096 files/digest-pnet-0.6.8 63
diff --git a/dev-dotnet/pnet/files/digest-pnet-0.6.8 b/dev-dotnet/pnet/files/digest-pnet-0.6.8
new file mode 100644
index 000000000000..b01b824adfc7
--- /dev/null
+++ b/dev-dotnet/pnet/files/digest-pnet-0.6.8
@@ -0,0 +1 @@
+MD5 8640255197f34ac155fd49140692cdae pnet-0.6.8.tar.gz 3504435
diff --git a/dev-dotnet/pnet/pnet-0.6.8.ebuild b/dev-dotnet/pnet/pnet-0.6.8.ebuild
new file mode 100644
index 000000000000..140645b5520e
--- /dev/null
+++ b/dev-dotnet/pnet/pnet-0.6.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pnet/pnet-0.6.8.ebuild,v 1.1 2004/08/08 07:44:38 scandium Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Portable .NET runtime, compiler, tools"
+HOMEPAGE="http://www.dotgnu.org/"
+SRC_URI="mirror://gnu/dotgnu/pnet/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64"
+IUSE=""
+
+DEPEND=">=dev-util/treecc-0.3.0
+ !dev-dotnet/mono"
+
+src_compile() {
+ use amd64 && replace-flags -O? -O1
+ econf || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ dodoc AUTHORS ChangeLog HACKING INSTALL NEWS README
+ dodoc doc/gtk-sharp.HOWTO
+ dohtml doc/*.html
+
+ # init script
+ exeinto /etc/init.d ; newexe ${PORTDIR}/dev-dotnet/mono/files/dotnet.init dotnet
+ insinto /etc/conf.d ; newins ${PORTDIR}/dev-dotnet/mono/files/dotnet.conf dotnet
+}
+
+pkg_postinst() {
+ echo
+ einfo "If you want to avoid typing '<runtime> program.exe'"
+ einfo "you can configure your runtime in /etc/conf.d/dotnet"
+ einfo "Use /etc/init.d/dotnet to register your runtime"
+ echo
+}