summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2005-05-13 00:45:12 +0000
committerPeter Johanson <latexer@gentoo.org>2005-05-13 00:45:12 +0000
commit408cf8a0c077812318faf3eea0860d6a00a4c7e2 (patch)
tree2b1865c67059c5e0b752c35ee91bd692d8625c88 /dev-dotnet/nant/nant-0.85_rc3.ebuild
parentmark stable (diff)
downloadgentoo-2-408cf8a0c077812318faf3eea0860d6a00a4c7e2.tar.gz
gentoo-2-408cf8a0c077812318faf3eea0860d6a00a4c7e2.tar.bz2
gentoo-2-408cf8a0c077812318faf3eea0860d6a00a4c7e2.zip
Bump. Includes fixes to make nant compile on mono-1.1.7, and now builds with the 2.0 profile if on mono-1.1.x
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'dev-dotnet/nant/nant-0.85_rc3.ebuild')
-rw-r--r--dev-dotnet/nant/nant-0.85_rc3.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/dev-dotnet/nant/nant-0.85_rc3.ebuild b/dev-dotnet/nant/nant-0.85_rc3.ebuild
new file mode 100644
index 000000000000..88d52cbd2af7
--- /dev/null
+++ b/dev-dotnet/nant/nant-0.85_rc3.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/nant/nant-0.85_rc3.ebuild,v 1.1 2005/05/13 00:45:12 latexer Exp $
+
+inherit mono eutils
+
+MY_P=${P/_rc/-rc}
+
+DESCRIPTION=".NET build tool"
+HOMEPAGE="http://nant.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lang/mono"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ local targetlibdir=""
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-0.85-rc2-is-unix.diff || die
+ epatch ${FILESDIR}/${PN}-0.85-rc2-profile.diff || die
+ epatch ${FILESDIR}/${MY_P}-mono-1.1.7-compat.diff || die
+
+ # Fix a problem with duplicate building caused by the doc= target
+ for file in $(find ${S}/src -name '*.build')
+ do
+ sed -i "s: doc=.*>:>:" \
+ ${file}
+ done
+
+ # Problem with is-unix() on mono-1.1.x where the platform is detected
+ # as !is-unix().
+ sed -i -e "s:install-windows, install-linux:install-linux:" \
+ -e 's:if.*is-unix()}\"::' \
+ ${S}/NAnt.build || die "sed failed"
+
+ # When we have mono-1.1.x, we should build against 2.0,
+ # so that people using nant can use either the 2.0 or 1.0 profiles
+ if has_version ">=dev-lang/mono-1.1.4"; then
+ sed -i -e "s/-f:NAnt.build/-t:mono-2.0 -f:NAnt.build/" \
+ ${S}/Makefile || die "sed failed"
+
+ targetlibdir="${S}/build/mono-2.0.unix/nant-0.85-debug/bin/lib/"
+ else
+ # Fix for AppDomain unloading on 1.0.x. See bug #90113
+ export MONO_NO_UNLOAD=1
+ targetlibdir="${S}/build/mono-1.0.unix/nant-0.85-debug/bin/lib/"
+ fi
+
+ # Fix for build problem with rc3
+ mkdir -p "${targetlibdir}"
+ cp ${S}/lib/log4net.dll "${targetlibdir}"
+}
+
+src_compile() {
+ emake -j1 || die
+}
+
+src_install() {
+ make prefix=${D}/usr install || die
+ # Fix ${D} showing up in the nant wrapper script, as well as silencing
+ # warnings related to the log4net library
+ sed -i \
+ -e "s:${D}::" \
+ -e "2iexport MONO_SILENT_WARNING=1" \
+ ${D}/usr/bin/nant
+ dodoc README.txt
+
+ # Remove the extraneous log4net.dll copy
+ rm ${D}/usr/share/NAnt/bin/lib/log4net.dll
+}