summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-06-24 17:28:32 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-06-24 17:28:32 +0000
commit2856531ee99f9c5159a9ecde94c021d54c1ae9f4 (patch)
treea4d39df1fb062182c78a84ca0ffa60b553c780d0 /dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild
parentAdded ~amd64 (diff)
downloadgentoo-2-2856531ee99f9c5159a9ecde94c021d54c1ae9f4.tar.gz
gentoo-2-2856531ee99f9c5159a9ecde94c021d54c1ae9f4.tar.bz2
gentoo-2-2856531ee99f9c5159a9ecde94c021d54c1ae9f4.zip
dev-dotnet/monocalendar: initial version (fixing bug #88921)
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild')
-rw-r--r--dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild b/dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild
new file mode 100644
index 000000000000..4986c22ff5d2
--- /dev/null
+++ b/dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild,v 1.1 2007/06/24 17:28:32 jurek Exp $
+
+inherit mono eutils
+
+S="${WORKDIR}/MonoCalendar"
+
+DESCRIPTION="iCal clone for .NET"
+HOMEPAGE="http://www.monocalendar.com/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-source-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=dev-lang/mono-1.2.1"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ cd ${S}/bin/Release/
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/$(get_libdir)/${PN}
+ insinto /usr/$(get_libdir)/${PN}
+
+ doins bin/Release/*dll
+ doins bin/Release/*.exe
+
+ make_wrapper monocalendar "mono /usr/$(get_libdir)/${PN}/MonoCalendar.exe"
+}