summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTodd Berman <tberman@gentoo.org>2004-02-13 20:11:07 +0000
committerTodd Berman <tberman@gentoo.org>2004-02-13 20:11:07 +0000
commit2033155a332261cd5010e69025911c59da4901a3 (patch)
tree327fda0fc49beaabd63803d42fe3f77b2d2d8ba5 /dev-dotnet/mono
parentvarious fixes (Manifest recommit) (diff)
downloadgentoo-2-2033155a332261cd5010e69025911c59da4901a3.tar.gz
gentoo-2-2033155a332261cd5010e69025911c59da4901a3.tar.bz2
gentoo-2-2033155a332261cd5010e69025911c59da4901a3.zip
version bump
Diffstat (limited to 'dev-dotnet/mono')
-rw-r--r--dev-dotnet/mono/ChangeLog10
-rw-r--r--dev-dotnet/mono/files/digest-mono-0.26-r12
-rw-r--r--dev-dotnet/mono/files/digest-mono-0.302
-rw-r--r--dev-dotnet/mono/mono-0.30.ebuild (renamed from dev-dotnet/mono/mono-0.26-r1.ebuild)22
4 files changed, 26 insertions, 10 deletions
diff --git a/dev-dotnet/mono/ChangeLog b/dev-dotnet/mono/ChangeLog
index 0727f46d1963..b410be58cf9c 100644
--- a/dev-dotnet/mono/ChangeLog
+++ b/dev-dotnet/mono/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-dotnet/mono
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono/ChangeLog,v 1.6 2003/10/04 20:07:21 scandium Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono/ChangeLog,v 1.7 2004/02/13 20:11:07 tberman Exp $
+
+*mono-0.30 (13 Feb 2004)
+
+ 13 Feb 2004; Todd Berman <tberman@gentoo.org> mono-0.26-r1.ebuild,
+ mono-0.30.ebuild:
+ Adding 0.30, removing 0.26
*mono-0.28 (04 Oct 2003)
diff --git a/dev-dotnet/mono/files/digest-mono-0.26-r1 b/dev-dotnet/mono/files/digest-mono-0.26-r1
deleted file mode 100644
index f9f4f430f3eb..000000000000
--- a/dev-dotnet/mono/files/digest-mono-0.26-r1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 6821b1e8e4493109d9d42a90a631223a mono-0.26.tar.gz 8939242
-MD5 4ccc74667ff4d79ba08b341d2e684921 mcs-0.26.tar.gz 5990189
diff --git a/dev-dotnet/mono/files/digest-mono-0.30 b/dev-dotnet/mono/files/digest-mono-0.30
new file mode 100644
index 000000000000..1a03f12dbd60
--- /dev/null
+++ b/dev-dotnet/mono/files/digest-mono-0.30
@@ -0,0 +1,2 @@
+MD5 84bc49f39c905936d594042fd29cd07c mono-0.30.tar.gz 9713905
+MD5 05152878b29d3e3bfcd1b902cf7e6817 mcs-0.30.tar.gz 8080066
diff --git a/dev-dotnet/mono/mono-0.26-r1.ebuild b/dev-dotnet/mono/mono-0.30.ebuild
index 26cffcdc6f26..804c589176de 100644
--- a/dev-dotnet/mono/mono-0.26-r1.ebuild
+++ b/dev-dotnet/mono/mono-0.30.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono/mono-0.26-r1.ebuild,v 1.3 2004/02/07 20:27:50 scandium Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono/mono-0.30.ebuild,v 1.1 2004/02/13 20:11:07 tberman Exp $
-inherit mono
+inherit mono flag-o-matic
+
+strip-flags
MCS_P="mcs-${PV}"
MCS_S=${WORKDIR}/${MCS_P}
@@ -13,19 +15,19 @@ SRC_URI="http://www.go-mono.com/archive/${P}.tar.gz
http://www.go-mono.com/archive/${MCS_P}.tar.gz"
HOMEPAGE="http://www.go-mono.com/"
-LICENSE="GPL-2 LGPL-2 X11"
+LICENSE="GPL-2 | LGPL-2 | X11"
SLOT="0"
-KEYWORDS="x86 -ppc"
+KEYWORDS="~x86 -ppc"
DEPEND="virtual/glibc
>=dev-libs/glib-2.0
+ >=dev-libs/icu-2.6
!dev-dotnet/pnet"
RDEPEND="${DEPEND}
dev-util/pkgconfig
- dev-libs/libxml2
- dev-libs/libxslt"
+ dev-libs/libxml2"
src_unpack() {
unpack ${A}
@@ -33,6 +35,12 @@ src_unpack() {
# add our own little in-place mcs script
echo "${S}/mono/mini/mono ${S}/runtime/mcs.exe \"\$@\" " > ${S}/runtime/mcs
chmod +x ${S}/runtime/mcs
+
+ echo "${S}/mono/mini/mono ${S}/runtime/monoresgen.exe \"\$@\" " > ${S}/runtime/monoresgen
+ chmod +x ${S}/runtime/monoresgen
+
+ PATH="${PATH}:${S}/runtime"
+ export PATH
}
src_compile() {
@@ -45,6 +53,8 @@ src_compile() {
echo "MONO_PATH=${S}/runtime" >> build/config.make
echo "BOOTSTRAP_MCS=${S}/runtime/mcs" >> build/config.make
echo "RUNTIME=${S}/mono/mini/mono \${RUNTIME_FLAGS}" >> build/config.make
+ echo "PATH=${PATH}:${S}/runtime" >> build/config.make
+ echo "export PATH" >> build/config.make
echo "export MONO_PATH" >> build/config.make
make || die "MCS compilation failure"
echo "prefix=/usr" >> build/config.make