summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-01-25 13:56:40 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-01-25 13:56:40 +0000
commitb56c4b780dfa94a5f15517255a8062c148c20b9a (patch)
tree4afe7280ee36041187d79d8a9ad9a903b65407b2 /dev-dotnet/mono-zeroconf
parentamd64/x86 stable, bug #256078 (diff)
downloadgentoo-2-b56c4b780dfa94a5f15517255a8062c148c20b9a.tar.gz
gentoo-2-b56c4b780dfa94a5f15517255a8062c148c20b9a.tar.bz2
gentoo-2-b56c4b780dfa94a5f15517255a8062c148c20b9a.zip
Fix bug 252647, thanks to Paul de Vrieze (pauldv@gentoo.org) for the patch.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-dotnet/mono-zeroconf')
-rw-r--r--dev-dotnet/mono-zeroconf/ChangeLog12
-rw-r--r--dev-dotnet/mono-zeroconf/files/mono-zeroconf-0.8.0-mono-2.2.patch24
-rw-r--r--dev-dotnet/mono-zeroconf/mono-zeroconf-0.8.0-r1.ebuild (renamed from dev-dotnet/mono-zeroconf/mono-zeroconf-0.8.0.ebuild)31
3 files changed, 47 insertions, 20 deletions
diff --git a/dev-dotnet/mono-zeroconf/ChangeLog b/dev-dotnet/mono-zeroconf/ChangeLog
index 4355f6e319d7..8a32745ecbc7 100644
--- a/dev-dotnet/mono-zeroconf/ChangeLog
+++ b/dev-dotnet/mono-zeroconf/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-dotnet/mono-zeroconf
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono-zeroconf/ChangeLog,v 1.5 2008/11/24 00:13:14 loki_val Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono-zeroconf/ChangeLog,v 1.6 2009/01/25 13:56:40 loki_val Exp $
+
+*mono-zeroconf-0.8.0-r1 (25 Jan 2009)
+
+ 25 Jan 2009; Peter Alfredsen <loki_val@gentoo.org>
+ +files/mono-zeroconf-0.8.0-mono-2.2.patch, -mono-zeroconf-0.8.0.ebuild,
+ +mono-zeroconf-0.8.0-r1.ebuild:
+ Fix bug 252647, thanks to Paul de Vrieze (pauldv@gentoo.org) for the
+ patch.
*mono-zeroconf-0.8.0 (24 Nov 2008)
diff --git a/dev-dotnet/mono-zeroconf/files/mono-zeroconf-0.8.0-mono-2.2.patch b/dev-dotnet/mono-zeroconf/files/mono-zeroconf-0.8.0-mono-2.2.patch
new file mode 100644
index 000000000000..777ff0134970
--- /dev/null
+++ b/dev-dotnet/mono-zeroconf/files/mono-zeroconf-0.8.0-mono-2.2.patch
@@ -0,0 +1,24 @@
+diff -urN mono-zeroconf-0.8.0.orig/src/Mono.Zeroconf.Providers.AvahiDBus/Mono.Zeroconf.Providers.AvahiDBus/Service.cs mono-zeroconf-0.8.0/src/Mono.Zeroconf.Providers.AvahiDBus/Mono.Zeroconf.Providers.AvahiDBus/Service.cs
+--- mono-zeroconf-0.8.0.orig/src/Mono.Zeroconf.Providers.AvahiDBus/Mono.Zeroconf.Providers.AvahiDBus/Service.cs 2008-06-27 00:45:12.000000000 +0200
++++ mono-zeroconf-0.8.0/src/Mono.Zeroconf.Providers.AvahiDBus/Mono.Zeroconf.Providers.AvahiDBus/Service.cs 2009-01-22 16:52:58.155891843 +0100
+@@ -65,17 +65,17 @@
+
+ public string Name {
+ get { return name; }
+- protected set { name = value; }
++ set { name = value; }
+ }
+
+ public string RegType {
+ get { return regtype; }
+- protected set { regtype = value; }
++ set { regtype = value; }
+ }
+
+ public string ReplyDomain {
+ get { return reply_domain; }
+- protected set { reply_domain = value; }
++ set { reply_domain = value; }
+ }
+
+ public uint NetworkInterface {
diff --git a/dev-dotnet/mono-zeroconf/mono-zeroconf-0.8.0.ebuild b/dev-dotnet/mono-zeroconf/mono-zeroconf-0.8.0-r1.ebuild
index 80cccd78347f..a0cf1d4a34a6 100644
--- a/dev-dotnet/mono-zeroconf/mono-zeroconf-0.8.0.ebuild
+++ b/dev-dotnet/mono-zeroconf/mono-zeroconf-0.8.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono-zeroconf/mono-zeroconf-0.8.0.ebuild,v 1.1 2008/11/24 00:13:14 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono-zeroconf/mono-zeroconf-0.8.0-r1.ebuild,v 1.1 2009/01/25 13:56:40 loki_val Exp $
-EAPI=1
+EAPI=2
-inherit eutils mono
+inherit base mono
DESCRIPTION="a cross platform Zero Configuration Networking library for Mono and .NET."
HOMEPAGE="http://www.mono-project.com/Mono.Zeroconf"
@@ -13,31 +13,26 @@ SRC_URI="http://banshee-project.org/files/${PN}/${P}.tar.bz2"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+avahi"
+IUSE="doc +avahi"
-RDEPEND=">=dev-lang/mono-1.1.10
- avahi? ( >=net-dns/avahi-0.6 )
+RDEPEND=">=dev-lang/mono-2.0
+ avahi? ( >=net-dns/avahi-0.6[mono] )
!avahi? ( net-misc/mDNSResponder )"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-pkg_setup() {
- local fail="Re-emerge net-dns/avahi with USE mono."
- if use avahi && ! built_with_use net-dns/avahi mono; then
- eerror "${fail}"
- die "${fail}"
- fi
+PATCHES=( "${FILESDIR}/${P}-mono-2.2.patch" )
+
+src_configure() {
+ econf $(use_enable doc docs)$(use_enable avahi) $(use_enable !avahi mdnsresponder)
}
src_compile() {
- local myconf
- use avahi || myconf="--disable-avahi"
- use avahi && myconf="--disable-mdnsresponder"
- econf --disable-docs ${myconf}
emake -j1 || die "emake failed."
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed."
- dodoc AUTHORS ChangeLog NEWS README
+ dodoc AUTHORS ChangeLog NEWS README || die "docs failed"
+ mono_multilib_comply
}