summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2008-01-13 02:25:09 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2008-01-13 02:25:09 +0000
commitc3b126f0ce61ec2b5685abb1a7079d0a9bee6b73 (patch)
treef36f209f116c9c83534a429a191f8b5f42fe0d12 /dev-dotnet/gtk-sharp
parentFix doc bundle installation for 3.5.4. Upstream changed the directory name. (diff)
downloadgentoo-2-c3b126f0ce61ec2b5685abb1a7079d0a9bee6b73.tar.gz
gentoo-2-c3b126f0ce61ec2b5685abb1a7079d0a9bee6b73.tar.bz2
gentoo-2-c3b126f0ce61ec2b5685abb1a7079d0a9bee6b73.zip
version bump from upstream. fixes bug #200504
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'dev-dotnet/gtk-sharp')
-rw-r--r--dev-dotnet/gtk-sharp/ChangeLog10
-rw-r--r--dev-dotnet/gtk-sharp/files/digest-gtk-sharp-2.10.26
-rw-r--r--dev-dotnet/gtk-sharp/gtk-sharp-2.10.2.ebuild55
3 files changed, 69 insertions, 2 deletions
diff --git a/dev-dotnet/gtk-sharp/ChangeLog b/dev-dotnet/gtk-sharp/ChangeLog
index df3a43c93319..123ab2aeaa3f 100644
--- a/dev-dotnet/gtk-sharp/ChangeLog
+++ b/dev-dotnet/gtk-sharp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-dotnet/gtk-sharp
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gtk-sharp/ChangeLog,v 1.78 2007/04/13 22:11:31 betelgeuse Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gtk-sharp/ChangeLog,v 1.79 2008/01/13 02:25:08 compnerd Exp $
+
+*gtk-sharp-2.10.2 (13 Jan 2008)
+
+ 13 Jan 2008; Saleem Abdulrasool <compnerd@gentoo.org>
+ +gtk-sharp-2.10.2.ebuild:
+ Version bump from upstream. Fixes bug #200504.
13 Apr 2007; Petteri Räty <betelgeuse@gentoo.org>
-gtk-sharp-1.0.8-r1.ebuild, -gtk-sharp-2.4.0.ebuild,
diff --git a/dev-dotnet/gtk-sharp/files/digest-gtk-sharp-2.10.2 b/dev-dotnet/gtk-sharp/files/digest-gtk-sharp-2.10.2
new file mode 100644
index 000000000000..9b73d08fc35c
--- /dev/null
+++ b/dev-dotnet/gtk-sharp/files/digest-gtk-sharp-2.10.2
@@ -0,0 +1,6 @@
+MD5 00d1fb21c5edd1b44ce1443695733ede gtk-sharp-2.10.0-configurable.diff.gz 479
+RMD160 fae9b28f384812cc8803f6e2abe5d4ceb4051da4 gtk-sharp-2.10.0-configurable.diff.gz 479
+SHA256 66699f2ef2bd288c6af35a80fbe7441a4349759e685b44a4dca9c77551c0cba6 gtk-sharp-2.10.0-configurable.diff.gz 479
+MD5 b7f674a801054152780b7064b7318990 gtk-sharp-2.10.2.tar.gz 2138075
+RMD160 876d8bdb3062ca9575bba379d6f6d60b51a5e4ad gtk-sharp-2.10.2.tar.gz 2138075
+SHA256 0f19673b941e1149c6f988f9264344676c629598bf74677afb901372c49a11dd gtk-sharp-2.10.2.tar.gz 2138075
diff --git a/dev-dotnet/gtk-sharp/gtk-sharp-2.10.2.ebuild b/dev-dotnet/gtk-sharp/gtk-sharp-2.10.2.ebuild
new file mode 100644
index 000000000000..f6bc3bf1c485
--- /dev/null
+++ b/dev-dotnet/gtk-sharp/gtk-sharp-2.10.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gtk-sharp/gtk-sharp-2.10.2.ebuild,v 1.1 2008/01/13 02:25:08 compnerd Exp $
+
+inherit eutils mono autotools
+
+DESCRIPTION="Gtk# is a C# language binding for the GTK2 toolkit and GNOME libraries"
+HOMEPAGE="http://gtk-sharp.sourceforge.net/"
+SRC_URI="mirror://gnome/sources/${PN}/${PV%.*}/${P}.tar.gz
+ mirror://gentoo/${PN}-2.10.0-configurable.diff.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/mono-1.1.9
+ >=x11-libs/gtk+-2.10"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.19
+ doc? ( >=dev-util/monodoc-1.1.8 )"
+
+RESTRICT="test"
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${WORKDIR}/${PN}-2.10.0-configurable.diff"
+
+ sed -i -e ':^CFLAGS=:d' "${S}/configure.in"
+
+ # Fix up pkgconfig entries
+ sed -i -e 's:^prefix.*:prefix=@prefix@:' \
+ -e 's:^libdir.*:libdir=@libdir@:' \
+ "${S}"/*/*.pc.in || die
+
+ eautoreconf
+
+ # disable building of samples (#16015)
+ sed -i -e "s:sample::" Makefile.in
+}
+
+src_compile() {
+ econf --disable-glade || die "configure failed"
+ LANG=C emake || die
+}
+
+src_install () {
+ emake GACUTIL_FLAGS="/root "${D}"/usr/$(get_libdir) /gacdir /usr/$(get_libdir) /package ${PN}-2.0" \
+ DESTDIR="${D}" install || die
+
+ dodoc README* ChangeLog
+}