summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-11-26 00:55:54 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-11-26 00:55:54 +0000
commitcf06642bf60382c1f6331578c32884fc9a1f916b (patch)
treedcec20a31b8c11b1d097b04ca6bf59c4e433f589 /dev-dotnet/gconf-sharp
parentRemove homepage and SRC_URI since they point to a domain squatter now; fix de... (diff)
downloadgentoo-2-cf06642bf60382c1f6331578c32884fc9a1f916b.tar.gz
gentoo-2-cf06642bf60382c1f6331578c32884fc9a1f916b.tar.bz2
gentoo-2-cf06642bf60382c1f6331578c32884fc9a1f916b.zip
Bump to 2.24.0
(Portage version: 2.2_rc16/cvs/Linux 2.6.28-rc4 x86_64)
Diffstat (limited to 'dev-dotnet/gconf-sharp')
-rw-r--r--dev-dotnet/gconf-sharp/ChangeLog8
-rw-r--r--dev-dotnet/gconf-sharp/gconf-sharp-2.24.0.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-dotnet/gconf-sharp/ChangeLog b/dev-dotnet/gconf-sharp/ChangeLog
index 9af3bea14239..01d6d44ddd14 100644
--- a/dev-dotnet/gconf-sharp/ChangeLog
+++ b/dev-dotnet/gconf-sharp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-dotnet/gconf-sharp
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gconf-sharp/ChangeLog,v 1.54 2008/11/25 20:56:30 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gconf-sharp/ChangeLog,v 1.55 2008/11/26 00:55:54 loki_val Exp $
+
+*gconf-sharp-2.24.0 (26 Nov 2008)
+
+ 26 Nov 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +gconf-sharp-2.24.0.ebuild:
+ Bump to 2.24.0
25 Nov 2008; Peter Alfredsen <loki_val@gentoo.org>
gconf-sharp-2.16.0.ebuild:
diff --git a/dev-dotnet/gconf-sharp/gconf-sharp-2.24.0.ebuild b/dev-dotnet/gconf-sharp/gconf-sharp-2.24.0.ebuild
new file mode 100644
index 000000000000..cb55b46d091e
--- /dev/null
+++ b/dev-dotnet/gconf-sharp/gconf-sharp-2.24.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gconf-sharp/gconf-sharp-2.24.0.ebuild,v 1.1 2008/11/26 00:55:54 loki_val Exp $
+
+EAPI=2
+
+GTK_SHARP_MODULE="gnome"
+GTK_SHARP_MODULE_DEPS="art"
+GTK_SHARP_REQUIRED_VERSION="2.12"
+
+inherit gtk-sharp-module
+
+SLOT="2"
+KEYWORDS="~x86 ~ppc ~sparc ~x86-fbsd ~amd64"
+IUSE=""
+
+DEPEND="${DEPEND}
+ >=gnome-base/gconf-2.20
+ >=dev-dotnet/gtk-sharp-2.12.6[glade]
+ >=dev-dotnet/gnome-sharp-${PV}
+ >=dev-dotnet/art-sharp-${PV}"
+
+src_prepare() {
+ gtk-sharp-module_src_prepare
+
+ # The makefile for GConf.PropertyEditors references two dll's which will
+ # not be built in our case because of the splitting of gnome-sharp;
+ # reference their system-installed counterparts instead.
+ # TODO: Should this be in the eclass? If no, the other fix for gconf-sharp
+ # in the eclass should be moved here as well.
+ sed -i -e "s:\$(top_builddir)/art/art-sharp.dll:${GTK_SHARP_LIB_DIR}/art-sharp.dll:" \
+ -e "s:\$(top_builddir)/gnome/gnome-sharp.dll:${GTK_SHARP_LIB_DIR}/gnome-sharp.dll:" \
+ "${S}"/gconf/GConf.PropertyEditors/Makefile.in || die "sed failed"
+}