summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2005-05-05 02:18:54 +0000
committerPeter Johanson <latexer@gentoo.org>2005-05-05 02:18:54 +0000
commit58ef7ec1f476edaa65af1b6d12be51263094cbb1 (patch)
tree6672f912392a998fe090a360544e9e7c8683652f /dev-dotnet/gconf-sharp
parentFix up some things that broke with the re-organization. (diff)
downloadgentoo-2-58ef7ec1f476edaa65af1b6d12be51263094cbb1.tar.gz
gentoo-2-58ef7ec1f476edaa65af1b6d12be51263094cbb1.tar.bz2
gentoo-2-58ef7ec1f476edaa65af1b6d12be51263094cbb1.zip
Bump.
(Portage version: 2.0.51.21)
Diffstat (limited to 'dev-dotnet/gconf-sharp')
-rw-r--r--dev-dotnet/gconf-sharp/ChangeLog8
-rw-r--r--dev-dotnet/gconf-sharp/Manifest2
-rw-r--r--dev-dotnet/gconf-sharp/files/digest-gconf-sharp-1.9.32
-rw-r--r--dev-dotnet/gconf-sharp/gconf-sharp-1.9.3.ebuild29
4 files changed, 40 insertions, 1 deletions
diff --git a/dev-dotnet/gconf-sharp/ChangeLog b/dev-dotnet/gconf-sharp/ChangeLog
index 320e0d50f619..90108a2dfab1 100644
--- a/dev-dotnet/gconf-sharp/ChangeLog
+++ b/dev-dotnet/gconf-sharp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-dotnet/gconf-sharp
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gconf-sharp/ChangeLog,v 1.15 2005/05/03 22:30:13 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gconf-sharp/ChangeLog,v 1.16 2005/05/05 02:16:44 latexer Exp $
+
+*gconf-sharp-1.9.3 (05 May 2005)
+
+ 05 May 2005; Peter Johanson <latexer@gentoo.org>
+ +gconf-sharp-1.9.3.ebuild:
+ Bump.
03 May 2005; Peter Johanson <latexer@gentoo.org> gconf-sharp-1.0.8.ebuild:
Mark stable on x86.
diff --git a/dev-dotnet/gconf-sharp/Manifest b/dev-dotnet/gconf-sharp/Manifest
index 86e18ba31611..3a593a496db6 100644
--- a/dev-dotnet/gconf-sharp/Manifest
+++ b/dev-dotnet/gconf-sharp/Manifest
@@ -4,7 +4,9 @@ MD5 c79a338b20f93bfb8dc4fac66c859383 gconf-sharp-1.0.6.ebuild 791
MD5 62c2aea04c208f7765edc58bb2f3ddf3 gconf-sharp-1.0.8.ebuild 792
MD5 da5c4c6e53a255488f042c721f8a0734 ChangeLog 1357
MD5 a60fdfbce7c7cfc52187ff86a7f8bbf8 metadata.xml 222
+MD5 1ebee71a1c318e69375a7d8a72ab59de gconf-sharp-1.9.3.ebuild 821
MD5 b63c29f6761c048a9d7943713c15c78c files/digest-gconf-sharp-1.0.4 147
MD5 ff5a2a47c3e1d785fc179c922857e409 files/digest-gconf-sharp-1.0.6 147
MD5 3af46f2e9fbd6a7f642bc1ef502d50ca files/digest-gconf-sharp-1.0.8 147
MD5 d1dddb54802e684259aedfd27a11af15 files/digest-gconf-sharp-1.9.2 147
+MD5 284fbaa2e02c9f1dca27440457411e0b files/digest-gconf-sharp-1.9.3 147
diff --git a/dev-dotnet/gconf-sharp/files/digest-gconf-sharp-1.9.3 b/dev-dotnet/gconf-sharp/files/digest-gconf-sharp-1.9.3
new file mode 100644
index 000000000000..d3aaed887246
--- /dev/null
+++ b/dev-dotnet/gconf-sharp/files/digest-gconf-sharp-1.9.3
@@ -0,0 +1,2 @@
+MD5 c7654c4947a554d7fd588f035c7ef92a gtk-sharp-1.9.3.tar.gz 2186372
+MD5 2f54720cea7a0f0f517c95ea9df0b8d1 gtk-sharp-1.9.3-configurable.diff.gz 1480
diff --git a/dev-dotnet/gconf-sharp/gconf-sharp-1.9.3.ebuild b/dev-dotnet/gconf-sharp/gconf-sharp-1.9.3.ebuild
new file mode 100644
index 000000000000..1b659f382c58
--- /dev/null
+++ b/dev-dotnet/gconf-sharp/gconf-sharp-1.9.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gconf-sharp/gconf-sharp-1.9.3.ebuild,v 1.1 2005/05/05 02:16:44 latexer Exp $
+
+inherit gtk-sharp-component
+
+SLOT="2"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+DEPEND="${DEPEND}
+ >=gnome-base/gconf-2.0
+ =dev-dotnet/glade-sharp-${PV}*
+ =dev-dotnet/gnome-sharp-${PV}*
+ =dev-dotnet/art-sharp-${PV}*"
+
+GTK_SHARP_COMPONENT_BUILD="gnome"
+GTK_SHARP_COMPONENT_BUILD_DEPS="art"
+GTK_SHARP_COMPONENT_SLOT="2"
+GTK_SHARP_COMPONENT_SLOT_DEC="-2.0"
+
+
+src_unpack() {
+ gtk-sharp-component_src_unpack
+
+ # Fix need as GConf.PropertyEditors references a locally built dll
+ sed -i "s:${GTK_SHARP_LIB_DIR}/gconf-sharp.dll:../GConf/gconf-sharp.dll:" \
+ ${S}/gconf/GConf.PropertyEditors/Makefile.in
+}