summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-09-21 12:22:48 +0000
committerPacho Ramos <pacho@gentoo.org>2010-09-21 12:22:48 +0000
commit448313ef01cdffe2eef7461d4443c139e0a31635 (patch)
tree81ece52c6b7a3c584439791902daae692a3e8c70 /dev-dotnet/flickrnet-bin
parentVersion bump. Remove old bogus version (diff)
downloadgentoo-2-448313ef01cdffe2eef7461d4443c139e0a31635.tar.gz
gentoo-2-448313ef01cdffe2eef7461d4443c139e0a31635.tar.bz2
gentoo-2-448313ef01cdffe2eef7461d4443c139e0a31635.zip
Revision bump to install pkgconfig file as needed by future f-spot versions. Remove old.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-dotnet/flickrnet-bin')
-rw-r--r--dev-dotnet/flickrnet-bin/ChangeLog11
-rw-r--r--dev-dotnet/flickrnet-bin/files/flickrnet.pc.in8
-rw-r--r--dev-dotnet/flickrnet-bin/flickrnet-bin-2.2-r1.ebuild (renamed from dev-dotnet/flickrnet-bin/flickrnet-bin-2.2.ebuild)13
3 files changed, 27 insertions, 5 deletions
diff --git a/dev-dotnet/flickrnet-bin/ChangeLog b/dev-dotnet/flickrnet-bin/ChangeLog
index 35d0d74fc449..77f1da78144d 100644
--- a/dev-dotnet/flickrnet-bin/ChangeLog
+++ b/dev-dotnet/flickrnet-bin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-dotnet/flickrnet-bin
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/flickrnet-bin/ChangeLog,v 1.3 2009/11/06 16:34:05 volkmar Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/flickrnet-bin/ChangeLog,v 1.4 2010/09/21 12:22:48 pacho Exp $
+
+*flickrnet-bin-2.2-r1 (21 Sep 2010)
+
+ 21 Sep 2010; Pacho Ramos <pacho@gentoo.org> -flickrnet-bin-2.2.ebuild,
+ +flickrnet-bin-2.2-r1.ebuild, +files/flickrnet.pc.in:
+ Revision bump to install pkgconfig file as needed by future f-spot
+ versions. Remove old.
06 Nov 2009; Mounir Lamouri <volkmar@gentoo.org> flickrnet-bin-2.2.ebuild:
Keywording for ppc, bug 284473
diff --git a/dev-dotnet/flickrnet-bin/files/flickrnet.pc.in b/dev-dotnet/flickrnet-bin/files/flickrnet.pc.in
new file mode 100644
index 000000000000..326042df5fec
--- /dev/null
+++ b/dev-dotnet/flickrnet-bin/files/flickrnet.pc.in
@@ -0,0 +1,8 @@
+libdir=@LIBDIR@
+assemblies_dir=${libdir}/mono/FlickrNet
+Libraries=${assemblies_dir}/FlickrNet.dll
+
+Name: FlickrNet
+Description: Flickr.Net API Library
+Version: @VERSION@
+Libs: -r:${assemblies_dir}/FlickrNet.dll
diff --git a/dev-dotnet/flickrnet-bin/flickrnet-bin-2.2.ebuild b/dev-dotnet/flickrnet-bin/flickrnet-bin-2.2-r1.ebuild
index e4bbed736931..3d5b29527b2c 100644
--- a/dev-dotnet/flickrnet-bin/flickrnet-bin-2.2.ebuild
+++ b/dev-dotnet/flickrnet-bin/flickrnet-bin-2.2-r1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/flickrnet-bin/flickrnet-bin-2.2.ebuild,v 1.3 2009/11/06 16:34:05 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/flickrnet-bin/flickrnet-bin-2.2-r1.ebuild,v 1.1 2010/09/21 12:22:48 pacho Exp $
EAPI=2
MY_PN="FlickrNet"
-inherit mono
+inherit mono multilib
DESCRIPTION="A .Net Library for accessing the Flickr API - Binary version"
HOMEPAGE="http://www.codeplex.com/FlickrNet"
@@ -32,4 +32,11 @@ src_compile() {
src_install() {
egacinstall Release/${MY_PN}.dll ${MY_PN} || die
+
+ # Install .pc file as required by f-spot
+ dodir /usr/$(get_libdir)/pkgconfig
+ sed -e "s:@VERSION@:${PV}:" \
+ -e "s:@LIBDIR@:/usr/$(get_libdir):" \
+ "${FILESDIR}"/flickrnet.pc.in > "${D}"/usr/$(get_libdir)/pkgconfig/flickrnet.pc \
+ || die "sed failed"
}